Subject: RE: Separate LCUP cookie vs replication - was RE: Comments onLCU P draft - opaque cookie

From: Christopher Apple <[email-masked]>
Date: Fri, 6 Jul 2001 12:11:20 -0400

The guidelines I recommended for modifying the document
have been adopted by the document editors. Specifically
about the label/OID, these guidelines indicate that the
document should describe how implementations are to
respond when they encounter labels/OIDs that they do not
natively support or understand. That is quite different
than stating formally in the spec that the labels are
irrelevant. As a co-chair, I wouldn't recommend that
a WG document be considered for IESG Last Call if it had
features explicitly specified, but specified as irrelevant.

Chris Apple
Program Manager - Directory Services
United Messaging Inc.
<http://www.unitedmessaging.com>
<mailto:[email-masked]> 
(V) 610-425-2860

   >-----Original Message-----
   >From: [email-masked] [mailto:[email-masked]]
   >Sent: Friday, July 06, 2001 11:25 AM
   >To: Kurt D. Zeilenga
   >Cc: Christopher Apple; [email-masked]; 
   >'Richard Huber';
   >[email-masked]; [email-masked]
   >Subject: Re: Separate LCUP cookie vs replication - was RE: Comments
   >onLCU P draft - opaque cookie
   >
   >
   >I think the language in our (the LCUP authors') working 
   >version of the draft is sufficient.  As Mark said, the new 
   >version will be
   >out shortly.
   >
   >"Kurt D. Zeilenga" wrote:
   >
   >> Well, my concern is that by labeling a value (the cookie)
   >> which the client should not care about will lead to
   >> interoperability problems as clients will start caring
   >> about a label which shouldn't matter.  As the value of
   >> the cookie matters to the protocol peer which generated
   >> it, the label seems quite pointless to me.  However, as
   >> long as there is language added to the text stating that
   >> the label is irrelevant to the clients implementing this
   >> specification, I can live with it.
   >>
   >> Kurt
   >

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 06 Jul 2001 09:59:25 -0700

At 09:11 AM 7/6/2001, Christopher Apple wrote:
>natively support or understand.

My point is that a client should not care what the
labels/OIDs are.  It should just return the cookie to
the server.  A client which cares will cease to
interoperate with servers providing other labels/OIDs.

Kurt