Subject: Subentries decision - internet draft withdrawn

From: "Ed Reed" <[email-masked]>
Date: Mon, 13 Aug 2001 08:04:38 -0600

Hello, all -

At the IETF in London the working group chairs of the LDUP and (late) LDUPEXT working groups considered the issues raised surrounding the LDAP Subentries draft I've been working on.  Their decision, as related to me, was to ask that the LDUP information model be revised so that object classes defined there for ReplicaSubentry and ReplicaAgreementSubentry no longer are treated as subentries, and that the work on the LDAP Subentries as a standards track document be ended.

So, the draft is hereby withdrawn from work group consideration.

The basis of the decision was that since the Access Control editors have decided not to use LDAP Subentries in their document, and since they were the only other charter-item document in the works that might have referenced the document, there appears to be insufficient interest in generalizing a variant from the X.500 version  of Subentries to be worth continuing in the working group.  There is a strongly felt (and forcefully expressed) feeling among several folks in the working group that there is no reason to "dummy down" the X.500 Subentry specification.  So we won't.

Thank you all for your patience in this matter...

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065
http://www.Reed-Matthews.COM

---

From: "Timothy Hahn" <[email-masked]>
Date: Mon, 13 Aug 2001 11:15:00 -0400

Ed,

Thanks for the summary.

Was the concensus that we not use subentries at ALL with respect to the 
information model - i.e. just use "regular entries" for this information? 
This seems very easy to do at the expense of these entries "showing up" in 
the directory when they otherwise might not be expected.  Of course, 
access controls and/or search filters would probably keep them from 
showing up in most cases anyway.

I'll get to work on re-aligning the LDUP information model draft.

Regards,
Tim Hahn

Internet: [email-masked]
Internal: Timothy Hahn/Endicott/IBM@IBMUS or IBMUSM00(HAHNT)
phone: 607.752.6388     tie-line: 8/852.6388
fax: 607.752.3681

"Ed Reed" <[email-masked]>
08/13/2001 10:04 AM

        To:     <[email-masked]>, <[email-masked]>
        cc: 
        Subject:        Subentries decision - internet draft withdrawn

Hello, all -

At the IETF in London the working group chairs of the LDUP and (late) 
LDUPEXT working groups considered the issues raised surrounding the LDAP 
Subentries draft I've been working on.  Their decision, as related to me, 
was to ask that the LDUP information model be revised so that object 
classes defined there for ReplicaSubentry and ReplicaAgreementSubentry no 
longer are treated as subentries, and that the work on the LDAP Subentries 
as a standards track document be ended.

The basis of the decision was that since the Access Control editors have 
decided not to use LDAP Subentries in their document, and since they were 
the only other charter-item document in the works that might have 
referenced the document, there appears to be insufficient interest in 
generalizing a variant from the X.500 version  of Subentries to be worth 
continuing in the working group.  There is a strongly felt (and forcefully 
expressed) feeling among several folks in the working group that there is 
no reason to "dummy down" the X.500 Subentry specification.  So we won't.

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065

---

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 13 Aug 2001 10:42:25 -0600

Hmm, I wonder how many other drafts refer to it. I know the password policy draft does.

I forsee a whole bunch of 'special' auxilliary objectclasses being defined that carry subtree policy semantics.

>>> "Ed Reed" <[email-masked]> 08/13/01 08:04AM >>>

Hello, all -

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065

---

From: Christopher Apple <[email-masked]>
Date: Mon, 13 Aug 2001 12:51:44 -0400

This was more of a recommendation from the LDAP-related Co-Chairs
for how to proceed with the document than anything like consensus
at this stage. Concensus around our recommendation will have to be
gauged based on mailing list discussion of the revised information
model document.

Chris Apple
Program Manager - Directory Services
United Messaging Inc.
< http://www.unitedmessaging.com <http://www.unitedmessaging.com/> >
< mailto:[email-masked]
<mailto:[email-masked]> >
(V) 610-425-2860

-----Original Message-----
From: Timothy Hahn [mailto:[email-masked]]
Sent: Monday, August 13, 2001 11:15 AM
To: [email-masked]
Subject: Re: Subentries decision - internet draft withdrawn

Ed, 

Thanks for the summary. 

Was the concensus that we not use subentries at ALL with respect to the
information model - i.e. just use "regular entries" for this
information?  This seems very easy to do at the expense of these entries
"showing up" in the directory when they otherwise might not be expected.
Of course, access controls and/or search filters would probably keep
them from showing up in most cases anyway. 

Regards,
Tim Hahn

08/13/2001 10:04 AM 

Hello, all -

At the IETF in London the working group chairs of the LDUP and (late)
LDUPEXT working groups considered the issues raised surrounding the LDAP
Subentries draft I've been working on.  Their decision, as related to
me, was to ask that the LDUP information model be revised so that object
classes defined there for ReplicaSubentry and ReplicaAgreementSubentry
no longer are treated as subentries, and that the work on the LDAP
Subentries as a standards track document be ended.

The basis of the decision was that since the Access Control editors have
decided not to use LDAP Subentries in their document, and since they
were the only other charter-item document in the works that might have
referenced the document, there appears to be insufficient interest in
generalizing a variant from the X.500 version  of Subentries to be worth
continuing in the working group.  There is a strongly felt (and
forcefully expressed) feeling among several folks in the working group
that there is no reason to "dummy down" the X.500 Subentry
specification.  So we won't.

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065

---

From: Christopher Apple <[email-masked]>
Date: Mon, 13 Aug 2001 13:24:26 -0400

Comments below....

Chris Apple
Program Manager - Directory Services
United Messaging Inc.
<http://www.unitedmessaging.com>
<mailto:[email-masked]> 
(V) 610-425-2860

   >From: Jim Sermersheim [mailto:[email-masked]]
   >Sent: Monday, August 13, 2001 12:42 PM
   >To: [email-masked]; [email-masked]; [email-masked]

Here's the list I've found, please post any missing I-D URLs to
the list if you know of them:

http://search.ietf.org/internet-drafts/draft-reed-ldup-inheritance-00.tx
t (indirectly) 

http://search.ietf.org/internet-drafts/draft-ietf-ldup-infomod-03.txt

http://search.ietf.org/internet-drafts/draft-behera-ldap-password-policy
-04.txt

http://www.ietf.org/internet-drafts/draft-ietf-ldapext-acl-model-08.txt

   >
   >I forsee a whole bunch of 'special' auxilliary 
   >objectclasses being defined that carry subtree policy semantics.

That's the idea...

Chris.

   >At the IETF in London the working group chairs of the LDUP 
   >and (late) LDUPEXT working groups considered the issues 
   >raised surrounding the LDAP Subentries draft I've been 
   >working on.  Their decision, as related to me, was to ask 
   >that the LDUP information model be revised so that object 
   >classes defined there for ReplicaSubentry and 
   >ReplicaAgreementSubentry no longer are treated as 
   >subentries, and that the work on the LDAP Subentries as a 
   >standards track document be ended.
   >
   >The basis of the decision was that since the Access Control 
   >editors have decided not to use LDAP Subentries in their 
   >document, and since they were the only other charter-item 
   >document in the works that might have referenced the 
   >document, there appears to be insufficient interest in 
   >generalizing a variant from the X.500 version  of 
   >Subentries to be worth continuing in the working group.  
   >There is a strongly felt (and forcefully expressed) feeling 
   >among several folks in the working group that there is no 
   >reason to "dummy down" the X.500 Subentry specification.  
   >So we won't.
   >

---

From: "Ed Reed" <[email-masked]>
Date: Mon, 13 Aug 2001 20:16:09 -0600

Yeah - the idea is that just making them "regular" entries should cause
the least impact on LDUP InfoMod.  That seems better, now, than referencing
some yet-to-be-written LDAP expression of the X.500 subentry.

It is interesting to note the extent to which subtree refinement of X.500 addresses
one of the LDUP incomplete replica objectives - identification of entries of certain
object classes, right?  But not selected attributes...still need the attribute
filters if we want to support that.

So - We'll just make the SUP TOP instead of ldapsubentries and keep going.  We'll
need to bring the scope discussion from the LdapSubentries doc back into infomod...
but does that mean we need to bring in the administrative model discussion as
a description of the LDUP specific administrative area and it's management...probably.

Oh, we'll probably need to define structure rules to define the intended containment
of the Replica and ReplicaAgreement object classes...can we say Replica entries
are only allowed to be contained by ReplicionContext Aux Classes?

Ed
>>> Christopher Apple <[email-masked]> 08/13/01 10:51AM >>>

Chris Apple

-----Original Message-----
From: Timothy Hahn [mailto:[email-masked]] 
Sent: Monday, August 13, 2001 11:15 AM
To: [email-masked] 
Subject: Re: Subentries decision - internet draft withdrawn

Ed, 

Thanks for the summary. 

Regards,
Tim Hahn

08/13/2001 10:04 AM 

Hello, all -

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065