Subject: Coverage matrix - Requirements vs Model (Architecture) -06.txt version

From: "Ed Reed" <[email-masked]>
Date: Wed, 21 Nov 2001 19:23:21 -0700

For better or worse, here is my take on how the current Model document addresses the current Requirements document requirements.

I've highlighted comments for requirements not addressed or explicitly broken, in a bold type font.

The version of this document that I'm distributing is an Acrobat PDF file.  Free readers are available for as many OS platforms as I think are likely to be needed from www.adobe.com.

The -06 Model document requires more work.  But I also think that some of the directions that the Requirments authors have taken will prove troublesome to the management operations document authors.  We'll see.

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 585 624 2402
http://www.Reed-Matthews.COM
Note:  Area code is 585

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 21 Nov 2001 20:00:36 -0800

>I've highlighted comments for requirements not addressed or explicitly broken, in a bold type font.

I'll comment only on the two which might be viewed as suggesting
changes to the requirements I-D.

G9.1 N/A 

I concur.

G10.  Note that this REQUIRES that changes to RootDSE information be
maintained OUTSIDE of LDUP, either directly via Management Operations,
or as side effects of those Management Operations.

Well, I think it's a matter of properly specify the relationship
between DSA-specific information in the root DSE and replication
policy/state information held elsewhere in non-DSA specific
attributes.

For example, namingContexts is maintained on a DSA-specific basis
but is derived from non-DSA-specific information held elsewhere
in the DIT.  I would think that any replication-specific attribute
added to the root DSE would be DSA-specific but, as needed,
derived from non-DSA-specific information held elsewhere in the
DIT.

I see the G10 as being a very appropriate requirement.  It requires
LDUP not change the meaning of DSA specific.

Kurt