Subject: Re: Adding to the LDAP ACM to a WG charter

From: [email-masked] (Richard V Huber)
Date: Fri, 16 Nov 2001 18:59:10 -0500

I see a number of interoperability issues that the ACM work addresses.

It is difficult to build systems that are directory vendor neutral if
they need to deal with access controls.  Examples include directory
maintenance systems and some types of provisioning systems (systems
that add new users to the directory in situations where access
permissions matter).

And as several others have already noted, it will also be very hard to
have a useful standard replication system without a standard way to
move access control information between systems.

Since LDAPEXT is shutting down, the ACM work needs a new home.  Since
most of the members of LDAPEXT are also part of LDUP, and since the ACM
work is needed for LDUP, LDUP seems like the right place to do it.

Access control is a complicated topic.  I think it needs the benefit of
the technical review a WG will provide.

Rick Huber

PS: If there's any doubt, this email is FOR adding ACM to the LDUP charter!

: From [email-masked] Fri Nov 16 18:31:12 2001
: From: "Chris Apple" <[email-masked]>
: To: "Paul Leach" <[email-masked]>, <[email-masked]>
: Cc: <[email-masked]>
: References: <[email-masked]>
: Subject: Re: Adding to the LDAP ACM to a WG charter
: 
: One of those folks' posting didn't reach me until after I'd already sent out
: that
: particular posting.
: 
: I sort of counted your other posting on the topic somewhere in the middle -
: you didn't
: seem to me to be expressing an objection to adding ACM, but said you thought
: it was
: possible. I'm taking this response of yours to mean that I should count you
: as one of the
: 3 WG members who are objecting to ACM being added to LDUP's charter.
: 
: I'll have to give the archive another pass and see if I missed other WG
: members
: saying yes or no...
: 
: And note that I didn't say we have reached concensus - I said that consensus
: is leaning
: towards adding ACM (or it appeared so at the time).
: 
: Chris.
: 
: Currently self-employed pondering the meaning of life in Olde City,
: Philadelphia, PA, US, Earth
: ----- Original Message -----
: From: "Paul Leach" <[email-masked]>
: To: "Chris Apple" <[email-masked]>; <[email-masked]>
: Cc: <[email-masked]>
: Sent: Friday, November 16, 2001 5:50 PM
: Subject: RE: Adding to the LDAP ACM to a WG charter
: 
: 
: 
: > -----Original Message-----
: > From: Chris Apple [mailto:[email-masked]]
: > Sent: Friday, November 16, 2001 5:00 AM
: > To: [email-masked]
: > Cc: [email-masked]
: > Subject: Re: Adding to the LDAP ACM to a WG charter
: >
: >
: >
: > Thanks. So far, you are the only LDUP WG member
: > to raise such concerns. Which means that concensus
: > is currently leaning towards adding LDAP ACM to the
: > LDUP WG charter. That is clear by looking at the
: > postings on the topic in the mailing list archives.
: 
: I'm sorry, but two other people at least have echoed Kurt's concern.
: Maybe that still means there is concensus, but we'd like to be
: acknowledged as objecting. And as far as I could see, there weren't many
: more than 3 in favor, so I actually question that concensus has been
: reached.
: 
: >
: > However, I am still on the hook to post another
: > charter revision that includes LDAP ACM as a tool
: > to gauge WG concensus on the matter based on a
: > concrete proposal for deliverables.
: 
: That's fair.
: 
: Paul

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 16 Nov 2001 16:24:46 -0800

At 03:59 PM 2001-11-16, Richard V Huber wrote:
>Access control is a complicated topic.

What leads you (and others) believe LDUP WG can achieve
this objective in a reasonable amount of time?

How do you respond to those who believe the LDUP WG
will suffer from the same lack of consensus that LDAPext
faced in attempting this work?

Kurt