Subject: RE: RE: moving access control discussion to LDUP

From: "Chris Apple" <[email-masked]>
Date: Thu, 15 Nov 2001 15:26:54 -0500

At 02:05 PM 2001-11-14, John Strassner wrote:
>So how will the protocol be able to interoperate without a common ACM?

At the level of interoperability this WG is attempting to achieve,
it cannot.  But then, this WG will needs much more than a common
ACM to provide the level of interoperability it is attempting to
achieve.

Chris Apple> I believe you have posted some
suggestions/observations about what the WG might have
to consider related to this in the posting to which John
replied. I'll respond separately to the original posting.
I do believe there is merit in some of what you propose.
Whether this additional security-related work needs to be included
in separate documents or folded into a revision of the ACM
document (if and when it becomes an LDUP deliverable) is something
we should definitely discuss on the list.

IMO, the WG as bitten off more that it can chew and bitting off
more will only cause the WG to choke.

Chris Apple> Opinion noted. It will be considered along with the
rest of the opinions on this matter and WG consensus will be judged
based on the collective hum of the responses.

So, I wonder, what is beyond scope of this working group?

Kurt

Chris Apple> That flavor of comment adds no value to
the list, the WG, the charter, or any deliverable we are
charged with producing. Our ADs will tell the WG if it is
stepping out of bounds, so to speak, with respect to adopting
the ACM work and perhaps adding other deliverables as you
suggested in the posting to which John Strassner replied
with his question. I have heard your objections to adopting
the ACM work as has John. They will be taken into consideration
when John and I discuss consensus around the new charter.
Keep in mind that discussion between Patrik, John, and I has taken
place about the scoping issue related to the ACM work - and that
Patrik, at that time, indicated that he had no objection to it being added
provided that LDAPEXT was truly going to shut down prior to achieving
consensus on it.

Unless a substantial number of other WG members express
concerns similar to yours, John and I will be required as co-chairs to
report to the list that consensus goes against the opinion you have
expressed.

Enough mashed potatoes; its time for some meat:

The WG should not attempt to actively work on technical
specifications that are not a part of the official version of
it. The current version of the charter indicates that in December 2001,
we will re-evaluate the charter. I am simply starting the process now
so that we can clearly understand and get to work on deliverables
tied to a revised charter *in* December rather than starting the process
then. This means that we are clearly, at this time, within the bounds of
what our charter allows us to do. I do not believe, in this case, that
starting on a deliverable earlier than scheduled is a bad thing.

Keep in mind the following:

1) the charter is currently being revised
2) discussion related to the proposed charter took place on the list
3) a number of clarifications and suggestions were received
both publicly and privately
4) I'm revising the document now and will report it to the WG mailing
list for confirmation that I captured everything that made sense to include

Given that we did not know at the time the charter revision was proposed
to the list discussion of the timing with which the LDAPEXT WG intends to
close (before ACM is complete/published as an RFC), we added text
to the charter (to which no objections were raised that I'm aware of)
allowing
the WG to consider whether or not the ACM work should be added to
the charter.

So, speaking as the co-chair currently responsible for revising
the charter proposal, I have decided to extend the original plan
for revising the charter proposal now instead of later, largely
because it is now known that LDAPEXT will not be pursuing
the progression of the ACM document.

Chris Apple

Currently self-employed pondering the meaning of life in Olde City,
Philadelphia, PA, US, Earth

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 15 Nov 2001 14:18:15 -0800

At 12:26 PM 2001-11-15, Chris Apple wrote:
>Kurt wrote:
>That flavor of comment adds no value to the list, the WG, the charter, or any deliverable we are charged with producing.

In writing a charter, discussing and documenting what is beyond
scope of the working group certainly adds value.  I, for one,
cannot figure out what is beyond the scope of this working group.
Your response to one of my previous posts certainly didn't help
clarify matters:
   Since there is nothing explicitly in the charter about
   this, I suppose it would be logical to say that it is
   not explicitly prohibited.
   http://www.imc.org/ietf-ldup/mail-archive/msg01200.html

Kurt

---

From: "Ed Owens" <[email-masked]>
Date: Thu, 15 Nov 2001 16:05:11 -0800

Chris et al;
    I have been silent on this list for some time but since silence
currently counts as acceptance (as it always has) I need to express my
concurrence with Kurt that ACM should not be added to the LDUP charter.
While I follow and understand what the lack of ACM might mean for LDUP cross
vendor implementations I believe it is too much for the WG at this time (and
since LDAPEXT couldn't come to consensus I have doubts whether this WG could
even on a meaningful subset for LDUP).  So add one more voice against adding
ACM to the charter.
        Ed Owens

Edward Owens
Principal Consultant
Noetic Solutions LLC
(925)366-1005
[email-masked]
http://www.noetic.net