Subject: FW: LDUP engineering group on access control

From: "Chris Apple" <[email-masked]>
Date: Wed, 27 Feb 2002 17:32:03 -0500

FYI. Ed Reed will be joining the list of folks below in addressing the
access control needs for LDUP. I would also like to invite Steven Legg
to participate as an active member of the Design Team for LDUP
Access Control since he has chosen to publish a couple of individual
contribution drafts on this topic recently.
 
After much deliberation over language in various charter proposals,
John and I feel that the best way that this topic can be handled
in a revised LDUP WG charter is to replace all details of prior
proposals
related to this topic with text that says we are chartering an official,
WG-endorsed Design Team for LDUP Access Control to come up
with a plan for and possibly draft specifications for the WG to
consider.
The basic notion is that the WG needs to address a minimum
ACM for LDUP implementation interoperability. (Not the exact words
I'll propose, but you get the idea).
 
RFC 2418, covering WG guidelines, supports the creation
of such teams:
 
6.5. Design teams

   It is often useful, and perhaps inevitable, for a sub-group of a
   working group to develop a proposal to solve a particular problem.
   Such a sub-group is called a design team.  In order for a design team
   to remain small and agile, it is acceptable to have closed membership
   and private meetings.  Design teams may range from an informal chat
   between people in a hallway to a formal set of expert volunteers that
   the WG chair or AD appoints to attack a controversial problem.  The
   output of a design team is always subject to approval, rejection or
   modification by the WG as a whole.
 
John and I would like for the Design Team to settle on a "mini-charter"
for 
this work. I plan to include in a revised WG charter proposal, a
milestone
that this group of volunteers will present a proposed "mini-charter"
at the upcoming working group meeting in Minneapolis. This
"mini-charter"
MUST define a scope for the team's work (what you are and are not
seeking to address), and SHOULD include a tentative list of milestones
and
deliverables for the WG to consider. Those deliverables would not be
added
to the WG charter explicitly until consensus is reached that they should
and
the ADs approve such actions. Since I'm still among the unemployed (but
a
few qualified leads in the pipeline lately :), I have the cycles to help
out productively
and would like to be included in the pre-Minneapolis discussions that
the Design
Team for LDUP Access Control has. My schedule is more or less
wide open for conference calls if that's what we'd like to do. Also, I
plan to
be in Minneapolis as early as 3/16 and am largely free to meet
face-to-face
about the topic while in town. Phone contact information for me is
available in
the attached vCard.
 
Design Team on LDUP Access Control membership:
 
Tim Hahn - ([email-masked]) - IBM 
Matt Hirsch ([email-masked]) - NSA 
James Benedict ([email-masked]) - no affiliation given
Ed Reed
Steven Legg (if available)

Chris Apple

[email-masked] 

-----Original Message-----
From: Timothy Hahn [mailto:[email-masked]] 
Sent: Thursday, January 10, 2002 10:36 AM
To: [email-masked]
Subject: LDUP engineering group on access control

Chris, 

Has this engineering group been set up yet? 

From my append to the mailing list, I have heard responses (offering to
participate) from: 

        Tim Hahn - ([email-masked]) - IBM 
        Matt Hirsch ([email-masked]) - NSA 
        James Benedict ([email-masked]) - no affiliation given

Do you know of others? 

Regards,
Tim Hahn

Internet: [email-masked]
Internal: Timothy Hahn/Endicott/IBM@IBMUS or IBMUSM00(HAHNT)
phone: 607.752.6388     tie-line: 8/852.6388
fax: 607.752.3681

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 27 Feb 2002 16:04:13 -0800

Chris,

It is not clear to me what the purpose of this design
team is.  If it sole purpose is to make suggestions
regarding a charter revision, that's fine.

However, a number of your statements imply to me that
this design team is to (or may at its choosing) undertake
LDAP ACM engineering work (including producing I-Ds).
The LDUP WG is not chartered to undertake work in this
area at present.

I ask that you provide a clear terse mission statement
for this design team.

Thanks, Kurt

At 02:32 PM 2002-02-27, Chris Apple wrote:
>in a revised LDUP WG charter is to replace all details of prior proposals
>with a plan for and possibly draft specifications for the WG to consider.
>John and I would like for the Design Team to settle on a "mini-charter" for 
>this work. I plan to include in a revised WG charter proposal, a milestone
>at the upcoming working group meeting in Minneapolis. This "mini-charter"
>seeking to address), and SHOULD include a tentative list of milestones and
>deliverables for the WG to consider. Those deliverables would not be added
>to the WG charter explicitly until consensus is reached that they should and
>the ADs approve such actions. Since I'm still among the unemployed (but a
>few qualified leads in the pipeline lately :), I have the cycles to help out productively
>and would like to be included in the pre-Minneapolis discussions that the Design
>wide open for conference calls if that's what we'd like to do. Also, I plan to
>be in Minneapolis as early as 3/16 and am largely free to meet face-to-face
>about the topic while in town. Phone contact information for me is available in
>the attached vCard.
> 
>From my append to the mailing list, I have heard responses (offering to participate) from: 
>

---

From: "Chris Apple" <[email-masked]>
Date: Thu, 28 Feb 2002 14:09:52 -0500

It is my intent that the members of the Design
Team confer and present a proposal to the WG for
a clear, terse mission statement that would bound
the scope of their subsequent work, should any such
work actually occur in the future. And that in addition,
the Design Team will propose a set of milestones/deliverables
or their own "mini-charter." The WG would then attempt
to achieve consensus on the mission statement and
"mini-charter" in the same way that we deal with any
other discussion topic. Whether or not that consensus
includes adding some or all of those milestones and/or
deliverables to the WG charter is a matter that will
have to be discussed once we have a clear work program
Proposal from the Design Team.

So, I suppose you could indeed say that this Design
Team, for the time being, is merely going to bound
the problem(s) that need to be solved related to Access
Control for LDUP and also to suggest a work program that
may or may not be added to the WG charter at a later
date.

Just so that its really clear, here's what's happening:

1) The Design Team will discuss and document a clear
mission statement (I called it something like
"scope of work" in an earlier e-mail) about
what they are specifically seeking to accomplish
related to addressing Access Control in the Context
of LDUP.

2) The Design Team will discuss and document a proposed
work program that seeks to accomplish the mission defined
in the mission statement.

3) Results from 1) and 2) will be presented to the
WG for consideration at the WG meeting and discussed
further on the mailing list.

4) A revised WG Charter, capturing changes discussed
on the list and during the last WG meeting will be
drafted and posted to the WG Mailing list. It will
include a milestone for the formation of a Design Team
to determine how access control should be addressed as
well as a milestone for their initial report to the
WG with proposals consistent with 1) and 2) above.

5) If a consensus can be achieved while discussion mentioned
in 3) is taking place that we should add the Design Team's
proposal to the WG Charter, we will add the resulting
Design Team mission statement to the WG charter proposal
along with any deliverables/milestones that will be
performed by members of the Design Team going forward.

This process has already started via off-list
e-mail exchange as is typical with Design Teams.

Also, Rick Huber reminded me that he was willing to
be a member of the Design Team as well. It was my
error in omitting his name from the list of volunteers.

Design Team members: please include Rick Huber on
all LDUP Access Control Design Team discussion.

Chris Apple

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]] 
Sent: Wednesday, February 27, 2002 7:04 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: FW: LDUP engineering group on access control

Chris,

Thanks, Kurt

At 02:32 PM 2002-02-27, Chris Apple wrote:
>to participate as an active member of the Design Team for LDUP Access 
>Control since he has chosen to publish a couple of individual 
>John and I feel that the best way that this topic can be handled in a 
>revised LDUP WG charter is to replace all details of prior proposals 
>related to this topic with text that says we are chartering an 
>official, WG-endorsed Design Team for LDUP Access Control to come up 
>consider. The basic notion is that the WG needs to address a minimum 
>ACM for LDUP implementation interoperability. (Not the exact words I'll

>propose, but you get the idea).
> 

milestone
"mini-charter"
and
added
a
the Design
plan to
face-to-face
available in