Subject: Open issues / questions re: Architecture of LDUP

From: "Ed Reed" <[email-masked]>
Date: Fri, 01 Mar 2002 15:54:26 -0700

Hello, all.

In compiling the latest version of the architecture document (draf-ietf-ldup-model-07.txt, just submitted and copied to the list), I tried to keep track of the things I don't know about what we're doing.  Here's a summary...

1) what administrative model will be used for managing replica topology information?  There are three offerings on the table:  a retracted proposal from me with my ldapSubentry definition, Kurt's Subentry schema entry implies certain things that would come from the X.500 admin model, and Steven Legg's description of the X.500 model as adapted for LDAP for use with a Basic or Simple Access Control models.  I hope we'll arrive at a concensus (quickly) to adopt the work Steven's worked on (since my own offering was shot down out of the gate).

2) Replica Context and Replicas with regard to DSAs - is it allowed to define two or more DIFFERENT Replica Contexts for the same portion of the DIT (for instance, one full and the others fractional in different ways)?  Are those different Replica Contexts, or different replica configurations of the same Replica Context?  

3) Depending on your answer to #2, is it permitted (in the information model, for instance) to ever have two or more Replicas of the SAME Replication Context (or more precisely, of all or part of the same subtree of the DIT sharing a common base entry) ON THE SAME DSA?  If so, and if something akin to a presentation address is to be associated with each replica, there must be a way to address them separately when setting up an LDAP connection for an LDUP replication session...how would that be done?

4) Are sparse replicas in or out?  right now, they're out of the architecture, but read-only franctional replicas are in.

5) Is the notion of a Primary replica type dead, or will the Mandatory Replica Management engineering team find a need for one?  I confess that I don't know (yet) whether they have already decided they don't need one, or not.

Comments welcome.

Ed 

=================
Ed Reed
Reed-Matthews, Inc.
+1 585 624 2402
http://www.Reed-Matthews.COM
Note:  Area code is 585

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 01 Mar 2002 13:51:09 -0800

>1) what administrative model will be used for managing replica topology information?  There are three offerings on the table:  a retracted proposal from me with my ldapSubentry definition, Kurt's Su…

I think there are really only two (or one if your proposal is truly retracted).

The description of the X.500 admin model and description of the
subentry mechanism of that model together describe one approach.
A subsequent revision of the subentry I-D (which Steven and I
co-authored) will likely absorb the generic description of the
X.500 model from Steven's X.500 models I-D.

I recommend this WG to build the replication administrative
model upon the framework provided by the X.500 generic administrative
model.

Kurt

---

From: Ryan Moats <[email-masked]>
Date: Fri, 1 Mar 2002 19:24:04 -0600

| 5) Is the notion of a Primary replica type dead, or will the Mandatory
| Replica Management engineering team find a need for one?  I confess that
| I don't know (yet) whether they have already decided they don't need one,
| or not.

I'll jump in here.  To date, I don't think we've seen a need for one, as
our discussions so far have been in terms of "updatable or primary" and
not a case where there's a difference.

Ryan

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 05 Mar 2002 20:32:10 -0800

>2) Replica Context and Replicas with regard to DSAs - is it allowed to define two or more DIFFERENT Replica Contexts for the same portion of the DIT (for instance, one full and the others fractional…

I would argue that all entries within scope of a subentry
define a "area of replication" or "replica context".  (I would
use only the term "area of replication".)  Each subentry
defines one replication agreement.  It may be appropriate to
limit the scope of that agreement to only a pair of replication
peers and possibly even to one replication flow.

>4) Are sparse replicas in or out?  right now, they're out of the architecture, but read-only franctional replicas are in.

Not to further wrapped around terminology, I'd say in.  In
fact, I suggest one use the subentry's subtree refinement
mechanism to define a sparse set of entries to replicate.

Kurt