Subject: Re: Open issues / questions re: Architecture of LDUP

From: "Ed Reed" <[email-masked]>
Date: Fri, 01 Mar 2002 17:05:38 -0700

That's what I thought.  

I concur.

That means that the hierarchical subentry information model will need adaptation, in particular to make explicit the association between a replicationAgreement and the two (or more?) replicas which share it (since without name subordination in the hierarchical subentry scheme, the parent association doesn't exist as one of the referenced replicas).

MRM and INFOMOD authors should take note, and voice objections, if any, soon.

Ed
>>> "Kurt D. Zeilenga" <[email-masked]> 03/01/02 04:51PM >>>
At 02:54 PM 2002-03-01, Ed Reed wrote:
>In compiling the latest version of the architecture document (draf-ietf-ldup-model-07.txt, just submitted and copied to the list), I tried to keep track of the things I don't know about what we're doing.  Here's a summary...
>
>1) what administrative model will be used for managing replica topology information?  There are three offerings on the table:  a retracted proposal from me with my ldapSubentry definition, Kurt's Subentry schema entry implies certain things that would come from the X.500 admin model, and Steven Legg's description of the X.500 model as adapted for LDAP for use with a Basic or Simple Access Control models.  I hope we'll arrive at a concensus (quickly) to adopt the work Steven's worked on (since my own offering was shot down out of the gate).

I think there are really only two (or one if your proposal is truly retracted).

The description of the X.500 admin model and description of the
subentry mechanism of that model together describe one approach.
A subsequent revision of the subentry I-D (which Steven and I
co-authored) will likely absorb the generic description of the
X.500 model from Steven's X.500 models I-D.

I recommend this WG to build the replication administrative
model upon the framework provided by the X.500 generic administrative
model.

Kurt

=================
Ed Reed
Reed-Matthews, Inc.
+1 585 624 2402
http://www.Reed-Matthews.COM
Note:  Area code is 585

---

From: "John McMeeking" <[email-masked]>
Date: Fri, 1 Mar 2002 21:42:34 -0600

I think that the adaptation falls into two areas:
1) a subentry entry that defines an area of replication as an
administrative area with replicaSubentry containing a DN pointer to this
subentry.
2) change replicaSubentry and replicaAgreementSubentry to not be
subentries.  Then these classes can have their existing hierarchical
relationship.
There would be no need for a subtreespecification matching rule -- DN match
works fine.

That said, I need to reread various x.500 specs to make sure my
understanding of administrative area as it applies to LDUP is adequate.

John  McMeeking

                      "Ed Reed"                                                                                                  
                      <[email-masked]        To:       <[email-masked]>                                                     
                      M>                       cc:       <[email-masked]>                                                     
                      Sent by:                 Subject:  Re: Open issues / questions re: Architecture of LDUP                    
                      owner-ietf-ldup@m                                                                                          
                      ail.imc.org                                                                                                

                      03/01/2002 06:05                                                                                           
                      PM                                                                                                         

That's what I thought.

I concur.

That means that the hierarchical subentry information model will need
adaptation, in particular to make explicit the association between a
replicationAgreement and the two (or more?) replicas which share it (since
without name subordination in the hierarchical subentry scheme, the parent
association doesn't exist as one of the referenced replicas).

MRM and INFOMOD authors should take note, and voice objections, if any,
soon.

Ed
At 02:54 PM 2002-03-01, Ed Reed wrote:
>In compiling the latest version of the architecture document
(draf-ietf-ldup-model-07.txt, just submitted and copied to the list), I
tried to keep track of the things I don't know about what we're doing.
Here's a summary...
>
>1) what administrative model will be used for managing replica topology
information?  There are three offerings on the table:  a retracted proposal
from me with my ldapSubentry definition, Kurt's Subentry schema entry
implies certain things that would come from the X.500 admin model, and
Steven Legg's description of the X.500 model as adapted for LDAP for use
with a Basic or Simple Access Control models.  I hope we'll arrive at a
concensus (quickly) to adopt the work Steven's worked on (since my own
offering was shot down out of the gate).

I think there are really only two (or one if your proposal is truly
retracted).

Kurt

=================
Ed Reed
Reed-Matthews, Inc.
+1 585 624 2402