Subject: Re: LCUP issue: sync, then sync and persist

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 04 Sep 2002 07:43:04 -0600

Ah, seems like this could be done with another field on the update
control.

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 09/04/02 12:11AM >>>

At 10:51 PM 2002-09-03, Jim Sermersheim wrote:

>I don't get it... A synchronizeAndPersist session should return the
>complete copy, then drop into the "persist" mode. What am I missing?

A sync to persist transition notification.

>Jim
>
>>>> "Kurt D. Zeilenga" <[email-masked]> 09/03/02 11:50PM >>>
>At 10:23 PM 2002-09-03, Jim Sermersheim wrote:
>>Why is there a suggestion in Section 6 to "perform an initial
>>synchronization...(synchronizeOnly)" and then immediately perform a
>>synchronizeAndPersist session? Why not just perform a
>>synchronizeAndPersist session to begin with?
>
>Because the client has no other way to determine that
>it presently has a complete copy of the DIT fragment.
>
>Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 04 Sep 2002 07:15:58 -0700

>Ah, seems like this could be done with another field on the update

IMO, what's needed is a intermediate response PDU indicating
the end of the synchronize phase and provide a a new cookie.
This not only works when there are no sync events, but also
works when there are persist event occurring during
synchronization.  Calling it an "end of sync phase" marker
doesn't prevent an overlapping "persist" phase.

I have no problem will allowing an overlapping "persist"
phase (as the current I-D does) AS LONG AS it is clear
to the client when it has a complete copy of the DIT
fragment.

Then, we can work on providing the client with a complete
and accurate copy...

Kurt