Subject: Re: LCUP: convergence?

From: "Timothy Hahn" <[email-masked]>
Date: Wed, 11 Sep 2002 16:20:35 -0400

Hi all,

I agree with Kurt on this.

I believe that the LCUP draft needs to clearly state that "eventual
convergence" is the goal and show how the protocol can, indeed, be used to
get there (through appropriate use of synchronize, or synchronizeAndPersist
operations, for example).  Right now, it is unclear how to use the protocol
to get "eventual convergence" in a client.

Also to be covered should be a discussion of when it can be assumed by the
client to be "safe" to use only "persistOnly" and still be sure of gaining
"eventual convergence".

Equally important is a discussion of how clients will know that, with the
request that was made, "eventual convergence" cannot be ensured by the
server. (so that a client can re-formulate its held data and LCUP
request(s).

Regards,
Tim Hahn

Internet: [email-masked]
Internal: Timothy Hahn/Durham/IBM@IBMUS
phone: 919.224.1565     tie-line: 8/687.1565
fax: 919.224.2540

                      "Kurt D.                                                                                                         
                      Zeilenga"                To:       <[email-masked]>                                                           
                      <[email-masked]        cc:                                                                                     
                      g>                       Subject:  LCUP: convergence?                                                            
                      Sent by:                                                                                                         
                      owner-ietf-ldup@m                                                                                                
                      ail.imc.org                                                                                                      

                      09/11/2002 01:18                                                                                                 
                      PM                                                                                                               

In my analysis of the various possible uses of LCUP, I
see a strong requirement for the protocol to provide
"eventual convergence" of the synchronized content.
However, in reviewing the LCUP I-D (see previously
posts for details), I see that it provides for only
"lossy convergence".  That is, LCUP I-D allows the
synchronized content to diverge.  It is not clear to
me that "lossy convergence" meets the needs of the
applications described in the document.

What's convergence level(s) are intended to be
supported by this protocol?

Kurt

---

From: [email-masked] (Mark C Smith)
Date: Wed, 11 Sep 2002 17:43:07 -0400

> to get "eventual convergence" in a client.

I also agree.  This area needs more text and probably protocol changes 
as well.

> client to be "safe" to use only "persistOnly" and still be sure of gaining

The answer may be "never" but some people do not like that answer ;-)

> server. (so that a client can re-formulate its held data and LCUP

Agreed.

-- 
Mark Smith
Netscape Directory Product Development
My words are my own, not my employer's.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 11 Sep 2002 14:56:33 -0700

>The answer may be "never" but some people do not like that answer ;-)

I think it should be noted that 'persistOnly' is not a
synchronization mechanism, but is an change notification
mechanism.

Kurt