Subject: RE: LCUP: rename of baseObject (was something else)

From: "Liben, Michael (GTS)" <[email-masked]>
Date: Wed, 4 Sep 2002 09:30:50 -0400

I would recommend a requery of the object using a persistent value such as a UUID immediately before attempting an update. This would return the 'current' dn of the object and minimize instances where
it has been renamed or deleted.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]] 
Sent: Wednesday, September 04, 2002 2:19 AM
To: [email-masked]
Subject: Re: LCUP: rename of baseObject (was something else)

At 10:36 PM 2002-09-03, Kurt D. Zeilenga wrote:
>At 10:20 PM 2002-09-03, Jim Sermersheim wrote:
>>The scenario I was thinking of is one where the base existed when a
>>persistent LCUP session starts, but later is renamed or deleted.
>
>LCUP should be clear on the expected behavior here...

Client Considerations implies noSuchObject is
returned in this case.  This needs to be detailed
in Section 4 (along with many other protocol
details found in sections 6 and 7).

---

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 04 Sep 2002 07:47:43 -0600

Often, the LCUP client is not the same, thus not aware of the "updater"
and its actions.

>>> "Liben, Michael (GTS)" <[email-masked]> 09/04/02 07:30AM
>>>

I would recommend a requery of the object using a persistent value such
as a UUID immediately before attempting an update. This would return the
'current' dn of the object and minimize instances where
it has been renamed or deleted.