Subject: WG Last Call: LCUP Draft

From: "Chris Apple" <[email-masked]>
Date: Sun, 1 Sep 2002 12:49:17 -0400

The purpose of this message is to initiate the LDUP
working group last call on the LDAP Client Update Protocol
draft.

WHAT DOCUMENT?

The document in last call is:

http://www.ietf.org/internet-drafts/draft-ietf-ldup-lcup-03.txt

WHAT IS A LAST CALL FOR?

The purpose of the working group last call is to ensure
that the working group has reached consensus on the
document, believes that all the known outstanding issues
have been addressed, and is ready to put the document
forward for Proposed Standard status.

During the last call, any comments on the documents are
collected and discussed on the mailing list.

HOW LONG DOES IT LAST?

The last call starts Tuesday, September 3, 2002 and will
Last approximately two weeks.

It will end on Tuesday, September 17, 2002 at 1700 ET.

WHAT'S THE NEXT STEP?

After the last call completes, there are three possible
outcomes:

1) No changes are required and we request our ADs to put
   forward the documents to the IESG for Proposed Standard
   status.

2) Minor changes agreed to on the list are required, and
   the documents are revised. We then ask our ADs to put
   forward the revised documents to the IESG for
   Proposed Standard status.

3) Major issues are raised and no consensus is reached on
   the list. In this case, we discuss things until consensus
   is reached, at which time another working group last call
   will be issued.

Assuming we achieve outcome 1) or 2), and that the ADs
agree with our assessment, the next stop for the documents
is with the IESG. The IESG reads them and may approve the
documents (with or without changes), or send the documents
back to the working group to have major issues addressed.

If the first outcome happens, the documents are put forward
for a two-week last call to the entire IETF, and after
successful completion the documents are published as RFCs
with Proposed Standard status.

If the second outcome happens, we go back and address
the issues, putting the documents forward again when we
believe they're ready.

WHAT SHOULD YOU DO?

You should read the documents, making sure that 1) there
are no problems or deficiencies or outstanding issues that
need to be resolved; and 2) that there are no typos,
formatting problems, grammatical errors, etc.

Any substantive problems you find, you should send to the
list. Any minor problems (typos, etc.) you may send to the
list or just to the authors. If, for some reason, you have
comments you don't want to send to the entire list, you may
send them to me and/or LDUP WG co-chair John Strassner.

Silence means consent.

Read, enjoy, and send your comments in!

regards,
Chris Apple and John Strassner

Chris Apple - Principal Architect

DSI Consulting, Inc.

mailto:[email-masked]

http://www.dsi-consulting.com

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 03 Sep 2002 11:38:50 -0700

A month or so ago, I provided the authors with a laundry
list of technical and editorial comments.  Before I echo
each of these on the list (which I will before the end
of comment period), I like to raise what I consider my
biggest concern.

My biggest concern is that this protocol provide the
client will all the events necessary for it to "synchronize"
update its copy of the fragment of the DIT previously returned
to that which would be returned if the original request would
have been repeated.

In the worst case, a client repeating the original request
may find that the copy "synchronized" by LCUP is MOSTLY changed!

The protocol basically needs not only to send a copy of
all entries which are within scope which have significantly
changed, but also send a list of UUIDs and CSNs of all the
entries which have not changed.  This would not only allows
the client to determine the set of entries which have been
deleted from the fragment, but also determine if an entry
returned but not updated needs to be refreshed.  In which
case, it can request a copy of those entries which it
believes need to be refreshed.  This can be done out of
band with a persist operation.

The persist needs a bit of work as well.  Basically, the
server needs to be required to generate the set of
events necessary for eventual convergence of the client's
copy of the DIT fragment.

Kurt

---

From: "Chris Apple" <[email-masked]>
Date: Tue, 3 Sep 2002 16:56:51 -0400

Please do post the laundry list to the WG mailing list. I want to be in
a position to track all issues
raised shortly after the WG Last Call period is over.

DSI Consulting, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Kurt D. Zeilenga
Sent: Tuesday, September 03, 2002 2:39 PM
To: [email-masked]
Cc: [email-masked]; John Strassner
Subject: Re: WG Last Call: LCUP Draft

Kurt

---

From: "Chris Apple" <[email-masked]>
Date: Tue, 10 Sep 2002 13:51:47 -0400

Thanks for the review and discussion so far.

Per the WG Last Call announcement, the period of review will conclude on
Tuesday, September 17, 2002 at 1700 ET.

After that time, John and I will prepare a comprehensive issues/defects
list, review that with the LCUP document editors, and post to the
mailing list our findings.

I'll post a target date for accomplishing this on Wednesday, September
18, 2002.

DSI Consulting, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Chris Apple
Sent: Sunday, September 01, 2002 12:49 PM
To: [email-masked]
Cc: John Strassner
Subject: WG Last Call: LCUP Draft

WHAT DOCUMENT?

WHAT IS A LAST CALL FOR?

HOW LONG DOES IT LAST?

WHAT'S THE NEXT STEP?

WHAT SHOULD YOU DO?

Silence means consent.

regards,

DSI Consulting, Inc.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 11 Sep 2002 10:18:45 -0700

In my analysis of the various possible uses of LCUP, I
see a strong requirement for the protocol to provide
"eventual convergence" of the synchronized content.
However, in reviewing the LCUP I-D (see previously
posts for details), I see that it provides for only
"lossy convergence".  That is, LCUP I-D allows the
synchronized content to diverge.  It is not clear to
me that "lossy convergence" meets the needs of the
applications described in the document.

What's convergence level(s) are intended to be
supported by this protocol? 

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sat, 14 Sep 2002 18:47:14 -0700

I find the wording used in the document quite confusing.
Namely because it defines a cookie as represent client state,
but is then says it may be sent initially (without value)
to indicating the desired scheme.

I believe the specification would be a lot clearer if the cookie/scheme
were defined as:

  LCUPScheme ::= LDAPOID
  LCUPCookie ::= SEQUENCE {
	scheme          LCUPScheme,
	value           OCTET STRING
  }

and request control was defined as:

  ClientUpdateControlValue ::= SEQUENCE {
      updateType         ENUMERATED {
                               synchronizeOnly         (0),
                               synchronizeAndPersist   (1),
                               persistOnly             (2) },
      sendCookieInterval INTEGER    OPTIONAL,
      scheme		  LCUPScheme OPTIONAL,
      cookie             LCUPCookie OPTIONAL
  }

where scheme may only be specified on initial request to indicate
desired scheme and cookie must be provided on subsequent
requests.

---

From: "Chris Apple" <[email-masked]>
Date: Wed, 18 Sep 2002 17:57:51 -0400

The WG Last Call Period ended yesterday at 1700 ET.

I expect to have an issues list prepared and posted to the list on
Friday, September 20, 2002.

John and I are expecting to do a subsequent WG Last Call on this
document based on the number and
Scope of issues raised on the list. This WG Last Call would take place
after a subsequent version
of the document is published. I'll be looking to the LCUP draft editors
to indicate when that
is feasible after reviewing the issues list to be posted to the WG
Mailing List this Friday.

DSI Consulting, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Chris Apple
Sent: Tuesday, September 10, 2002 1:52 PM
To: [email-masked]
Subject: RE: WG Last Call: LCUP Draft

DSI Consulting, Inc.

-----Original Message-----

WHAT DOCUMENT?

WHAT IS A LAST CALL FOR?

HOW LONG DOES IT LAST?

WHAT'S THE NEXT STEP?

WHAT SHOULD YOU DO?

Silence means consent.

regards,

DSI Consulting, Inc.

---

From: "Chris Apple" <[email-masked]>
Date: Tue, 24 Sep 2002 19:27:56 -0400

Running behind schedule on this. I now expect it will be completed by
this Friday or earlier.

DSI Consulting, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Chris Apple
Sent: Wednesday, September 18, 2002 5:58 PM
To: [email-masked]
Subject: RE: WG Last Call: LCUP Draft

DSI Consulting, Inc.

-----Original Message-----

DSI Consulting, Inc.

-----Original Message-----

WHAT DOCUMENT?

WHAT IS A LAST CALL FOR?

HOW LONG DOES IT LAST?

WHAT'S THE NEXT STEP?

WHAT SHOULD YOU DO?

Silence means consent.

regards,

DSI Consulting, Inc.