Subject: LCUP issue: Need for lcupReloadRequired

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 03 Sep 2002 23:03:12 -0600

Why is this error needed? It seems that if this scenario exists, the
server would simply send the full set of entries, and a new cookie. The
current specification indicates that the client would try to sync,
receive an error, then try to sync again with an empty cookie. Is there
a benefit to the extra step?

Jim

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 03 Sep 2002 22:23:21 -0700

>a benefit to the extra step?

Yes, it tells the client to delete everything it has.  Otherwise
it might be left with entries which should be have been deleted
but were not.

Of course, give that LCUP doesn't ensure this doesn't happen
under success resync is part of my greatest concern.

Kurt