Subject: Re: LCUP: updating cookie when no entries are to be sent

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 03 Sep 2002 21:09:31 -0600

Isn't that what the stateUpdate boolean is used for? Maybe the draft
should instruct the client to not assume that the search result entry
represents a change of any kind

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 09/03/02 08:43PM >>>

I believe LCUP needs to provide a mechanism which
allows the server to send, at any time, a new cookie
to the client without requiring the server to send an
entry.  This is useful in cases where the cookie
the server previously sent is no quite old and
a new cookie would allow more efficient resync
if the session where to be unexpectedly dropped.
In fact, the cookie may be so old to cause a
full sync to occur when no changes would be
necessary if the cookie were updated.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 03 Sep 2002 21:03:31 -0700

>represents a change of any kind

No.  The stateUpdate flag is a control which must be attached
to an entry.  There may be no entries to send.

Kurt