Subject: LCUP: updating cookie when no entries are to be sent

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 03 Sep 2002 19:43:30 -0700

I believe LCUP needs to provide a mechanism which
allows the server to send, at any time, a new cookie
to the client without requiring the server to send an
entry.  This is useful in cases where the cookie
the server previously sent is no quite old and
a new cookie would allow more efficient resync
if the session where to be unexpectedly dropped.
In fact, the cookie may be so old to cause a
full sync to occur when no changes would be
necessary if the cookie were updated.

Kurt

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 03 Sep 2002 23:20:09 -0600

Sorry, yes. This is a subset of the resaons why no entry presently
matches the filter.

The scenario I was thinking of is one where the base existed when a
persistent LCUP session starts, but later is renamed or deleted.

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 09/03/02 11:11PM >>>
At 09:45 PM 2002-09-03, Jim Sermersheim wrote:
>>What if no entry (presently) matches the filter?
>
>Good point. This was a defect in psearch, and hasn't been resolved
yet
>in LCUP. We assumed that in this case, the operation fails with no
such
>entry.

Yikes... noSuchObject should only be used to indicate that the
baseObject of the search request was not located.

Kurt