Subject: LCUP Eventual Convergence, one possible approach

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 31 Oct 2002 10:11:32 -0800

As noted during the LCUP I-D's WG Last Call, there are some
significant eventual convergence issues with the current
LCUP approach.  Jong and I have been experimenting with
LCUP and exploring different approaches to provide eventual
convergence.  We believe that "running code" is necessary
to ensure we standardize a sound approach.

We think we may have workable approach to offer.  However,
the approach is somewhat experimental.  We have not yet convinced
ourselves that it "works" (e.g., we haven't coded it yet).  A
number of complex issues still need to be sorted out.
draft-zeilenga-ldup-sync-00.txt describes the basic approach
we are pursuing.  Your comments are welcomed.

Our I-D is not intended to compete with the LCUP I-D.  It
is provided to further discussions of the LCUP eventual
convergence issues.  It should be noted that there are
likely other viable approaches to providing eventual
convergence.  Our I-D offers one possible approach.  It is
our hope that that the LDUP WG can quickly reach consensus
on approach and then have the LCUP authors run with it.
(We are willing to aid the authors in anyway we can.)

To this end, we ask that sufficient time be allocated at
IETF#55 to discuss LCUP eventual convergence issues, possible
approaches, and next steps.  As these issues are quite
complex, it may advantageous to have some informal
discussions prior to the LDUP session (by telechat if
necessary).

Kurt & Jong

---

From: "Chris Apple" <[email-masked]>
Date: Thu, 31 Oct 2002 16:45:05 -0500

Sounds good to me. We'll plan on discussing it at
the meeting. However, at least some of the LCUP
authors are unable to make it to the meeting. So
we'll have to be especially diligent about posting
a summary of the discussion on this topic to the
WG mailing list. 

Chris Apple - Principal Architect

DSI Consulting, Inc.

mailto:[email-masked]

http://www.dsi-consulting.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Kurt D. Zeilenga
Sent: Thursday, October 31, 2002 1:12 PM
To: [email-masked]
Subject: LCUP Eventual Convergence, one possible approach

Kurt & Jong