Subject: [ledbat] Fwd: New Version Notification for draft-ietf-ledbat-congestion-05.txt

From: Janardhan Iyengar <[email-masked]>
Date: Tue, 10 May 2011 18:35:55 -0400

Dear all,

A new version of the LEDBAT draft is now available online.  We've touched up some text and clarified several points about the algorithm.  We are hoping to do WGLC with this version, so please read and comment as soon as you can.

The major mods to the algo and description are:

1. (Sec. 3.4) We've modified the MIN filter that was being used for current_delays to an unspecified filter.  The main reason was that MIN is NOT a good filter for current_delays, something like an EWMA filter is more appropriate.
2. (Sec. 3.3 and 3.4) We've added text to clarify how a receiver that delays acks (sends acks less frequently than once per data packet) may pack several delay samples in one ack, and we've modified the sender to deal with multiple delay samples in each ack.
3. (Sec. 3.5) Added a definition of the GAIN parameter, and text that separates increase-GAIN from decrease-GAIN.

Other nits:

1. (Sec. 3.2) Added definition of "MSS" to the Preliminaries Section.
2. (Sec. 3.4) Fixed a bug in the cwnd increase/decrease algorithm to include an MSS factor in its computation.

Thanks!
- jana

-------- Original Message --------
Subject: New Version Notification for draft-ietf-ledbat-congestion-05.txt
Date: Tue, 10 May 2011 15:16:42 -0700
From: [email-masked]
To: [email-masked]
CC: [email-masked], [email-masked],	[email-masked], [email-masked]

A new version of I-D, draft-ietf-ledbat-congestion-05.txt has been successfully submitted by Janardhan Iyengar and posted to the IETF repository.

Filename:	 draft-ietf-ledbat-congestion
Revision:	 05
Title:		 Low Extra Delay Background Transport (LEDBAT)
Creation date:	 2011-05-10
WG ID:		 ledbat
Number of pages: 17

Abstract:
    LEDBAT is an experimental delay-based congestion control algorithm
    that attempts to utilize the available bandwidth on an end-to-end
    path while limiting the consequent increase in queueing delay on the
    path.  LEDBAT uses changes in one-way delay measurements to limit
    congestion that the flow itself induces in the network.  LEDBAT is
    designed for use by background bulk-transfer applications; it is
    designed to be no more aggressive than TCP congestion control and to
    yield in the presence of any competing TCP flows, thus limiting
    interference with the network performance of the competing flows.

The IETF Secretariat

---

From: Murari Sridharan <[email-masked]>
Date: Thu, 19 May 2011 21:00:53 +0000

Folks, we are looking to sign off on this fairly soon. This version is good enough to go to WGLC so please send your review feedback to the authors. 

Thanks
M & R

-----Original Message-----
From: Janardhan Iyengar [mailto:[email-masked]] 
Sent: Tuesday, May 10, 2011 3:36 PM
To: [email-masked]
Cc: Mirja Kuehlewind; Murari Sridharan; Rolf Winter ([email-masked])
Subject: Fwd: New Version Notification for draft-ietf-ledbat-congestion-05.txt

Dear all,

Other nits:

Thanks!
- jana

-------- Original Message --------
Subject: New Version Notification for draft-ietf-ledbat-congestion-05.txt
Date: Tue, 10 May 2011 15:16:42 -0700
From: [email-masked]
To: [email-masked]
CC: [email-masked], [email-masked],	[email-masked], [email-masked]

Abstract:

The IETF Secretariat