Subject: Re: [ledbat] New Version Notification for draft-ietf-ledbat-congestion-05.txt

From: Padma Bhooma <[email-masked]>
Date: Wed, 25 May 2011 19:12:51 -0700

I reviewed the latest draft. Thanks for making all the changes and explaining the parameters. I have a few editorial comments:

- In section 4.2.2 second paragraph, the draft suggests that LEDBAT does not induce losses. Even though it is true in most cases, I am not sure if we can conclusively say that. If the queue is smaller than 100ms worth of data, there can be a loss.

- One of the implications of the size of BASE_HISTORY is that a sender will not respond to a change in delay for that many minutes if the change is due to a change in the link or route. I am not sure if it is worth mentioning that .. but I thought I'd bring it up.

-  In section 4.3.3 second paragraph, there is a typo -- "LEDBAT has been been implemented and successfully.." There has to be only one "been" :) 

Thanks,
Padma

> 
> Message: 1
> Date: Thu, 19 May 2011 21:00:53 +0000
> From: Murari Sridharan <[email-masked]>
> To: "[email-masked]" <[email-masked]>,
> 	"[email-masked]" <[email-masked]>
> Subject: Re: [ledbat] New Version Notification for
> 	draft-ietf-ledbat-congestion-05.txt
> Message-ID:
> 	<[email-masked]>
> 	
> Content-Type: text/plain; charset="utf-8"
> 
> Folks, we are looking to sign off on this fairly soon. This version is good enough to go to WGLC so please send your review feedback to the authors. 
> 
> Thanks
> M & R
> 
> -----Original Message-----
> From: Janardhan Iyengar [mailto:[email-masked]] 
> Sent: Tuesday, May 10, 2011 3:36 PM
> To: [email-masked]
> Cc: Mirja Kuehlewind; Murari Sridharan; Rolf Winter ([email-masked])
> Subject: Fwd: New Version Notification for draft-ietf-ledbat-congestion-05.txt
> 
> Dear all,
> 
> A new version of the LEDBAT draft is now available online.  We've touched up some text and clarified several points about the algorithm.  We are hoping to do WGLC with this version, so please read and comment as soon as you can.
> 
> The major mods to the algo and description are:
> 
> 1. (Sec. 3.4) We've modified the MIN filter that was being used for current_delays to an unspecified filter.  The main reason was that MIN is NOT a good filter for current_delays, something like an EWMA filter is more appropriate.
> 2. (Sec. 3.3 and 3.4) We've added text to clarify how a receiver that delays acks (sends acks less frequently than once per data packet) may pack several delay samples in one ack, and we've modified the sender to deal with multiple delay samples in each ack.
> 3. (Sec. 3.5) Added a definition of the GAIN parameter, and text that separates increase-GAIN from decrease-GAIN.
> 
> Other nits:
> 
> 1. (Sec. 3.2) Added definition of "MSS" to the Preliminaries Section.
> 2. (Sec. 3.4) Fixed a bug in the cwnd increase/decrease algorithm to include an MSS factor in its computation.
> 
> Thanks!
> - jana
> 
> 
> 
> -------- Original Message --------
> Subject: New Version Notification for draft-ietf-ledbat-congestion-05.txt
> Date: Tue, 10 May 2011 15:16:42 -0700
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked], [email-masked],	[email-masked], [email-masked]
> 
> A new version of I-D, draft-ietf-ledbat-congestion-05.txt has been successfully submitted by Janardhan Iyengar and posted to the IETF repository.
> 
> Filename:	 draft-ietf-ledbat-congestion
> Revision:	 05
> Title:		 Low Extra Delay Background Transport (LEDBAT)
> Creation date:	 2011-05-10
> WG ID:		 ledbat
> Number of pages: 17
> 
> Abstract:
>    LEDBAT is an experimental delay-based congestion control algorithm
>    that attempts to utilize the available bandwidth on an end-to-end
>    path while limiting the consequent increase in queueing delay on the
>    path.  LEDBAT uses changes in one-way delay measurements to limit
>    congestion that the flow itself induces in the network.  LEDBAT is
>    designed for use by background bulk-transfer applications; it is
>    designed to be no more aggressive than TCP congestion control and to
>    yield in the presence of any competing TCP flows, thus limiting
>    interference with the network performance of the competing flows.
> 
> 
> 
> 
> The IETF Secretariat
> 
> 
> ------------------------------
> 
> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat
> 
> 
> End of ledbat Digest, Vol 29, Issue 4
> *************************************

---

From: Janardhan Iyengar <[email-masked]>
Date: Mon, 30 May 2011 20:23:59 -0400

Hi Padma,

> I reviewed the latest draft. Thanks for making all the changes and explaining the parameters. I have a few editorial comments:

Thanks so much for going through the draft!

> - In section 4.2.2 second paragraph, the draft suggests that LEDBAT does not induce losses. Even though it is true in most cases, I am not sure if we can conclusively say that. If the queue is smal…

Done. Changed to "LEDBAT seeks to avoid losses".

> - One of the implications of the size of BASE_HISTORY is that a sender will not respond to a change in delay for that many minutes if the change is due to a change in the link or route. I am not su…

Good suggestion.  I've added the following text:

"The size of the base_delays list, BASE_HISTORY, SHOULD be 10. If the actual base delay decreases, due to a route change for instance, a LEDBAT sender adapts immediately, irrespective of the value of BASE_HISTORY. If the actual base delay increases however, a LEDBAT sender will take BASE_HISTORY minutes to adapt and may wrongly infer congestion in the meanwhile. A value for BASE_HISTORY is thus a tradeoff: a higher value may yield a more accurate measurement when the base delay is unchanging, and a lower value results in a quicker response to actual increase in base delay."

> - In section 4.3.3 second paragraph, there is a typo -- "LEDBAT has been been implemented and successfully.." There has to be only one "been" :)

Fixed.

If you have any other comments about the algorithm's exposition, good or bad, we'd love to hear it.  As I said earlier, we're hoping to get to WGLC soon, so any positive comments will be helpful as well (esp. since you are implementing LEDBAT).

Thanks again!
- jana

-- 
Janardhan Iyengar
Assistant Professor, Computer Science
Franklin & Marshall College
http://www.fandm.edu/jiyengar