Subject: [ledbat] C-code of ledbat

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 29 Jun 2011 09:35:17 +0200

Hi

Is there any c-code for LEDBAT available ?
I may be interested to make a model for our proprietary wireless (LTE/HSPA) modeling software.
I guess the pseudo code in the draft should do but c-code may be easier to copy-paste

/Ingemar

=================================
INGEMAR JOHANSSON  M.Sc.
Senior Researcher

Ericsson AB
Wireless Area Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com
Visit http://labs.ericsson.com !
=================================

---

From: Dario Rossi <[email-masked]>
Date: Wed, 29 Jun 2011 09:48:48 +0200

Hi Ingemar,

you basically have two options: our open source OpenLedbat [OL] 
implementation and the BitTorrent [BT] one:

     [BT] G. Hazel. uTorrent Transport Protocol library. 
http://github.com/bittorrent/libutp, May 2010.

     [OL] 
http://perso.infres.enst.fr/~drossi/index.php?n=Software.LEDBAT 
<http://perso.infres.enst.fr/%7Edrossi/index.php?n=Software.LEDBAT>

there are a few differences that may let you choose one or the other:

OL replaces /TCP/ congestion control with Ledbat (i.e., is based on TCP 
framing, not uTP one) so it is not compatible with uTP headers unlike BT.

BT implementantion works at the application layer, OL at kernel layer: 
so, OL is transparent w.r.t the application (ie., you can revert to TCP 
later without modyfing the app)

OL not only works as a Linux kernel module, but also as  an ns2 
simulation module, so it may be good for controlled evaluation before 
deployment  (note: though we have checked that the module loads in linux 
and have made limited experiments where it works as expected (e..g., 
yield to tcp, etc.) we have mostly used our code in simulation during 
our research).

I guess you know that both implementation are affected by a latecomer 
issue (we verified it happens in BT http://arxiv.org/pdf/1006.3018v1 in 
a testbed and in OL by n2 simulation)

hope it helps,
D.

On 06/29/2011 09:35 AM, Ingemar Johansson S wrote:
> _www.ericsson.com_
> Visit _http://labs.ericsson.com_ !
> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat

-- 
  Oo    Associate Professor
   >     TELECOM ParisTech
  ~     (formerly ENST)

mail:  [email-masked]
phone: +33.1.4581.7563
fax:   +33.1.4581.7158
web:   http://www.enst.fr/~drossi