Subject: Re: [ledbat] WG last call on draft-ietf-ledbat-congestion-08

From: Padma Bhooma <[email-masked]>
Date: Tue, 11 Oct 2011 16:39:59 -0700

Hi,

I reviewed the latest draft and I have few comments on the latest changes. A receiver may have to echo the remote timestamp to allow for computation of RTT which it can use for computing CTO. It might be useful to mention that the sender is supposed to retransmit sent data or transmit new data to restart the ACK clock.

Other than the comments above I think the algorithm is ready for adoption.

The implementation of LEDBAT algorithm that was done as a TCP Congestion control module in Mac OS X is available at the following link:
http://opensource.apple.com/source/xnu/xnu-1699.22.81/bsd/netinet/tcp_ledbat.c

Thanks,
Padma

---

From: Rolf Winter <[email-masked]>
Date: Fri, 14 Oct 2011 18:07:35 +0000

This is awesome news. Have you done measurements with the implementation that you can share?

On 12.10.2011, at 01:40, "Padma Bhooma" <[email-masked]> wrote:

> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat

---

From: Padma Bhooma <[email-masked]>
Date: Tue, 18 Oct 2011 22:00:16 -0700

We have done measurements to see how LEDBAT will behave on wireless links under different kinds of network conditions. Our main
emphasis was to see improvement in response time and throughput for a competing flow when there is a LEDBAT upload in 
progress compared to a standard TCP flow in progress. 

For instance, the following graph shows how web page load times to different websites changed when a standard TCP upload (blue)
or LEDBAT (green) or no upload flow (yellow) was in progress to another host. The numbers with LEDBAT are very close to having
no upload and they show a huge improvement in response time. The Y-axis is page load times in milliseconds.

Here is another graph for similar measurements on 3G:

Another important goal for LEDBAT is to make sure that a LEDBAT flow will yield to a standard TCP flow when they have to share 
the link. Here is a graph to show how two LEDBAT flows (Flow A and Flow B marked as bk) yielded to another loss-based TCP flow:

Overall, we have observed that using LEDBAT as a congestion control algorithm improves response time for other 
applications which is very desirable in some scenarios.

Thanks,
Padma