Subject: RE: [lemonade] Re: IMAP as submit server and SPAM

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Tue, 10 Jun 2003 12:01:26 -0500

Comparing the two options in light of the Lemonade requirements for efficiency over costly, high-latency links.

Using SMTP-Submit, 

1) Client requests a hash-token for a body part or message of interest from existing IMAP connection. (one round trip)

2) Client opens new TCP session to SMTP-Submit server (one round-trip)

3) Initiates SMTP protocol, determine capabilities, and authenticates to Submit server (three round trips)

4) Client sends message to submit server (about two round trips using command pipelining)

5) Client closes SMTP (1 round-trip)

Each wireless round-trip is about 100-150 ms... for a network-induced "extra" latency of about a second.  Extra latency if the client has to wait for the submit server to resolve the references before providing the 200 OK response to the DATA or BDAT for the submission.

The open of TCP and authentication also requires sending of extra data... maybe two hundred extra bytes or so vs. using an existing authenticated session. (extra $$)

Using IMAP-Submit 

1) Client posts message to outbox, client annotates message with SMTP envelope in pipeline, receives status in response (1 round trip)
	
Greg V.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Tue, 10 Jun 2003 10:39:06 -0700 (Pacific Daylight Time)

> Comparing the two options in light of the Lemonade requirements for efficiency over costly, high-latency links.

You've given an argument for creating a better submit protocol than SMTP,
but not for making IMAP be that submit protocol.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade