Subject: [lemonade] Wireless latencies

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Wed, 11 Jun 2003 09:50:34 -0500

My earlier message was incorrect.  Below I suggest an average RTT of abount 100 ms, or a simple message submission time using SMTP-submit of about 1 second.  My measured experience using a CDMA data network has an average RTT of 1200 milliseconds (100 samples), or about 10 seconds to send a short message using a separate SMTP connection, or about 1-2 seconds using an existing IMAP connection.  There is good bandwidth at that RTT if the app uses it effeciently.  This longer RTT is consistent with other literature I have seen on the subject.

My appologies for spreading mis-information.

Greg V.

-----Original Message-----
From: Vaudreuil, Greg M (Greg) [mailto:[email-masked]]
Sent: Tuesday, June 10, 2003 12:01 PM
To: IETF LEMONADE (E-mail)
Subject: RE: [lemonade] Re: IMAP as submit server and SPAM

Comparing the two options in light of the Lemonade requirements for efficiency over costly, high-latency links.

Using SMTP-Submit, 

1) Client requests a hash-token for a body part or message of interest from existing IMAP connection. (one round trip)

2) Client opens new TCP session to SMTP-Submit server (one round-trip)

3) Initiates SMTP protocol, determine capabilities, and authenticates to Submit server (three round trips)

4) Client sends message to submit server (about two round trips using command pipelining)

5) Client closes SMTP (1 round-trip)

Each wireless round-trip is about 100-150 ms... for a network-induced "extra" latency of about a second.  Extra latency if the client has to wait for the submit server to resolve the references before providing the 200 OK response to the DATA or BDAT for the submission.

The open of TCP and authentication also requires sending of extra data... maybe two hundred extra bytes or so vs. using an existing authenticated session. (extra $$)

Using IMAP-Submit 

1) Client posts message to outbox, client annotates message with SMTP envelope in pipeline, receives status in response (1 round trip)
	
Greg V.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 11 Jun 2003 13:21:33 -0400

Hi Vaudreuil,,

--On Wednesday, June 11, 2003 9:50 AM -0500 "Vaudreuil, Greg M (Greg)" 
<[email-masked]> wrote:

| My earlier message was incorrect.  Below I suggest an average RTT of
| abount 100 ms, or a simple message submission time using SMTP-submit of
| about 1 second.  My measured experience using a CDMA data network has an
| average RTT of 1200 milliseconds (100 samples), or about 10 seconds to
| send a short message using a separate SMTP connection, or about 1-2
| seconds using an existing IMAP connection.  There is good bandwidth at
| that RTT if the app uses it effeciently.  This longer RTT is consistent
| with other literature I have seen on the subject.

And what if your SMTP submit server and smtp client were designed to keep 
the SMTP connection open for long periods of time, as is done for IMAP? 
That would eliminate the startup costs of SMTP (auth + tls), but not the 
RTT's for MAIL FROM/RCPT TO etc (though pipelining could reduce that). i.e. 
Isn't it possible with minor changes to get SMTP performance to be much 
better than it is now, even without considering the issues of expanding 
content? That would benefit not only wireless devices but potentially all 
SMTP clients. It would also level the playing field (wrt latency) when it 
comes to deciding where the expanding content submit should be (IMAP vs 
SMTP).

-- 
Cyrus Daboo