Subject: [lemonade] Comments on "IMAP Submit without Download Draft"

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Mon, 6 Oct 2003 22:05:45 +0530

Hello Gellens,

I'm Madan from Hewlett-Packard, India.

I'm new to this group. I went through your draft. 

I understand the defintion of Push and Pull 
approach:
They differ in who initiates the content 
transfer, whether it is server ( Push ) or
Message submission agent ( Pull ).

I seek/have few clarifications/recommendations on this draft.  

1. In the section 4.2.1 IMAP pull overview, 

   "The BURL extension should advertise what type of URLs it supports."

   I'm not sure how it would advertise. During EHLO 
   phase ? Pls clarify.

2. Its also mentioned thatcommands BURL/GENURL/GETURL Command 
   would be added. I'm not clear about where these commands will be
   added : in the SMTP extension or IMAP extension ?

3. We may have a general command URL and arguments to URL command 
   would differentiate B/GEN/GET. This would be more generic.

4. In the draft, Push , Pull method are discussed seperately. Did 
   we think of combined version. I could not find the neccessity of
   this combined version where the server would also push as well as 
   the message submission would pull the data from Server. We can 
   analyze the PushPull approach and document them also.

I'm not sure whether these items were already discussed or not. If these
had already been discussed, could you please redirect to the point where
I can get gist of these itesm.

Please let me know your comments.

Thanks and Regards,
MG

	**************************
	Madan Ganesh Velayudham
	[email-masked]	
	+91-80-205-3108
	**************************
	+HP/STSD/Internet Services
	Bangalore, India
	
	Everything is possible

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Thu, 9 Oct 2003 20:00:23 +0530

Hi Gellens,

	Could you please share your comments.

	Thanks and Regards,
	MG

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Madan Ganesh Velayudham
Sent: Monday, October 06, 2003 10:06 PM
To: [email-masked]
Cc: [email-masked]; 'Madan Ganesh V'
Subject: [lemonade] Comments on "IMAP Submit without Download Draft"

Hello Gellens,

Thanks and Regards,
MG

	Everything is possible

_______________________________________________
lemonade mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Fri, 17 Oct 2003 12:11:31 +0530

>    analyze the PushPull approach and document them also.

	No comments ????

	MG

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Madan Ganesh Velayudham
> Sent: Thursday, October 09, 2003 8:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [lemonade] Comments on "IMAP Submit without 
> Download Draft"
> 
> 
> Hi Gellens,
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Madan Ganesh Velayudham
> I'm not sure whether these items were already discussed or 
> not. If these had already been discussed, could you please 
> redirect to the point where I can get gist of these itesm.
>

---

From: Randall Gellens <[email-masked]>
Date: Fri, 24 Oct 2003 12:47:15 -0700

Sorry for the delay (I've been totally swamped and on constant travel 
for the past few weeks)

>  Message submission agent ( Pull ).

The key difference is in which *server* performs the submission: the 
Submit server or the IMAP server.

>     I'm not sure how it would advertise. During EHLO

Yes, that would be the likely method: the EHLO response would include 
BURL followed by a list of URI schemes perhaps including the domains 
that were trusted.  The draft included an example of this:
	250-BURL imap://trusted-host.example.com/

>     added : in the SMTP extension or IMAP extension ?

BURL would be an SMTP (actually, a Submission, not SMTP) extension.
GENURL and GETURL would be IMAP extensions.

>     would differentiate B/GEN/GET. This would be more generic.

GENURL requires that the client be authenticated.
GETURL does not require any authentication; the URL includes 
authorization.  Hence it may be cleaner from a security point of view 
to keep these commands separate.  BURL, as a Submit extension, is in 
a separate protocol and hence separate name space anyway.

>     analyze the PushPull approach and document them also.

My initial reaction to a combined mechanism would be that it would 
give us the negatives of each, plus adding multiple ways to 
accomplish the same thing.  I don't see much point.  Can you explain 
why this would be a good approach?

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Any smoothly functioning technology will be
indistinguishable from a rigged demo.  --Isaac Asimov

---

From: "Madan Ganesh Velayudham" <[email-masked]>
Date: Mon, 27 Oct 2003 23:20:29 +0530

Gellens,

	Thanks for your detailed response.

	In India, this week was a festival week.

> Submit server or the IMAP server.

	I understand now better.
> 	250-BURL imap://trusted-host.example.com/

	Thanks for the clarification.

> BURL would be an SMTP (actually, a Submission, not SMTP) 
> extension. GENURL and GETURL would be IMAP extensions.
> 
> >

	Now, I clearly feel the difference.

> why this would be a good approach?

	My initial assumption on this was the each of them share their
advantages.
	Now I will have rethink about it and let you know ASAP.

	+MG

> 
> >
> >  I'm not sure whether these items were already discussed or not. If 
> > these  had already been discussed, could you please redirect to the 
> > point where  I can get gist of these itesm.
> >