Subject: [lemonade] FW: 58th IETF Meeting minutes : LEMONADE - Nov 10

From: "Eric Burger" <[email-masked]>
Date: Thu, 4 Dec 2003 09:46:25 -0500

Is anyone awake?  I'm certainly not :-(

Looking over the list archives, I saw my posting asking for comments to the minutes.  However, NO ONE NOTICED I DIDN'T POST THE MINUTES!

Let's call this a final call on the minutes.  Please look over and send any comments by December 15.

Great thanks go to Madan for taking notes!

-----Original Message-----
  Nov 10 2003 - Monday - 1.00pm - 3.00pm
 + Agenda was described as the starting item by Glenn
 + Goals of lemonade by Glenn
   - Describes Uses cases and possible scenarios.
   - On context and motivation 
   - De-emphasize on the requirement aspect
 + MMS Mapping by Randell
   - Update to the existing draft would be "Mapping of
delivery of msgs in MMS world and eMail world"
 + IMAP Push/Pull started by Glenn
   - After the presentation, decision to be made on
which approach to go.
 + Submit without download by Randell
   - Depending on who is the activie entity IMAP Push
and Pull are differentiated, ie., whether IMAP server
or the Submit server
   - Various alternates mechanism by which IMAP PUSH
can be done were presented.
      * Submit Intrinsically
        Submit through IMAP
        Notes :
        Queueing of messages
        Generate DSNs
        Relaying
        Like Sendmail functionality in IMAP    
      * Proxy method
        Redendency in operation
        Issues in athentication/Authorization
        Complexity
        Administrationissues
    - Various alternate mechanism by which IMAP PULL
can be done were presented.
      * Submit server access IMAP for messages
      * Per-Mailbox access keys
      * URL includes time/role/user and signatures
using mailbox secrets.
    - IMAP COMPOSE
      Resolves many issues
      Independent of PUSH and PULL
    - URL AUTH
      Expiry time/User identity/Role identity were
described.
  + URL Auth by Chris and Mark
    One of the pull method.
    Changes :
       Authid and Authrole are included
       HMAC-MD5
    Upcoming changes :
       Generate the secret key on demand.
       Anonymous access ( Autherization without
authentication )
       Hash function
       Default configuration

    There was a long discussion oon URL AUTH, 
    - When the secret should be generated. 
    - Who creates the Ticket, Client or Server. Ans :
Client
    - Round trip in getting the tickets
    - To be decided : Secrets per mailbox or per user.
    - Specify both mechanism in the document.

  + Scalable mail environment by Chris:
     If the message store, outbound MTA and inbound
MTA are seperated, significant performance boost was
observed during his experimentation.
    
    - Security concerns in URLAUTH were discussed :
      * TLS Protection
      * Should not store URL without protection.
    - Where the queue should be, is not specified.
    - Document should be free from assumptions

  + IMAP COMPOSE by Pete
    - Simplifies other uses.
  + Decision on Which way 2 go : PUSH Vs PULL
    Currently we dont have enough technical details to
make a decision
    Before deciding, deployment cost should be
considered. Make the changes in one place or two
places. Arugment was that in Pull method, both IMAP
and submit server should be touched.
    Concentrate on this (email)specific problem and
work on a solution. Dont try to get a generic solution
righ now.
    Current specificatoin impact on Scalable mail were
desribed.
   NOTE: There should be a revisions of COMPOSE, Push
and Pull method drafts by Dec 17. After which the
decision on which method to follow will be decided.
  + IMAP4 Profile
  + S2S notification by Gev
    documents out-of-scope is descibed :
      subscription
      Notification service.
  + What it does :
      User identifcation
      Server notification service
      Store and Forward
      Reliablity
      Event ordering ( Queue / Time stamp ) 
      Dynamic structure ( Structure should be dynamic
with respect to the notification request )
      Security
      Should extensible enough to take care of end-end
notification in future

    Discussions :
     - this draft is not listed on the work group
items but it was sent to mailing list
     - Requirements were not clear
       Explicit boundary should be defined
       Structures
       Semantics required
       Event naming required

    Milestones :

    Jan04 : Goals, S2S, Streaming multimedia
    Apr04 : Forward without download documents 
    Jun04 : Profile for Mpbile devices
    Jul04 : Translation to other msg systmes.

   Milestones should be granular.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Madan Ganesh Velayudham <[email-masked]>
Date: Thu, 04 Dec 2003 20:44:55 +0530

>Looking over the list archives, I saw my posting asking for comments to the minutes.  However, NO ONE NOTICED I DIDN'T POST THE MINUTES!
Since this was my first IETF, i was in an assumption that Minutes will 
be kept in some URLs :-)

>Great thanks go to Madan for taking notes!
Welcome !

Cheers, MG

---

From: Randall Gellens <[email-masked]>
Date: Fri, 5 Dec 2003 10:38:21 -0800

Minor corrections:

>  delivery of msgs in MMS world and eMail world"

The biggest change in the pending update is the addition of mapping 
between delivery and disposition reports in the MMS and Email worlds.

>         Anonymous access ( Autherization without

I don't think anonymous access is an upcoming change, it's been a 
(the?) primary element of URL AUTH from the beginning.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
"SF Public Defender: Reasonable Doubt at a Reasonable Price" --Seen on
back of jacket worn by P-D staffer, as reported by Herb Cain in Chronicle

---

From: Marshall Rose <[email-masked]>
Date: Thu, 4 Dec 2003 09:01:32 -0800

> Looking over the list archives, I saw my posting asking for comments to the
> minutes.  However, NO ONE NOTICED I DIDN'T POST THE MINUTES!

sorry, i thought you were being post-ironic.
    
/mtr