Subject: RE: [lemonade] Comments on PUSH and PULL drafts

From: Mark Crispin <[email-masked]>
Date: Tue, 2 Mar 2004 16:10:40 -0800 (Pacific Standard Time)

On Tue, 2 Mar 2004, Vaudreuil, Greg M (Greg) wrote:
> Can you describe some mobile client cases that would be precluded?  I 
> was assuming the credentials for access and submission were the same....

Consider a public/group access IMAP server where you don't have an 
individual account.  You can choose to preclude mobile client use with 
such servers, but you need to recognize that you are doing that.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Tue, 2 Mar 2004 17:59:05 -0600

Can you describe some mobile client cases that would be precluded?  I was assuming the credentials for access and submission were the same....

I am also in favor of the simplifying assumption that the submission server is associated with the IMAP store from which the content is being retrieved.  I know that may not be the general case for full-featured desktop clients, but it seems reasonable given our requirement to support limited capability clients.  This restriction makes simpler the authentication of the submit server to the IMAP store, an important security requirement for some.... (Those who don't trust authorization without authentication)

Maybe I am mixing "Lemonade profile" requirements with the requirements for the underlying extensions... the clearly the Lemonade profile can be more restrictive. (I believe the profile is charter deliverable #3)

Greg V.

-----Original Message-----
From: Mark Crispin [mailto:[email-masked]]
Sent: Wednesday, March 03, 2004 8:47 AM
To: Vaudreuil, Greg M (Greg)
Cc: Rob Siemborski; Marcus D. Leech; [email-masked]
Subject: RE: [lemonade] Comments on PUSH and PULL drafts

On Tue, 2 Mar 2004, Vaudreuil, Greg M (Greg) wrote:
> A quibble... I view the IMAP server in the push model to be the submit 
> server... no reason to pass credentials to a subsequent submit server, 
> the user is already authenticated.

That still presumes that credentials to access mail are equivalent to 
credentials to post mail.  That's not always the case now.  If mobile 
clients make that a requirement, that will limit the cases in which mobile 
clients can be used.

-- Mark --