Subject: [lemonade] Working Group Last Call on URLAUTH

From: Mark Crispin <[email-masked]>
Date: Tue, 19 Oct 2004 08:35:05 -0700 (PDT)

Draft -03 of URLAUTH is almost ready for Working Group Last Call.  There 
is one point for discussion remaining:

;;; Earlier versions of this document had access identifiers for "any
;;; authorized user" and anonymous.  These were not needed for Lemonade
;;; submit-without-download and were removed.  Should something of this
;;; nature be put back as extensions?

That is, the "access" rule in the Formal Syntax would have two more rules, 
"authuser" and "anonymous".  Whether or not the server actually allows 
this would depend upon server policy.

I feel that this would make URLAUTH more useful, but since these are not 
necessary for Lemonade perhaps these should wait until there's a URLAUTH 
extensions document that also adds other mechanisms.

I'd like a WG decision on this point, and then we're ready for Last Call!

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: [email-masked]
Date: Fri, 22 Oct 2004 06:05:31 -0500

> -----Original Message-----
> From: ext Mark Crispin [mailto:[email-masked]]
> Sent: Thursday, October 21, 2004 3:09 PM
...
> I think that you may have misunderstood authuser.  Authuser restricts 
> access to authorized users of the IMAP server.  In other words, the 
> "organization" for authuser is the "set of individuals who 
> have accounts 
> on the IMAP server."

Thank You. This clarifies things nicely.

Mike