Subject: Re: [lemonade] Media Conversion

From: Lyndon Nerenberg <[email-masked]>
Date: Fri, 01 Oct 2004 11:42:13 -0700

--On 2004-9-27 12:18 PM -0400 Eric Burger <[email-masked]> 
wrote:

> Content adaptation could be added to IMAP URL spec.

Eric, do you have a strawman proposal for how this would be done? I 
would really like to look at this before I try to figure out make 
Channel deal with conversion.

What appeals to me about doing this in the IMAP URL spec is that it 
would be applicable to more than just the Channel case. Conversion is 
useful in and of itself, and making it available in the general case is 
a much better design.

--lyndon

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Fri, 1 Oct 2004 15:15:03 -0500

The strawman discussed briefly in San Diego was to construct a new, multi-purpose data fetch protocol that included a way to discover and request media conversion.  The idea was this capability, using the URLAUTH infrastructure, would be generally useful outside of messaging.   This woould work something like "fetch this IMAP content specified in this URLAUTH and convert it into a small jpeg for me".  Some have ideas about extending HTTP for that role given other initiaves to support mobile browsers.

There was also a contingent of folks interested in a mechanism within IMAP proper for cases of things that could be downloaded as objects rather than streamed, or to save a transport channel.  The primary objection to this approach was the implied plug-in conversion infrastructure required for an IMAP server.   The out-of-band retrieval (channel++) mechanism seemed to avoid burdening the IMAP server, being ammenable to things like streaming accelleration, and being more reusable across the applications domain.

My recollections ready for augmentation.

Greg V.

-----Original Message-----
From: Lyndon Nerenberg [mailto:[email-masked]]
Sent: Friday, October 01, 2004 2:42 PM
To: Eric Burger; [email-masked]
Subject: Re: [lemonade] Media Conversion

--lyndon