Subject: [lemonade] Target directory for CATENATE in forward without download

From: [email-masked]
Date: Fri, 8 Oct 2004 09:16:45 -0500

In an actual implementation of forward without download in what folder did the authors envision the temporary message created by CATENATE be stored?

I realize the drafts are written in such a way as to allow any folder to be used, which seems totally correct to me. Should the target folder be a special folder the IMAP server creates for this purpose? Maybe each client creates a special folder? Should the user see this transient message in the folder?

In a way this is a server side Outbox folder, but only for certain messages.

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Fri, 8 Oct 2004 21:12:34 -0700 (Pacific Daylight Time)

On Fri, 8 Oct 2004 [email-masked] wrote:
> In an actual implementation of forward without download in what folder 
> did the authors envision the temporary message created by CATENATE be 
> stored?

I suggest that this name be defined by the client, although there should 
be a convention defined for clients that are willing to cooperate.

I suggest that the name *NOT* be OUTBOX or "Sent Items".

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 12 Oct 2004 13:38:55 +0100

Mark Crispin wrote:

>> In an actual implementation of forward without download in what 
>> folder did the authors envision the temporary message created by 
>> CATENATE be stored?
>
> I suggest that this name be defined by the client, although there 
> should be a convention defined for clients that are willing to cooperate.

IMHO, any such convention should be exposed in NAMESPACE command.

> I suggest that the name *NOT* be OUTBOX or "Sent Items".

This can be something like "Drafts" and messages are moved to Outbox 
when they are sent.

An alternative is to just mark a catenated message with a special flag 
(or even \Draft?): a smart client will be able to deal with any such 
message no matter which mailbox it is in.

Alexey

---

From: Cyrus Daboo <[email-masked]>
Date: Sat, 09 Oct 2004 12:40:26 -0400

Hi Mark,

> be a convention defined for clients that are willing to cooperate.

If you want proper interop between clients then really the server needs to 
advertise a name that all clients can pick up. If we want to do that then I 
suggest that the name be an item returned in the NAMESPACE response using 
the extension options for NAMESPACE, e.g.:

* NAMESPACE (("" "/" "X-LEMONADE-OUTBOX" ("LEMONADE-OUTBOX"))) NIL NIL

This does not have to be a requirement, merely a hint to clients that want 
interoperability.

-- 
Cyrus Daboo