Subject: [lemonade] Comments about CATENATE-02

From: Alexey Melnikov <[email-masked]>
Date: Thu, 14 Oct 2004 00:06:05 +0100

>4.  Response Codes
 >
 >   When a CATENATE command fails it may return a response code that
 >   describes a reason for the failure.

I think this should be changed to:

   When a CATENATE command fails it SHOULD return a response code that
   describes a reason for the failure. Two possible response codes are 
described below,
   however other response codes are also possible.

i.e. we want to encourage detailed error reporting.

 >5.  Formal Syntax
 >
 >   The following syntax specification uses the Augmented Backus-Naur
 >   Form (ABNF) [6] notation.  Undefined elements are defined in the
 >   formal syntax of the ABNF [6], IMAP [1], and IMAP URL [2]
 >   specifications.
 >
 >   catenate = "CATENATE" SP mailbox [SP flag-list] [SP date-time]
 >                       1*(SP (literal / imapurl))
 >
I think the document should extend the resp-text-code non-terminal 
defined in RFC 3501, i.e. add

   resp-text-code =/ badurl_response_code / toobig_response_code

 >   badurl_response_code = "BADURL" SP imapurl
 >
 >   toobig_response_code = "TOOBIG"

Alexey

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Pete Resnick <[email-masked]>
Date: Sat, 16 Oct 2004 11:40:22 -0500

On 10/14/04 at 12:06 AM +0100, Alexey Melnikov wrote:

>    describes a reason for the failure. Two possible response codes 
>are described below,

You will note that I have avoided citing RFC 2119 up to this point. 
RFC 2119 imperatives are *not* to be used to "encourage" anything 
that does not affect interoperability. I'd really prefer to leave it 
as-is.

>defined in RFC 3501

Done.

pr
--
Pete Resnick <http://www.qualcomm.com/~presnick/>
QUALCOMM Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sat, 16 Oct 2004 22:49:27 +0200

> that does not affect interoperability. I'd really prefer to leave it 

Right. We may want to encourage detailed error reporting, but that has 
nothing to do with CATENATE and everything to do with IMAP in general.

Arnt

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 18 Oct 2004 17:38:13 +0100

Pete Resnick wrote:

> RFC 2119 imperatives are *not* to be used to "encourage" anything that 
> does not affect interoperability. I'd really prefer to leave it as-is.

More precise error reporting simplifies debugging and error handling. It 
doesn't affect interoperability directly.

When I see "SHOULD" in a document I usually think "this is pretty 
important, I better implement it". Otherwise I am more likely to ignore it.
I guess this is just me.

Alexey