Subject: [lemonade] Reconnect-01 Problems

From: [email-masked]
Date: Mon, 18 Oct 2004 06:13:30 -0500

The problem that needs to be optimized for a mobile client is the act of synchronizing. So I see two broad issues with reconnect:

1) It is not focused on the problem as I see it. There is no need to worry about folding in SELECT with LOGIN because these are not issues. The real issue is the time it takes for a set of folders with an unpredictable number of mail messages to synchronize. The draft imap-disc mentions an algorithm for server-to-client synchronization that is sensitive to both M and N where M is the number of folders and N is the number of messages in a folder. Mobile clients are more sensitive to the combination of M and N.

2) It does not address the multiple folder problem. While INBOX may be of special interest it is not the only folder of interest. 

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 18 Oct 2004 14:55:32 +0200

It sounds as if the condstore extension addresses your needs much better 
than reconnect. Could you have a look at what condstore can do for you?

Arnt