Subject: RE: [lemonade] RE: Comments about CLEARIDLE

From: [email-masked]
Date: Mon, 8 Nov 2004 08:31:44 -0600

> -----Original Message-----
> From: ext Alexey Melnikov [mailto:[email-masked]]
> Sent: Monday, November 08, 2004 8:40 AM
...
> Speaking as a server implementor: the choice of allowing 
> notifications 
> from multiple mailboxes has deep impact on server implementations.

Why?

...
> So, apart from the syntax, there is no difference between 
> your \Renamed 
> proposal and my REFERRAL proposal.

Agreed

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 08 Nov 2004 15:52:32 +0000

[email-masked] wrote:

>>notifications from multiple mailboxes has deep impact on server implementations.
>>    
>>
>Why?
>  
>
I think I need to correct myself: "the choice of allowing notifications 
has deep impact on server implementations." I.e. it might not trivial to 
add IDLE support to a server, as this requires addition of notification 
infrastructure (for example additional thread(s) to poll for changes; 
additional data structures to store and report notifications). Adding 
support for multimailbox notifications once the IDLE is implemented 
should be much simpler.

BTW, how many servers implement IDLE?

Alexey