Subject: [lemonade] RE: Comments about CLEARIDLE

From: [email-masked]
Date: Sun, 7 Nov 2004 17:59:43 -0600

> -----Original Message-----
> From: ext Alexey Melnikov [mailto:[email-masked]]
> Sent: Sunday, November 07, 2004 12:18 PM
...
> One thing the needs discussing is whether the problem of 
> receiving flag 
> changes/new mail notifications for multiple mailboxes (over a single 
> connection) is worth solving. I frankly don't know for sure.

The sync algorithm for IMAP assumes multiple mailboxes so I 
don't understand why it would not be of interest.

> I suggest you review the LISTEXT extension (currently 
> draft-ietf-imapext-list-extensions-10.txt).
> \Deleted is the same as \NonExistent.

Agreed.

> This might be less obvious for people not following IMAPEXT, 
> but there 
> was a proposal to have REFERRAL data returned in LIST responses. It 
> serves exactly this purpose. See 
> <http://www.imc.org/ietf-imapext/mail-archive/msg01921.html>, 
> item # 5.
> It also avoids the proposed hack (sorry, I can't find a 
> better word) of 
> tying two LIST responses together.

I did not like tying the two together either.

I assume the semantics are that when a renamed folder is requested
by the client via a LIST the server will send a referring url? For 
how long does the server need to remember the reference?

>  >       Example:
>  >          S: * 1 FETCH (UID 34 FLAGS (\Recent) ENVELOPE 
> (...) BODY (...))
> 
> Actually no, BODY must not be in this list, as it is potentially very 
> big. You surely wouldn't want to push a 10Mb message to you 
> cell phone.
> I also suggest to replace the ENVELOPE with the BODYSTRUCTURE.

I agree no MIME content is sent. That is why I used BODY and not BODY[].

BODYSTRUCTURE would do.

> Why can't we just you the STATUS response?
> 
>         S: * STATUS INBOX (MESSAGES 231 RECENT 7)

Agreed.

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 08 Nov 2004 11:52:02 +0000

>don't understand why it would not be of interest.
What is the percentage of users that gets there mail delivered to 
anything other than INBOX?

> [...]
>by the client via a LIST the server will send a referring url?
>
Yes.

>For how long does the server need to remember the reference?
>  
>
This is implementation specific.

>I agree no MIME content is sent. That is why I used BODY and not BODY[].
My mistake.