Subject: RE: [lemonade] partial fetches with IMAP URLs?

From: [email-masked]
Date: Tue, 23 Nov 2004 13:22:32 -0600

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of ext Mark Crispin
> Sent: Tuesday, November 23, 2004 1:44 PM
..
> On Tue, 23 Nov 2004 [email-masked] wrote:
> >>> Define the signature coverage to not include the range specifier.
> >> Magic invariably leads to evil.
> > How is this magic?
> 
> URLAUTH covers the entire URL.
> 
> Except when it doesn't cover the entire URL.  There's this 
> exception, that 
> exception, the other exception.  But trust us to anticipate all the 
> interactions and how they will affect security.

Right now the signature only covers everything prior to and 
excluding the 2rd ":" from the end. So technically it is not the 
entire URL, but I understand your point. Your point is about 
exceptions to the rule.

Of course the same rule applies in the case where there may be
URL to the right of <token>. In other words the rule can be the
same. So I don't see madness. I see consistency. Everything to
the left is signed. Everything to the right is not signed.

I think there may be more confusion by allowing ranges to be 
defined in two places, i.e. the URL and in a command that
uses a URL. Now there is the issue of tracking mismatches 
between them or disallowing them to be used together.

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Tue, 23 Nov 2004 12:25:18 -0800 (Pacific Standard Time)

> the left is signed. Everything to the right is not signed.

The current definition of URLAUTH requires that the URLAUTH be the last 
thing in the URL.

> between them or disallowing them to be used together.

These do two entirely different things.

One, in the generated URL, is a range determined by the entity that 
generated the URL, and the client can not retrieve outside that range.

The other allows the client to do partial fetching within data that he has 
access to.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.