Subject: RE: [lemonade] comments on draft-ietf-lemonade-urlauth-04.txt (fw d)

From: Eric Burger <[email-masked]>
Date: Mon, 22 Nov 2004 19:14:19 -0500

As these are all editorial, I would hold off on -05 until after WGLC closes,
you can get any and all comments in one update.

> -----Original Message-----
> From: Mark Crispin [mailto:[email-masked]]
> Sent: Monday, November 22, 2004 5:01 PM
> To: [email-masked]
> Subject: [lemonade] comments on 
> draft-ietf-lemonade-urlauth-04.txt (fwd)
> 
> 
> I have received the following comments on draft 04.  Unless 
> there is an 
> objection in the next day or two, I propose to act 
> affirmatively on all of 
> these comments and produce a draft 05.
> 
> I do not think that any of these changes invalidate the WGLC 
> on 04.  In my 
> opinion, they are all minor, fall into the category of 
> clarification, and 
> will result in a superior document.
> 
> -- Mark --
> 
> http://staff.washington.edu/mrc
> Science does not emerge from voting, party politics, or public debate.
> Si vis pacem, para bellum.
> 
> ---------- Forwarded message ----------
> 
> The examples that have wrapped lines would be easier to read if the
> continued lines were indented past the leading "C: " or "S: ".  The
> blurb about continuations at the start of the GENURLAUTH and URLFETCH
> examples should be removed now that that is mentioned in the
> 'conventions' section.
> 
> Shouldn't both RESETKEY and GENURLAUTH require that the user be
> able to access the mailbox named in the command or URL?  Should the
> server check whether the indicated message both exists and has the
> indicated part?
> 
> I think servers should be required to automatically generate a key
> the first time a user uses GENURLAUTH on a mailbox.  That is, a
> server MUST NOT require a client to use RESETKEY before GENURLAUTH.
> RESETKEY should only be used by clients for revocation, otherwise
> clients may unintentionally break each other's URLs.
> 
> The word "examine" at the end of the first paragraph of 
> BASE.6.3.URLFETCH
> should be capitalized.
> 
> The authuser/anonymous text bits look good to me, but I never really
> understood why generated such a furor.
> 
> The second line of the syntax for 'access' should be indented further.
> 
> I think the syntax for mechanism is more liberal than desired: uchar
> includes parens, asterisk, and URL %-escape sequences, none of which
> are permitted in the IMAP atom syntax.  I suspect mechanism names
> should be restricted to something like 1*(alpha / digit / safe),
> though maybe they should have different syntax in URLs vs IMAP?
> 
> The IANA Considerations section needs to request registration of
> URLAUTH in the imap4-capabilities registry.  There should also be
> a statement somewhere that the names of URLAUTH authorization
> mechanisms are case-insensitive.
> 
> _______________________________________________
> lemonade mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/lemonade
> 

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Mon, 22 Nov 2004 16:25:03 -0800 (Pacific Standard Time)

> you can get any and all comments in one update.

Roger wilco!! :-)

-- Mark --