Subject: RE: [lemonade] RE: Comments about CLEARIDLE

From: [email-masked]
Date: Mon, 8 Nov 2004 07:29:34 -0600

> -----Original Message-----
> From: ext Alexey Melnikov [mailto:[email-masked]]
> Sent: Monday, November 08, 2004 6:52 AM
...
> >>One thing the needs discussing is whether the problem of 
> >>receiving flag 
> >>changes/new mail notifications for multiple mailboxes (over 
> a single 
> >>connection) is worth solving. I frankly don't know for sure.
> >>    
> >>
> >
> >The sync algorithm for IMAP assumes multiple mailboxes so I 
> >don't understand why it would not be of interest.
> >  
> >
> What is the percentage of users that gets there mail delivered to 
> anything other than INBOX?

So the distinction is not so much one vs multiple it is between 
INBOX and other folders.

I think a more interesting question is can non INBOX folder state 
change for a client either while connected or disconnected. The 
answer is yes. The messages may not be "delivered" in the sense
that it is delivered to an INBOX, but messages can certainly
appear. For example it could be a shared folder.

I would agree that a more common use case is the use case for
conventional delivery to the inbox, but if a solution can be had 
for an arbitrary folder why not use it.

At the very least the asymmetry of the solution bothers me. Yes, I
know this is subjective.

> >>This might be less obvious for people not following IMAPEXT, 
> >>but there 
> >>was a proposal to have REFERRAL data returned in LIST responses. It 
> >>serves exactly this purpose. See 
> >><http://www.imc.org/ietf-imapext/mail-archive/msg01921.html>, 
> >>item # 5.
...
> >For how long does the server need to remember the reference?
> >  
> >
> This is implementation specific.

I can see it working, but why not use something like \Renamed 
(Sent once)? You have to admit Referral was targeted at solving 
a slightly different problem.

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 08 Nov 2004 13:39:51 +0000

>for an arbitrary folder why not use it.
Speaking as a server implementor: the choice of allowing notifications 
from multiple mailboxes has deep impact on server implementations.
The proposed solution is much easier for the clients then for the servers.

>>>>but there was a proposal to have REFERRAL data returned in LIST responses. It 
I think you are assuming how this is implemented. Referrals can be kept 
in memory and can be sent only once.
So, apart from the syntax, there is no difference between your \Renamed 
proposal and my REFERRAL proposal.