Subject: Re: [lemonade] Alternate Solution to Mobile MailSynchronizationOptimization - part 2

From: Alexey Melnikov <[email-masked]>
Date: Sun, 07 Nov 2004 18:13:31 +0000

[email-masked] wrote:

>>Isn't it [MSGFILTER] the mechanism proposed by XFILTER in P-IMAP?
>>    
>>
>
>No.
>  
>
Actually, it seems that there is a lot of overlap between the 
[MSGFILTER] "FILTER SET" and the [P-IMAP] XFILTER/XPSEARCH commands.
This also brings memories of long expired IMAPEXT VIEW extension.

Alexey

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Stephane Maes <[email-masked]>
Date: Sun, 7 Nov 2004 12:28:55 -0700

Agreed.

In my view the difference is non persistence. 

There may be use case for that but for P-IMAP and its use case, the filter must be permanent or the concept of mobile repository and filters would not help and rather burden the user.

Stephane
_____
Stephane H. Maes, PhD,
Director of Architecture - Mobile, Oracle Corporation.
Ph: +1-203-300-7786 (mobile/SMS); Fax / UM: +1-650-607-6296.
e-mail: [email-masked]
IM: shmaes (AIM, Y!) or [email-masked] (MSN Messenger) 

-----Original Message-----
From: Alexey Melnikov <[email-masked]>
To: [email-masked] <[email-masked]>
CC: Stephane Maes <[email-masked]>; [email-masked] <[email-masked]>
Sent: Sun Nov 07 11:13:31 2004
Subject: Re: [lemonade] Alternate Solution to Mobile MailSynchronizationOptimization - part 2

Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 07 Nov 2004 19:18:50 +0000

>In my view the difference is non persistence. 
With FILTER SET TAG filters can be persistent, they just don't create a 
virtual mailbox as P-IMAP does.

Anyway, I don't think we need two competing proposals.

---

From: Stephane Maes <[email-masked]>
Date: Sun, 7 Nov 2004 12:37:44 -0700

Not sure about persistency in FILTERSET.

Strong agreement of no need of competing proposal.

Strong view that we need to enable the virtual mailbox of XFilter.

Thanks

Stephane
_____
Stephane H. Maes, PhD,

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 07 Nov 2004 19:34:51 +0000

>Strong view that we need to enable the virtual mailbox of XFilter.
As far as I am concerned, this is just a detail. If I was a client 
writer I probably wouldn't care if I need to select a virtual mailbox or 
enable a filter on the current one.

---

From: [email-masked]
Date: Sun, 7 Nov 2004 18:05:05 -0600

> From: ext Alexey Melnikov [mailto:[email-masked]]
> Sent: Sunday, November 07, 2004 1:14 PM
...
> This also brings memories of long expired IMAPEXT VIEW extension.

I borrowed the syntax from the WINDOW draft because I thought 
they were very clear. The semantics are different.

Mike