Subject: RE: [lemonade] RE: Comments about CLEARIDLE

From: "Stephane H. Maes" <[email-masked]>
Date: Mon, 8 Nov 2004 09:22:23 -0800

BTW, how many servers implement IDLE?
<

Good question. It would help to know as well as if the implement IDLE, how many concurrent client session are they typically able to support?

Stephane

_____
Stephane H. Maes, PhD,
Director of Architecture - Mobile, Oracle Corporation.
Ph: +1-203-300-7786 (mobile/SMS); Fax: +1-650-506-7222; Office UM: +1-650-607-6296.
e-mail: [email-masked]
IM: shmaes (AIM) or [email-masked] (MSN Messenger)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexey Melnikov
Sent: Monday, November 08, 2004 7:53 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [lemonade] RE: Comments about CLEARIDLE

[email-masked] wrote:

>>Speaking as a server implementor: the choice of allowing
>>notifications from multiple mailboxes has deep impact on server implementations.
>>    
>>
>Why?
>  
>
I think I need to correct myself: "the choice of allowing notifications 
has deep impact on server implementations." I.e. it might not trivial to 
add IDLE support to a server, as this requires addition of notification 
infrastructure (for example additional thread(s) to poll for changes; 
additional data structures to store and report notifications). Adding 
support for multimailbox notifications once the IDLE is implemented 
should be much simpler.

BTW, how many servers implement IDLE?

Alexey

_______________________________________________
lemonade mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Lyndon Nerenberg <[email-masked]>
Date: Wed, 10 Nov 2004 01:26:21 -0800

--On 2004-11-8 9:22 AM -0800 "Stephane H. Maes" 
<[email-masked]> wrote:

> Good question. It would help to know as well as if the implement
> IDLE, how many concurrent client session are they typically able to
> support?

I'm a bit fuzzy about what you're asking for here. Are you looking for a
comparison of how many connections I can handle in SELECTed state vs. 
how
many I can handle in IDLE state? (For my server, there's no difference.)

--lyndon