Subject: RE: [lemonade] partial fetches with IMAP URLs?

From: [email-masked]
Date: Tue, 23 Nov 2004 09:46:52 -0600

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of ext Eric Burger
> Sent: Tuesday, November 23, 2004 9:49 AM
...
> What if I had a URLAUTH over an imap: URL?  If I hack the 
> byte range, won't
> that hack the signature.  

Define the signature coverage to not include the range specifier.

> Also, what about error conditions, 
> like fetching
> beyond the end of the object or across the end of the object?

This could be handled the same way FETCH does it.

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Tue, 23 Nov 2004 08:52:36 -0800 (PST)

> Define the signature coverage to not include the range specifier.

Magic invariably leads to evil.  We've learned this lesson the hard way 
many many times before.

If there is to be a byte range, it needs to be a facility in the URLFETCH 
command.  Additionally, it may also be desirable to have a facility in the 
IMAP URL.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.