Subject: [lemonade] New CATENATE (-03) submitted

From: Pete Resnick <[email-masked]>
Date: Sat, 11 Dec 2004 12:29:17 -0600

I sent off the new CATENATE draft. Until it is posted, you can find copies at:

http://www.qualcomm.com/~presnick/draft-ietf-lemonade-catenate-03.txt
http://www.qualcomm.com/~presnick/draft-ietf-lemonade-catenate-03.html
http://www.qualcomm.com/~presnick/draft-ietf-lemonade-catenate-03.xml

I will be on vacation until Dec. 28 and only reading e-mail 
occasionally. Please be patient with my replies.

pr
-- 
Pete Resnick <http://www.qualcomm.com/~presnick/>
QUALCOMM Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Pete Resnick <[email-masked]>
Date: Sat, 11 Dec 2004 15:29:24 -0600

On 12/11/04 at 1:25 PM -0800, Philip Guenther wrote:

>The examples need parens about the parameters.  I.e., on page 6,
>    C: A003 CATENATE Drafts FLAGS (\Seen \Draft $MDNSent)
>should become
>    C: A003 CATENATE Drafts (FLAGS (\Seen \Draft $MDNSent))
>and similar for the others.

That's not what the current ABNF says; that would be a syntactic 
change. Glad to change it if necessary, but I'd like to hear that.

pr

---

From: Philip Guenther <[email-masked]>
Date: Sat, 11 Dec 2004 13:45:39 -0800

>change. Glad to change it if necessary, but I'd like to hear that.

Uh, then what are those things in double-quotes in the syntax?

   parameters = ("(" parameter *(SP parameter) ")") / "NIL"

Philip Guenther

---

From: Pete Resnick <[email-masked]>
Date: Sat, 11 Dec 2004 15:47:30 -0600

>    parameters = ("(" parameter *(SP parameter) ")") / "NIL"

Oops. Right. OK, fixed.

pr

---

From: Philip Guenther <[email-masked]>
Date: Sat, 11 Dec 2004 13:25:14 -0800

>I sent off the new CATENATE draft. Until it is posted, you can find copies at:
...

The changes in the text looks good to me.

I also suggest tweaking one of the examples (#4 seems like a good
choice) to not specify any parameters, demonstrating how 'NIL' is
required in that case.  That is, on page 9, change
   C: A003 CATENATE Sent FLAGS (\Seen $MDNSent) TEXT {541}
to
   C: A003 CATENATE Sent NIL TEXT {541}

Philip Guenther