Subject: [lemonade] Push IMAP questions

From: "Marek Pola" <[email-masked]>
Date: Tue, 04 Jan 2005 11:56:15 +0100

Hello all,

I'm not sure this is the right place for my questions,  in that case I apologize, please advice me in that case where I can place them.

I wish to start implementing the Push IMAP protocol that is currently in Draft state.

There are different communication protocols, https or tcp when accessing emails, and also for the outband notifications, there is a number of notification options to choose from. It doesn't say in the draft if any of those options are mandatory? Obviously the servers will not support all options, but which ones must an implementation support?

Also, is there a test server anywhere on which a implementation can be tested, or is this planned in the near future?

Regards

Marek Pola

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Stephane H. Maes" <[email-masked]>
Date: Tue, 4 Jan 2005 10:10:15 -0800

Marek,

Thanks for your interest.

We will publish and implementation / interoperability guideline shortly that goes beyond the protocol and address such issues.

Today the protocol indeed lets you set / negotiate the transport but does not specify which one should be supported at the minimum.

For now we have taken the approach of always supporting the HTTP(s) and experimenting with the others. TCP with TLS is also expected to be supported but may fail to traverse firewalls. For that reason, I would suggest to first target HTTP, even if less elegant...

For notifications, I recommend to support SMS as at least wake-up of the client (on network where it makes sense), and in-band HTTP as well as UDP for most of the notification on always-on networks (we will publish a UDP method soon, may be in the upcoming next release of the draft).

Feel free to contact me if you need any more details or help as you implement. Clearly feedback will be appreciated. 

Also I could help you test interoperability against P-IMAP server and clients. This requires setting up an account for you etc... Please contact me to set that up when you are ready.

Thanks

Stephane

_____
Stephane H. Maes, PhD,
Director of Architecture - RTCC & Mobile, Oracle Corporation.
Ph: +1-203-300-7786 (mobile/SMS); Fax / Office UM: +1-650-607-6296.
e-mail: [email-masked]
IM: shmaes (AIM/Y!) or [email-masked] (MSN Messenger)
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Marek Pola
Sent: Tuesday, January 04, 2005 2:56 AM
To: [email-masked]
Subject: [lemonade] Push IMAP questions

Hello all,

Regards

Marek Pola