Subject: RE: [lemonade] LEMONADE WG Media Conversion Summary

From: [email-masked]
Date: Mon, 24 Jan 2005 17:51:15 -0600

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of ext Mark Crispin
> Sent: Monday, January 24, 2005 5:44 PM
...
> Is it anticipated that media conversion would be a facility 
> of specialized 
> IMAP servers?  

This is how I see it.

> 
> I am asking because server-based media conversion may be a 
> severe burden 

I agree.

> The capability mechanism need not be cumbersome; there could 
> be a general 
> capability for media conversions, and then an additional 
> negotiation for 
> the supported conversion mechanism(s).  Although this likely 
> adds an RTT, 
> that may be less costly in the overall scheme of things.

Any additional RTT could be lessened by allowing the client to 
gain this information at times of it's choosing, and making it
apply generally, i.e. to any specific body part as long as that
body part was of the correct content type.

You can see a related discussion based on Lyndon's proposal at ...
http://www1.ietf.org/mail-archive/web/lemonade/current/msg00993.html

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Tue, 25 Jan 2005 14:47:25 -0800

>  body part was of the correct content type.

If the mechanism does add an extra RTT, the client should be able to 
cache the information to be able to save the RTT in similar future 
cases.
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
It takes a wonderful brain and exquisite senses to produce a few
stupid ideas.                                        --Santayana