Subject: RE: [lemonade] problems implementing RESETKEY GENURLAUTH and URLFETCH

From: "Burger, Eric" <[email-masked]>
Date: Tue, 11 Apr 2006 09:53:15 -0400

<as participant>
Live by the Proxy, Die by the Proxy.

-----Original Message-----
From: Peter Coates [mailto:[email-masked]] 
Sent: Monday, April 10, 2006 9:58 PM
To: 'Ken Murchison'; 'Tony Finch'
Cc: [email-masked]; 'Mark Crispin'
Subject: RE: [lemonade] problems implementing RESETKEY GENURLAUTH and
URLFETCH

If we used referrals, the story with GENURLAUTH and URLFETCH would be
worse.
These are commands that are not open to being referred.  They have to be
proxied piecemeal.  The discussion here is leading me to believe that
there
is a problem with the design of these commands.  Bit of a shame that as
I
have done the (seriously ugly) work to do this proxying.  On the other
hand,
the cost of a GENURLAUTH command with multiple URLs which happen to be
hosted on multiple hosts is potentially much higher than a client would
expect.  That is the sort of surprise that ought not to be.

Peter 

-----Original Message-----
From: Ken Murchison [mailto:[email-masked]] 
Sent: April 10, 2006 18:28
To: Tony Finch
Cc: Mark Crispin; [email-masked]; Peter Coates
Subject: Re: [lemonade] problems implementing RESETKEY GENURLAUTH and
URLFETCH

Tony Finch wrote:
> On Mon, 10 Apr 2006, Mark Crispin wrote:
>> On Mon, 10 Apr 2006, Peter Coates wrote:
>>> Our server spreads users over multiple back ends, and if joe shares 
>>> any of his folders with sue, then the server sue is directed to will

>>> have to proxy some requests to joe's machine.  This is an entirely
reasonable approach.
>> And thus IMAP has a mechanism, called "referrals", to support this.  
>> You seem to have chosen not to use referrals.
> 
> That seems to be a common design choice - cf. the Cyrus Murder and the

> Perdition proxy.

Cyrus Murder will issue referrals iff the client has shown that it can
handle them (it sends either an RLIST or RLSUB)

Do any clients other than Pine support mailbox referrals?

--
Kenneth Murchison
Systems Programmer
Project Cyrus Developer/Maintainer
Carnegie Mellon University

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Tue, 11 Apr 2006 13:35:13 -0700 (Pacific Daylight Time)

> Live by the Proxy, Die by the Proxy.

There ought to be a koan on that line of thought, to be recited every time 
someone says "a proxy is easy, just tie together client code and server 
code."  :-)

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.