Subject: [lemonade] Trio in AUTH48

From: "Glenn Parsons" <[email-masked]>
Date: Tue, 4 Apr 2006 20:59:39 -0400

Folks,

The trio is now in AUTH48 ... but I sense there is an issue with the
ABNF that we probably need some consensus on...

The options as I see it are:

1. Stop AUTH48.  Include RFC2192bis as a mandatory reference.  Get IESG
re-approval and then resume AUTH48.  But what changes will we add?  Will
we include partial support now?  We need concrete text proposals if we
want to do this...

2.  Make the 'bug fix' changes Mark has proposed earlier today (with
tweaks as appropriate)

3.  Change nothing.  It doesn't matter since we will fix all this in
RFC2192bis and Profile-bis

What do folks think?

Cheers,
Glenn.
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Tue, 4 Apr 2006 18:39:41 -0700

> What do folks think?

The AUTH48 has already been stopped.  The only question is whether that 
stop gets revoked.

There was no consultation to the WG, the document editor, or the chair to 
stop the AUTH48.  It was just done.

All because of a simple matter about a hyphen vs. an underscore.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: Ted Hardie <[email-masked]>
Date: Wed, 5 Apr 2006 07:10:11 -0700

At 6:39 PM -0700 4/4/06, Mark Crispin wrote:
>The AUTH48 has already been stopped.  The only question is whether that stop gets revoked.
>
>There was no consultation to the WG, the document editor, or the chair to stop the AUTH48.  It was just done.
>

Just to clarify this, the AUTH48 period is not being stopped.  The working group
chairs and AD are cc'ed on all AUTH48 notes from the RFC Editor.  When the
URLAUTH one came through, I let the RFC Editor know that WG had been
discussing a change, and that I think the WG chairs needed to call consensus
on the change.  Here's the text I sent:

>Dear RFC Editors,
>	 There is currently discussion in the working group on whether the draft
>ought to be updated to refer to the ABNF productions in draft-ietf-lemonade-rfc2192bis-01.txt.  The chairs will need to call consensus in the working group on that issue and an
>underlying ABNF issue. I would prefer that they make an explicit approval if that text
>needs to be added to this RFC-to-be, as they will be better able to manage the timing
>than I will.  If they believe that the better path would be to get IESG approval of
>the change, I will, naturally, be available to shepherd that question in the IESG.
>				thanks,
>					Ted Hardie

This is not to say that I believe they need to run a WGLC on the issue; if they
are satisfied now that the working group has come to consensus on the approach,
they can simply notify the RFC Editor.   If they feel that the working group needs
to make a more declarative statement, then they need to set the bounds for that.
The RFC-to-be doesn't leave AUTH48 for that.  If they feel the change is substantive
and that the IESG needs to re-approve, I will arrange for that, but I'm not starting
from the point that this is needed.
				regards,
					Ted

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 05 Apr 2006 15:10:27 +0100

Glenn Parsons wrote:

> Folks,
>
> The trio is now in AUTH48 … but I sense there is an issue with the 
> ABNF that we probably need some consensus on…
>
I don't like 3, I am happy with both 1 and 2. But # 1 will mean that we 
need to publish 2192bis asap, so it will need reviews and specific 
suggestions about text.

---

From: Mark Crispin <[email-masked]>
Date: Wed, 5 Apr 2006 09:22:14 -0700 (PDT)

On Wed, 5 Apr 2006, Ted Hardie wrote:
> Just to clarify this, the AUTH48 period is not being stopped.

The message that you sent to the RFC editor sure looks like a stop to me. 
It was sufficient to block my intended work on the fixes last night.

There was no prior consultation with the chair, the document editor, or 
the WG.

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.

---

From: Ted Hardie <[email-masked]>
Date: Wed, 5 Apr 2006 09:57:27 -0700

At 9:22 AM -0700 4/5/06, Mark Crispin wrote:
>The message that you sent to the RFC editor sure looks like a stop to me. It was sufficient to block my intended work on the fixes last night.

Mark,
	I am sorry  for any confusion; any other work you need to do for
the AUTH48 can certainly go forward.  But, as I said in my earlier message,
I believe the chairs need to call consensus on the resolution to the syntax
discussion.  That shouldn't go into the document until that consensus has been
called.
	Glenn's message has three proposals, only one of which would
stop AUTH48 to get IESG approval of a set of changes; if that one is the one
the working group decides on, then we can get that approval and move
on.  None of the other work on the AUTH48 document would be lost even in
that case; the RFC Editor would apply those deltas to the work already done.
			regards,
				Ted

>There was no prior consultation with the chair, the document editor, or the WG.
>
>-- Mark --
>
>http://panda.com/mrc

---

From: Mark Crispin <[email-masked]>
Date: Wed, 5 Apr 2006 15:13:13 -0700 (Pacific Daylight Time)

On Wed, 5 Apr 2006, Ted Hardie wrote:
> But, as I said in my earlier message,

The silence has been deafening in response to the message from the chair.

Since the Working Group refuses to give guidance, shall we abandon the 
trio and tell the RFC Editor to cancel publication of these documents?

Ted Hardie made it abundantly clear that I can not be trusted to figure 
out for myself how to resolve something as simple and stupid as whether or 
not a syntax rule name has an underscore or a hyphen.

-- Mark --

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 05 Apr 2006 19:34:41 -0400

Hi Glenn,

> RFC2192bis and Profile-bis

I think (2) makes the most sense as this can be done quickly and the 
documents published without causing any problems in the future.

-- 
Cyrus Daboo

---

From: Mark Crispin <[email-masked]>
Date: Wed, 5 Apr 2006 23:46:23 -0700 (PDT)

> documents published without causing any problems in the future.

Most of these changes are things that were agreed to several months ago.

-- Mark --

http://panda.com/mrc

---

From: Pete Resnick <[email-masked]>
Date: Thu, 6 Apr 2006 13:09:13 -0500

On 4/5/06 at 7:34 PM -0400, Cyrus Daboo wrote:

>Hi Glenn,
>
>--On April 4, 2006 8:59:39 PM -0400 Glenn Parsons <[email-masked]> wrote:
>

Agreed. This does mean when 2192bis gets published, it will probably 
need to add some sort of CAPABILITY so that BURL and CATENATE can use 
the new forms.

pr
-- 
Pete Resnick <http://www.qualcomm.com/~presnick/>
QUALCOMM Incorporated

---

From: Dave Cridland <[email-masked]>
Date: Thu, 06 Apr 2006 19:46:13 +0100

On Thu Apr  6 19:09:13 2006, Pete Resnick wrote:
>> I think (2) makes the most sense as this can be done quickly and 
>> the documents published without causing any problems in the future.
> 
> Agreed. This does mean when 2192bis gets published, it will 
> probably need to add some sort of CAPABILITY so that BURL and 
> CATENATE can use the new forms.

I think that's the best solution.

Although I was secretly hoping for CATENATELESS. ;-)

Dave.
-- 
           You see things; and you say "Why?"
   But I dream things that never were; and I say "Why not?"
    - George Bernard Shaw