Subject: RE: CALL FOR CONSENSUS (was RE: [lemonade] on MTI conversions)

From: "Burger, Eric" <[email-masked]>
Date: Fri, 14 Apr 2006 16:06:37 -0400

Fourth choice is not a choice, but the reality: if one implements a
conversion, they are going to do a suite.

The reason for choice 3 was so that we would REQUIRE multiple
conversions, to ensure that people write code to handle more than one. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mark Crispin
Sent: Friday, April 14, 2006 2:41 PM
To: Burger, Eric
Cc: Dave Cridland; Ned Freed; Enhancements to Internet email to support
diverse service enivronments
Subject: RE: CALL FOR CONSENSUS (was RE: [lemonade] on MTI conversions)

On Fri, 14 Apr 2006, Burger, Eric wrote:
> Part of me wants to say, "Live with it, it is HTML to text."
>
> Another part of me wants to say, "Character set conversion is so
> trivial, let's go with that."
>
> Yet another part of me is inclined to say, "Do HTML to text *and*
> character set conversions."

What about the fourth choice:

Do HTML to text.  As a server implementation option, also do character
set 
conversions.

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Burger, Eric" <[email-masked]>
Date: Wed, 19 Apr 2006 07:31:51 -0400

So here is the quandry: (1) define achievable subset of full HTML 4.01 to text, (2) punt on what the result is supposed to look like and say do full HTML, (3) really mandate full HTML to text, (4) do something else.

You know, charset is beginning to not look so bad...

 -----Original Message-----
From: 	Randall Gellens [mailto:[email-masked]]
Sent:	Tue Apr 18 19:24:39 2006
To:	Alexey Melnikov
Cc:	support diverse service enivronments; Ned Freed; Burger, Eric
Subject:	Re: CALL FOR CONSENSUS (was RE: [lemonade] on MTI conversions)

At 12:44 PM +0100 4/18/06, Alexey Melnikov wrote:

>  I think you underestimate the complexity of this.
>  For example, how does one convert <table> element to text? How to 
> deal with column widths in percents and pixels, etc.?

You're right, Alexey, I was overlooking aspects of this that add 
significant difficulty, such as tables.  I was thinking of the 
Qpopper code that converts HTML to plain text.  It does a decent job 
on the basic stuff (paragraphs, attributes, entities, etc.)  I don't 
think it handles tables, though.
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Nothing in the world is more dangerous than sincere ignorance and
conscientious stupidity.
          --Martin Luther King, Jr.
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade