Subject: Re: [lemonade] WGCL Convert-05

From: Eric Burger <[email-masked]>
Date: Tue, 16 Jan 2007 10:05:49 -0800 (PST)

Trip down memory lane time:

We all understand that the one conversion is not useful. However, many of the useful conversions are *real hard*. Moreover, there are a huge number of possible conversions.  What must be supported to be OMA compliant is the OMA's problem.  Mobile e-mail folks will have to do what OMA says, anyway.  Voice mail folks (as an example) could not care less about text conversion, but they sure care about audio and image conversion.

The important part for lemonade to do is a protocol that supports at least two conversions.  This way we can prove protocol interoperation with more than one conversion type and a conversion that takes parameters.

The work group consensus is that charset and html->text conversions were (1) *relatively* easy and (2) somewhat useful.

So...

Discussion on the conversions specified by the document are OUT OF SCOPE.

Focus on the protocol itself.

----- Original Message ----
From: Arnt Gulbrandsen <[email-masked]>
To: [email-masked]
Cc: Ben Last <[email-masked]>; Eric Burger <[email-masked]>
Sent: Tuesday, January 16, 2007 8:04:57 AM
Subject: Re: [lemonade] WGCL Convert-05

Ben Last writes:
>> From: Arnt Gulbrandsen [mailto:[email-masked]]
>> Decent surely means something that's tailored to your screen width 
>> and font, which isn't what the convert document specifies.
> Ah... good point, but plain unwrapped text is still better than nothing.

Better than the code you already have?

> One could argue, though, that conversion on the server with no 
> knowledge of screen size, resolution and fonts is a problem for many 
> types of conversion. For instance, it'd be very useful to have the 
> server down-size images that are too large for client display.

Sure. In that case the draft does the right thing: the client asks for a 
conversion including downscaling to a specified size.

Arnt

____________________________________________________________________________________
Don't pick lemons.
See all the new 2007 cars at Yahoo! Autos.
http://autos.yahoo.com/new_cars.html 

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Ben Last" <[email-masked]>
Date: Wed, 17 Jan 2007 08:10:01 -0000

>From: Eric Burger [mailto:[email-masked]] 

Me declaro culpable :)

How relevant is it for the document to cover the format of error
responses, particularly relating to bad parameter values?

Regards
Ben

R&D Manager
EMCC Software Ltd