Subject: Re: [lemonade] About draft-gulbrandsen-imap-notify-02

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 12 Feb 2007 08:08:53 +0100

Lingyan Wu writes:
> How about to only send very important and urgent events in unselected 
> mailbox (e.g. the events that can pass outband-notification filters) 
> through unsolicited STATUS response including the 
> event--STATUS(EVENT)?

I _think_ the latest/next sieve notify draft is close to that. At least 
if there's a new "imap" mechanism. Which there will be - I'm sure 
Alexey will write a draft.

The sieve notify mechanism then does this:

If the filters pass
   If the user is logged in via IMAP
     notify via IMAP response
   else
     notify outband
   endif
endif

So we just need to add text ensuring that IMAP notify and SIEVE notify 
will not send the same NewMessage event twice. Which will be really 
easy to implement anyway. Good.

Arnt

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Lingyan Wu <[email-masked]>
Date: Mon, 12 Feb 2007 17:14:14 +0800

----- Original Message ----- 
From: "Arnt Gulbrandsen" <[email-masked]>
To: <[email-masked]>
Cc: "Lingyan Wu" <[email-masked]>
Sent: Monday, February 12, 2007 3:08 PM
Subject: Re: [lemonade] About draft-gulbrandsen-imap-notify-02

>> through unsolicited STATUS response including the event--STATUS(EVENT)?
>
> I _think_ the latest/next sieve notify draft is close to that. At least if 
> there's a new "imap" mechanism. Which there will be - I'm sure Alexey will 
> write a draft.
>

Please look at the following definitions.
o        Filtering results into the following logical types:

§   Type A: Messages filtered out and not accessible by the MEM Client (no 
notification, no access)

§   Type B: Messages that are accessible by the MEM Client but no outband 
notification takes place. However, In-band Notifications take place while 
the MEM Client is connected to MEM Server.

§   Type C: Messages that are accessible by the MEM Client for which 
notifications (outband or inband) are always sent to the MEM Client.

According to the definition, filters for outband seems more strict than 
filters for inband. I mean it seems that the messages passing outband 
filters is subset of the messages passing inband filters. Right or not?
If I misunderstand the definitions, please give corrections and guidance.
If not, maybe the following mechanism is more appropriate.

If the user is logged in via IMAP
   If the inband filters pass
      notify via IMAP response
   endif
else
   If the outband filters pass
      notify outband
   endif
endif

> will not send the same NewMessage event twice. Which will be really easy 
> to implement anyway. Good.
>
> Arnt
>