Subject: [lemonade] Review request for draft-ietf-lemonade-convert-06.txt

From: Ted Hardie <[email-masked]>
Date: Fri, 27 Apr 2007 10:49:08 -0700

Hi Larry,
	During some recent discussion of this draft within LEMONADE,
the idea of harmonizing these IMAP convert parameters with the
media features registry came up.  There seem to be a couple of ways
to do that.  One would be to keep the current focus on OMA-derived
terms, and add those to the registry under the global tree as g.oma.$value.
Another would be to shift the IMAP usage to the IETF registered values
where they already exist (e.g. moving width and height to pix-x and pix-y,
since those are pixel values in the current document) and registering
new values where they do not.  There are a couple of potential parameters
that might be a tricky (the resize directive's crop, for example), but it
still seems like it migh work.
	If you can review the document and provide advice to the group,
it would be much appreciated.
			thanks,
				Ted Hardie

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 27 Apr 2007 18:55:45 -0700

On the specific question of whether it is reasonable
to re-use existing IETF registered values, well, I
don't see any reason not to, if they're being used
with the same meaning.

But my broader concern is that the sets of values chosen
don't really seem to match what's necessary to be effective.
>From a content creation point of view, it seems like
you need to know a lot more, and I'm not sure why content
conversion would be different. 

At least, that seems to be the tone of W3C work in this
area, e.g., http://www.w3.org/TR/DDR-requirements 
http://www.w3.org/2005/MWI/DDWG/ which is ongoing,
and even of commercial products in this area
(http://www.adobe.com/products/creativesuite/devicecentral/).

In general, I think coordinating IMAP with web access
mechanisms is a good idea, even if the web work isn't
happening in the IETF.

Larry

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 27 Apr 2007 18:55:45 -0700

Larry