Subject: [lemonade] How can a server identify client's capabilities (was WGCL Convert-05)

From: Alexey Melnikov <[email-masked]>
Date: Fri, 13 Apr 2007 10:18:55 +0100

Randall Gellens wrote:

> Also in Section 5, the text mentions the server having knowledge of 
> the device: how does the client identify a specific device?  Users may 
> have multiple devices.

Lingyan Wu wrote:

> How about to add a optional parameters (URL of UAProfile) to the 
> CONVERT requeste?
> Server can get device capability information based on the URL provided 
> in the request and determine what conversions are possible.

This might work, something like:

      c001 FETCH 2 BODY[3.CONVERT ("image/jpeg" ("DeviceID" "Nokia-770"))]

?

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Lingyan Wu <[email-masked]>
Date: Mon, 16 Apr 2007 11:34:40 +0800

----- Original Message ----- 
From: "Alexey Melnikov" <[email-masked]>
To: "Lingyan Wu" <[email-masked]>; "Randall Gellens" 
<[email-masked]>
Cc: "Lemonade WG" <[email-masked]>
Sent: Friday, April 13, 2007 5:18 PM
Subject: How can a server identify client's capabilities (was WGCL 
Convert-05)

> Randall Gellens wrote:
>
>> Also in Section 5, the text mentions the server having knowledge of the 
>> device: how does the client identify a specific device?  Users may have 
>> multiple devices.
>
> Lingyan Wu wrote:
>
>> How about to add a optional parameters (URL of UAProfile) to the CONVERT 
>> requeste?
>> Server can get device capability information based on the URL provided in 
>> the request and determine what conversions are possible.
>

---

From: Lingyan Wu <[email-masked]>
Date: Mon, 16 Apr 2007 11:37:46 +0800

Yes. Just as what I thought before. Thank you!

BTW. I'm sorry I sent an email with nothing just now.

Best Regards,
Lingyan

----- Original Message ----- 
From: "Alexey Melnikov" <[email-masked]>
To: "Lingyan Wu" <[email-masked]>; "Randall Gellens" 
<[email-masked]>