Subject: RE: [lemonade] Inclusion of QUICKSTART in Lemonade Profile-bis

From: <[email-masked]>
Date: Fri, 4 May 2007 15:18:58 +0300

As a client vendor, this definiately got my attention since reducing the number of roundtrips is always a good thing.
However, reading the comments from other participants, it seems that there is no real benefit.
Is it really so? Cutting the roundtrips to half does not have real benefits?
I do not have a client that implements this, so I cannot check this myself.
If the claims regarding no benefit are true, then obviously there is no point complicating the implementations.
Anyone with actual measurements?
Thank You.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

>-----Original Message-----
>From: ext Eric Burger [mailto:[email-masked]] 
>Sent: 24 April, 2007 02:39
>To: Lemonade WG
>Subject: RE: [lemonade] Inclusion of QUICKSTART in Lemonade Profile-bis
>
>Joking aside, anyone think this MUST be in Profile-bis?  
>Alternately, anyone think it MUST NOT be in Profile-bis? 
>
>-----Original Message-----
>From: Tony Finch [mailto:[email-masked]]
>Sent: Tuesday, April 17, 2007 10:45 AM
>To: Alexey Melnikov
>Cc: Lemonade WG
>Subject: Re: [lemonade] Inclusion of QUICKSTART in Lemonade Profile-bis
>
>On Tue, 17 Apr 2007, Alexey Melnikov wrote:
>>
>> I actually disagree that this is insignificant. Not very 
>many clients 
>> keep persistent SMTP connections.
>
>It occurred to me this morning that a good slogan for 
>QUICKSTART is "makes SMTP as fast as HTTP POST".
>
>Tony.
>--
>f.a.n.finch  <[email-masked]>  http://dotat.at/ FAIR ISLE: WEST 
>OR NORTHWEST 5 TO 7, DECREASING 4 OR 5, BACKING SOUTHWEST 
>LATER. MODERATE OR ROUGH, OCCASIONALLY VERY ROUGH IN WEST. 
>SQUALLY SHOWERS.
>MODERATE OR GOOD.
>
>
>_______________________________________________
>lemonade mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/lemonade
>Supplemental Web Site:
>http://www.standardstrack.com/ietf/lemonade
>
>Notice:  This email message, together with any attachments, 
>may contain information  of  BEA Systems,  Inc.,  its 
>subsidiaries  and  affiliated entities,  that may be 
>confidential,  proprietary,  copyrighted  and/or legally 
>privileged, and is intended solely for the use of the 
>individual or entity named in this message. If you are not the 
>intended recipient, and have received this message in error, 
>please immediately return this by email and then delete it.
>
>
>_______________________________________________
>lemonade mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/lemonade
>Supplemental Web Site:
>http://www.standardstrack.com/ietf/lemonade
>

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Tony Finch <[email-masked]>
Date: Fri, 4 May 2007 15:17:10 +0100

On Fri, 4 May 2007, [email-masked] wrote:

> However, reading the comments from other participants, it seems that
> there is no real benefit. Is it really so? Cutting the roundtrips to
> half does not have real benefits?

There's a benefit of up to a couple of seconds less delay (assuming 300ms
RTT) if the client sends in the foreground. There's no benefit if your
client can send in the background. So it's probably interesting and useful
for some but not all people.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
NORTH UTSIRE SOUTH UTSIRE: NORTH 5 OR 6, OCCASIONALLY 7. MODERATE. MAINLY
FAIR. MODERATE OR GOOD.

---

From: <[email-masked]>
Date: Mon, 7 May 2007 11:31:54 +0300

Hello Tony,

>RTT) if the client sends in the foreground. There's no benefit 
>if your client can send in the background. So it's probably 
>interesting and useful for some but not all people.

Using fixed network, right? Not a GPRS or other wireless connection,
right?

---

From: Tony Finch <[email-masked]>
Date: Mon, 7 May 2007 11:18:45 +0100

> Using fixed network, right? Not a GPRS or other wireless connection,

I'm not making any assumptions about the network layer, because this is a
purely application-layer optimization. I'm only counting time from the
sending of the first TCP SYN, so I'm not counting setup delays that occur
before that point, e.g. DNS lookups.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
SOLE: SOUTHWESTERLY 6 OR 7. ROUGH OR VERY ROUGH. RAIN OR DRIZZLE. MODERATE OR
POOR.