Subject: [lemonade] CONVERT: conversion from text/html to text/plain as a SHOULD

From: Alexey Melnikov <[email-masked]>
Date: Sat, 05 May 2007 12:21:16 +0100

Randall Gellens wrote:

>>  3). Mandatory to implement conversion:
>>
>>>  ----------
>>>  Section 6.1.1:
>>>
>>>  Do we really want to say SHOULD for text/html to text/plain?
>>
>>   I think we had this discussion before and I thought that consensus 
>> was declared.
>>  However I feel that many people are unhappy with the choice, so 
>> maybe we don't actually have a consensus.
>>
>>  Do you think charset conversion (ISO-8859-* to UTF-8) is better?
>
> Better and more useful, perhaps.
>
>>>  Is this actually useful for any mobile device that can support IMAP?
>>
>>   It is useful for a desktop client that doesn't support HTML.
>
> But are there any clients that don't support HTML?

The most simple ones might not.

>>>  I wonder if text/plain to text/html wouldn't be just as useful? (it 
>>> is easier to implement).
>>
>>   It is easier, but I think it is pointless.
>
> Perhaps not.  If a client has an HTML display engine, it is easier to 
> use it than to reformat plain text to fit a small screen.  As an 
> example, Eudora for Palm makes use of the Qpopper x-mangle option to 
> have plain text (both format=flowed and format=fixed) converted to 
> HTML to make rendering easier.

Interesting. But I still don't think this is generally useful to warrant 
a SHOULD.

-----------------------------------------
Trying to summarize opinions on this issue:
People against text/html -> text/plain conversion: Randy, Arnt, Dave.

I personally can be counted as +0.5 for dropping it as well. The major 
problem for me is that this conversion is underspecified and specifying 
it would take a lot of time.

So at this point I think we have a rough consensus for not having this 
as a SHOULD. I will delete the relevant text. If you object, please 
speak up now.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 05 May 2007 12:26:06 +0100

> as a SHOULD. I will delete the relevant text. If you object, please 

Correction: I will change the text to make informative, instead of 
deleting it.