Subject: Re: [lemonade] CONVERT - Clients Do Not Know

From: "Eric Burger" <[email-masked]>
Date: Mon, 25 Jun 2007 14:50:12 -0700

Most likely, "please convert to image/png at 320x240" which may or may not involve size or format conversion.

--
Sent from my wireless e-mail device. Sorry if terse.  We all need lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.

-----Original Message-----
From: [email-masked] <[email-masked]>
To: Eric Burger; [email-masked] <[email-masked]>
Sent: Mon Jun 25 01:35:44 2007
Subject: RE: [lemonade] CONVERT - Clients Do Not Know

Hi Eric,

>I would like to ask a sanity check question: who REALLY is 
>going to offer the user the option of which converted-to 
>format to download?  My assertion is most of the time the 
>device will decide for the user, i.e., "file is in image/foo, 
>I only understand image/png, so please convert," or, "image is 
>1960x1400 at 16-bit depth, I can only render 320x240 at 8-bit 
>depth, so please convert."

Do You mean format, size or both?

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: <[email-masked]>
Date: Tue, 26 Jun 2007 13:21:03 +0300

Or,
"please convert to image/png or image/jpg but no more than 1megabytes"? (server decides image resolution)
"please convert to 320x240 but no more than 10kilobytes"? (server decides a format based on info about client and suitable compression that provides <10k)

I think mobile devices are more likely to convert due to attachment size limit than convert due to image resolution/format.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

>From: ext Eric Burger [mailto:[email-masked]] 
>Sent: 26 June, 2007 00:50
>To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]
>Subject: Re: [lemonade] CONVERT - Clients Do Not Know
>
>Most likely, "please convert to image/png at 320x240" which 
>may or may not involve size or format conversion.
>
>--
>Sent from my wireless e-mail device. Sorry if terse.  We all 
>need lemonade: see 
><http://www.standardstrack.com/ietf/lemonade> for what lemonade is.
>
>>I would like to ask a sanity check question: who REALLY is going to 
>>offer the user the option of which converted-to format to 
>download?  My 
>>assertion is most of the time the device will decide for the user, 
>>i.e., "file is in image/foo, I only understand image/png, so please 
>>convert," or, "image is 1960x1400 at 16-bit depth, I can only render 
>>320x240 at 8-bit depth, so please convert."
>
>Notice:  This email message, together with any attachments, 
>may contain information  of  BEA Systems,  Inc.,  its 
>subsidiaries  and  affiliated entities,  that may be 
>confidential,  proprietary,  copyrighted  and/or legally 
>privileged, and is intended solely for the use of the 
>individual or entity named in this message. If you are not the 
>intended recipient, and have received this message in error, 
>please immediately return this by email and then delete it.
>

---

From: Eric Burger <[email-masked]>
Date: Thu, 28 Jun 2007 13:32:55 -0700

Thoughts on the idea of maximum size (or suggested size) as the parameter,
rather than format?

On 6/26/07 3:21 AM, "[email-masked]" <[email-masked]>
wrote:

> "please convert to 320x240 but no more than 10kilobytes"? (server decides a
> format based on info about client and suitable compression that provides <10k)
> 
> I think mobile devices are more likely to convert due to attachment size limit
> than convert due to image resolution/format.
>

---

From: "Ben Last" <[email-masked]>
Date: Fri, 29 Jun 2007 10:06:16 +0100

Not sure it helps.  Yes, for images it's a reasonable approach, though I think there's other information that a converter would find useful, like pixel depth, resolution, etc.  But for other document formats, where conversion must be lossless, I'm not sure how a client can sensibly provide the server with a reasonable value.

On the subject of whether size or format is more likely as a client constraint: the amount of storage usable is a dynamically variable value (up to the full amount available, but varies depending on other processes on the device, and whether the client has any form of smart storage management).  A format is either supported or not.

There's a wider issue here about using images as the only use case when discussing this.  I'd prefer to use (or at least include):
* voice audio, as for voicemail-to-email setups
* music or other higher-quality audio
* documents in MS Office format (for better or worse, a de facto standard)
* PDFs, both those in vector format and those containing bitmaps
* Full webpages sent as attachments (in the Outlook/IE format that packages all images and HTML)

Further use cases left as an exercise for the massed minds of Lemonade...

regards
Ben

Ben Last
R&D Manager
EMCC Software

-----Original Message-----
From: Eric Burger [mailto:[email-masked]] 
Sent: 28 June 2007 21:33
To: [email-masked]
Subject: Re: [lemonade] CONVERT - Clients Do Not Know

Thoughts on the idea of maximum size (or suggested size) as the parameter, rather than format?

On 6/26/07 3:21 AM, "[email-masked]" <[email-masked]>
wrote:

> "please convert to 320x240 but no more than 10kilobytes"? (server 
> decides a format based on info about client and suitable compression 
> that provides <10k)
> 
> I think mobile devices are more likely to convert due to attachment 
> size limit than convert due to image resolution/format.
> 
>> Most likely, "please convert to image/png at 320x240" which may or 
>> may not involve size or format conversion.
>> 
>> --
>> Sent from my wireless e-mail device. Sorry if terse.  We all need 
>> lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what 
>> lemonade is.
>> 
>> Notice:  This email message, together with any attachments, may 
>> contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  
>> affiliated entities,  that may be confidential,  proprietary,  
>> copyrighted  and/or legally privileged, and is intended solely for 
>> the use of the individual or entity named in this message. If you are 
>> not the intended recipient, and have received this message in error,

---

From: <[email-masked]>
Date: Fri, 29 Jun 2007 12:53:13 +0300

Hi Ben,

>From: ext Ben Last [mailto:[email-masked]] 
>Sent: 29 June, 2007 12:06
>To: [email-masked]
>Not sure it helps.  Yes, for images it's a reasonable 
>approach, though I think there's other information that a 
>converter would find useful, like pixel depth, resolution, 
>etc.  But for other document formats, where conversion must be 
>lossless, I'm not sure how a client can sensibly provide the 
>server with a reasonable value.
>
>On the subject of whether size or format is more likely as a 
>client constraint: the amount of storage usable is a 
>dynamically variable value (up to the full amount available, 
>but varies depending on other processes on the device, and 
>whether the client has any form of smart storage management).  
>A format is either supported or not.
>
>There's a wider issue here about using images as the only use 
>case when discussing this.  I'd prefer to use (or at least include):

I fully agree with You. I came up with this idea - regarding images only in the first place - because I took a photo and wanted to send it over to a friend via MMS, and I had to convert it manually several times (crop, downscale, crop again) before I got it the right size (<=300k but acceptable quality). I foresee something similar when sending/fetching emails: client storage limit (for fetch), outgoing mail size limit by operator (for send) - and I would not want to go trough such hassle whenever I want to send an image.
There should not be any problem adding size limit to other formats - providing that it is the conclusion of the working group since it is only an idea at this point.
The only problem I could foresee is lossless conversion with size limit - this should be either:
 -  forbidden (or not applicable combo),
 - ignore lossless flag (for pictures or similar data)
 - cut when size reached (streams).

>> "please convert to image/png or image/jpg but no more than 
>1megabytes"?
>> (server decides image resolution)
>going to

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 29 Jun 2007 12:47:19 +0100

>Thoughts on the idea of maximum size (or suggested size) as the parameter,
I like this approach and I think it addresses Greg's issue.

---

From: "Vaudreuil, Greg M \(Greg\)" <[email-masked]>
Date: Fri, 29 Jun 2007 08:33:22 -0500

In private email, Alexy has encouraged me to drop my objections to using actual size, and to defer until later any extension to provide inexpensive hints as to the possibly converted objects size.  I believe the need is not well enough understood to delay this valuable body of work.

In particular, I've been convinced that most conversions will be chosen based on application context without regard to size.  That is, if you want a thumbnail preview, you ask for a preview.  If you need to use AMR audio, you ask for AMR.  There are cases where it would be useful to have more information to choose between alternatives, trading fidelity for size, but as this thread has shown, it is not clear at this time what information is needed to make these trade-offs.

Lets move on.

Greg V.