Subject: Re: [lemonade] IMAP NOTIFY and IDLE

From: "Eric Burger" <[email-masked]>
Date: Tue, 24 Jul 2007 07:56:56 -0700

Can you point to a normative definition of an EMN Protocol?

--
Sent from my wireless e-mail device. Sorry if terse.  We all need lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.

-----Original Message-----
From: Douglas Paul-APD028 <[email-masked]>
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Eric Burger; [email-masked] <[email-masked]>
Sent: Tue Jul 24 07:50:24 2007
Subject: RE: [lemonade] IMAP NOTIFY and IDLE

Hi Zoltan,

Thanks for your reply, I accept the small print is as you describe but I think you'd have to be pretty obtuse to misinterpret what an email notification message is for, given the title and the information provided within the content type OMA EMN.

It's been implemented and tested by your employer and mine as well as several other server and handset manufacturers and is a live service with paying subscribers in a number of regions. 

We need all work together to come up with the best solution for everyone, I don't think that adding another notification mechanism in an area of the business that has already got far too many solutions will help anyone.

Personally, I vote for IMAP Idle in high traffic "always on" situations and OMA EMN in low traffic  "connection on demand" situations - The two solutions aren't mutually exclusive.

I would also like to add that I think the additions that lemonade group has offered in regard to "forward without download", "Quick re-sync", etc, are very valuable additions to the standards and offer solutions to real life primary use cases.

Regards,

/Paul.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 24 July 2007 14:44
To: Douglas Paul-APD028; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [lemonade] IMAP NOTIFY and IDLE

Paul,
I would like to quote the second half on the EMN specification here:

"This specification defines a content type that can be used to notify e-mail clients that new e-mail is available for retrieval on an e-mail server. The e-mail notification (EMN) content can be sent using the WAP Push [PUSH] framework to a device with an EMN User Agent. This specification defines the EMN User Agent to be the client-side application that handles the EMN and triggers the e-mail client for further action. This specification does not define any normative behaviour for e-mail clients nor e-mail servers, as both fall out of the scope of the WAP Forum. Furthermore, this specification is independent of e-mail protocols such as POP3 or IMAP4. Nevertheless, use cases are presented to identify possible usage of the e-mail notification.
The EMN content type is an application of the Extensible Markup Language (XML) 1.0 [XML]. WBXML [WBXML] tokens are defined to allow for efficient over-the-air transmission."

It appears that there is no mechanism - only content type. Well, at least "can use WAP Push" is pretty far from mechanism definion on my scale (sounds more like an example). Specifications are open to (mis)interpretation though...

The specification is published on the OMA web site, draw Your own conclusions:
http://www.openmobilealliance.org/release_program/emn_v10.html

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

>-----Original Message-----
>From: ext Douglas Paul-APD028 [mailto:[email-masked]]
>Sent: 24 July, 2007 11:42
>To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]; 
>[email-masked]; [email-masked]
>Subject: RE: [lemonade] IMAP NOTIFY and IDLE
>
>
>My understanding is that it's an email notification mechanism hence the 
>acronym - EMail Notification.
>
>BTW, I wrote the OMA EMN Software Technical Requirements Specification 
>for my employer.
>
>Zoltan - please take a look at http://www.nokia.com/A4297065
>
>Regards,
>
>/Paul.
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: 23 July 2007 18:01
>To: Douglas Paul-APD028; [email-masked]; [email-masked]; 
>[email-masked]
>Subject: RE: [lemonade] IMAP NOTIFY and IDLE
>
>EMN is merely a content type definition - no mechanism whatsoever.
>
>Best regards: Zoltán Ördögh
>E-mail: zoltan dot ordogh at nokia dot com
>Phone: +358 50 386 0566
>
>>-----Original Message-----
>>From: ext Douglas Paul-APD028 [mailto:[email-masked]]
>>Sent: 23 July, 2007 18:47
>>To: Randall Gellens; Eric Burger; [email-masked]
>>Subject: RE: [lemonade] IMAP NOTIFY and IDLE
>>
>>
>>Please don't shoot me down in flames since I am a newbie on this 
>>mailing list but, if we don't get our finger out won't OMA EMN become 
>>the defacto alternatiive to the NOTIFY mechanism?
>>
>>Paul Douglas
>>European CSC
>>Motorola Limited
>>
>>-----Original Message-----
>>From: Randall Gellens [mailto:[email-masked]]
>>Sent: 23 July 2007 16:30
>>To: Eric Burger; [email-masked]
>>Subject: Re: [lemonade] IMAP NOTIFY and IDLE
>>
>>At 6:25 AM -0500 7/23/07, Eric Burger wrote:
>>
>>>  Is this not the case with IMAP NOTIFY (tell me about events
>>that I am
>>
>>> interested in) and IMAP IDLE (tell me about all events)?
>>
>>A major benefit of NOTIFY is that it can be used for multiple 
>>mailboxes, while IDLE only works for the selected mailbox.  I see 
>>NOTIFY as deprecating or obsoleting IDLE.
>>--
>>Randall Gellens
>>Opinions are personal;    facts are suspect;    I speak for 
>myself only
>>-------------- Randomly-selected tag: --------------- How is
>the world
>>ruled and how do wars start?  Diplomats tell lies to
>>journalists and then believe what they read.             --Karl Kraus
>>
>>
>>_______________________________________________
>>lemonade mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/lemonade
>>Supplemental Web Site:
>>http://www.standardstrack.com/ietf/lemonade
>>
>>
>>_______________________________________________
>>lemonade mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/lemonade
>>Supplemental Web Site:
>>http://www.standardstrack.com/ietf/lemonade
>>
>

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: "Douglas Paul-APD028" <[email-masked]>
Date: Tue, 24 Jul 2007 16:12:06 +0100

OMA EMN is defined here: http://www.openmobilealliance.org/release_program/emn_v10.html - document is called OMA-Push-EMN-v1_0-20040614-C.pdf.

WAP Push (i.e. the mechanism for transmission) is defined here: http://www.openmobilealliance.org/tech/affiliates/wap/wapindex.html document is called AP-235-PushOTA-20010425-a.

Regards,

/Paul.

-----Original Message-----
From: Douglas Paul-APD028 <[email-masked]>
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Eric Burger; [email-masked] <[email-masked]>
Sent: Tue Jul 24 07:50:24 2007
Subject: RE: [lemonade] IMAP NOTIFY and IDLE

Hi Zoltan,

Regards,

/Paul.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 24 July 2007 14:44
To: Douglas Paul-APD028; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [lemonade] IMAP NOTIFY and IDLE

Paul,