Subject: [lemonade] IMAP-SIEVE

From: Eric Burger <[email-masked]>
Date: Sun, 22 Jul 2007 02:10:19 -0400

Any comments on IMAP sieve?

http://tools.ietf.org/html/draft-ietf-lemonade-imap-sieve-03

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: <[email-masked]>
Date: Sun, 22 Jul 2007 17:34:35 +0300

Just two editorial:
1.
Abstract:
"Sieve defines an email filtering language that can, in principle,
   plug into any point in the processing of an email message"
2.2:
"The subsections below describe in detail the IMAP commands and
   situations on which IMAPSieve has an effect."
Isn't this contradicting? One is SIEVE, the other is IMAPSieve, so I am not sure.

2.
1.2:
"In examples, "C:" and "S:" indicate lines sent by the client and
   server respectively."
 You could remove this as there are no examples in this document.

Thank You.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

>-----Original Message-----
>From: ext Eric Burger [mailto:[email-masked]] 
>Sent: 22 July, 2007 09:10
>To: [email-masked]
>Subject: [lemonade] IMAP-SIEVE
>
>Notice:  This email message, together with any attachments, 
>may contain information  of  BEA Systems,  Inc.,  its 
>subsidiaries  and  affiliated entities,  that may be 
>confidential,  proprietary,  copyrighted  and/or legally 
>privileged, and is intended solely for the use of the 
>individual or entity named in this message. If you are not the 
>intended recipient, and have received this message in error, 
>please immediately return this by email and then delete it.
>
>

---

From: Stephan Bosch <[email-masked]>
Date: Tue, 31 Jul 2007 14:21:56 +0200

> http://tools.ietf.org/html/draft-ietf-lemonade-imap-sieve-03
I don't know whether this is the correct time and place to post this 
suggestion, but I'll do it anyway. I apologize if the suggested 
functionality is not within the scope of this proposed IMAP extension 
(or lemonade for that matter).

IMAPSieve currently only suggests running sieve scripts when certain 
IMAP commands are executed, apart from running a sieve script upon 
delivery. What I currently miss in the Sieve world is the ability for a 
client to simply run a sieve script on a folder when requested by the 
user (i.e. by issueing a new IMAP command). Many mail clients that 
support some form of filtering also include functionality to apply the 
currently defined filters on a specific folder or a set of messages. 
This is especially useful when the current filterset has misdelivered a 
large number of messages to a specific folter; the user can fix this by 
updating the filters accordingly and applying the filters to the folder 
in question. Of course the mail client could do this using a sequence of 
IMAP commands, but this does not test the new Sieve script on the server.

Just a thought...

Regards,

--
Stephan Bosch
[email-masked]