Subject: [lemonade] Dealing with in accessible mailboxes in NOTIFY

From: Cyrus Daboo <[email-masked]>
Date: Mon, 23 Jul 2007 14:44:55 -0500

Hi,
As discussed in the WG meeting, my proposal to avoid return NO for a 
failure on some mailboxes but not others is:

client does not have 'l' access to mailbox: return \NonExistent flag in 
LIST response for that mailbox

client has 'l' but no other access to mailbox: return \NoAccess flag in 
LIST response for that mailbox

The overall response still ends up being OK. The client will know exactly 
which mailboxes in the list are causing a problem and will know not to 
expect any notifications for those.

-- 
Cyrus Daboo

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 23 Jul 2007 22:00:21 +0200

Cyrus Daboo writes:
> client does not have 'l' access to mailbox: return \NonExistent flag 
> in LIST response for that mailbox
>
> client has 'l' but no other access to mailbox: return \NoAccess flag 
> in LIST response for that mailbox
>
> The overall response still ends up being OK. The client will know 
> exactly which mailboxes in the list are causing a problem and will 
> know not to expect any notifications for those.

Hm. Do you also think this is an appropriate way to handle ACL changes 
that lead to loss/gain of rights?

(This is a lot of effort for very unusual cases...)

Arnt