Subject: Re: [lemonade] Imap-notify-07 - Mailbox Names

From: Eric Burger <[email-masked]>
Date: Wed, 01 Aug 2007 11:20:12 -0500

The client inserts a mailbox name or list of mailbox names after the
"mailboxes" token.  The server MUST NOT do wildcard expansion.  This means
there is no special treatment for the LIST wildcard characters ('*' and '%')
if they are present in mailbox names.

On 7/26/07 2:45 PM, "Alexey Melnikov" <[email-masked]> wrote:

> Eric Burger wrote:
> 
>> What does section 6.6 mean when it says LIST wildcards are not special?
>> 
>> Does that mean:
>> (1) you can address mailboxes that contain * and %?
>> (2) simply that you cannot search (in which case, do you get BAD or NO)?
>> (3) something else?
>> (4) all of the above?
>>  
>> 
> The intent was (1). Of course any server that allows for mailboxes
> containing * and % is already strange
> (And any client that tryies to create them is broken)
> 
> Do you have a suggestion how to improve the text?
> 

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 01 Aug 2007 14:12:03 -0600

>if they are present in mailbox names.
Ok, I've used the last 2 sentences. Thanks for the suggestion.