Subject: Re: [lemonade] IMAP resume

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 16 Jan 2009 13:13:53 +0100

FWIW.

A friend who uses IMAP on his phone _all_ the time says that with his 
provider, he doesn't get TCP connection outages or IP address changes. 
If he loses coverage, there's 100% packet loss for a while, but the TCP 
connections aren't torn down and he gets the same IP address again 
after the outage. He's happy with the way IMAP works.

I'm happy that at least one telco has engineered its network to make 
existing software work well.

The provider is Deutsche Telekom's mobile subsidiary, whatever it's 
called right now.

Arnt
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Dave Cridland <[email-masked]>
Date: Fri, 16 Jan 2009 12:25:57 +0000

On Fri Jan 16 12:13:53 2009, Arnt Gulbrandsen wrote:
> FWIW.
> 
> A friend who uses IMAP on his phone _all_ the time says that with  
> his provider, he doesn't get TCP connection outages or IP address  
> changes. If he loses coverage, there's 100% packet loss for a  
> while, but the TCP connections aren't torn down and he gets the  
> same IP address again after the outage. He's happy with the way  
> IMAP works.
> 
> I'm happy that at least one telco has engineered its network to  
> make existing software work well.

I'm able to similarly hold an IMAP or XMPP connection through the  
(4-mile long) Severn tunnel using Orange's UK network, which  
certainly involves a tower-change.

Also, dormant connections don't appear to get severed.

It could be that I'm just not noticing the horror, or things might  
finally be improving.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 16 Jan 2009 14:21:23 +0100

Dave Cridland writes:
> things might  finally be improving.

On that note, happy new year to everyone!

Arnt

---

From: Ned Freed <[email-masked]>
Date: Fri, 16 Jan 2009 06:52:54 -0800 (PST)

> certainly involves a tower-change.

FWIW, I recently switched data service providers and I immediately noticed
similar effects: Used to be when I lost my connection and got it back I'd
always have a different IP address. With the new service this no longer occurs.

> Also, dormant connections don't appear to get severed.

This, OTOH, is still a problem sometimes. And sometimes not - I can't quite
figure it out.

> It could be that I'm just not noticing the horror, or things might

Maybe. But keep in mind that the plural of anecdote is not data.

				Ned