Subject: [lemonade] QRESYNC + \Recent flags

From: Timo Sirainen <[email-masked]>
Date: Sun, 15 Apr 2012 18:09:34 +0300

Something I just realized:

\Recent flag is kind of a special flag. Neither CONDSTORE nor QRESYNC RFC explicitly says what to do with it. I'd think there is no requirement to increase a message's MODSEQ when dropping its \Recent flag? But a client might still want to know when a mailbox has been SELECTed, so even if message MODSEQs themselves don't change, the mailbox's HIGHESTMODSEQ probably should.

Currently Dovecot doesn't change either of them.

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sun, 15 Apr 2012 18:00:47 +0200

Oh please. Say pine instead of "a client" and you're true to the truest if imap traditions.

Arnt

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 17 Apr 2012 12:36:04 +0100

Hi Timo,

On 15/04/2012 16:09, Timo Sirainen wrote:
> \Recent flag is kind of a special flag. Neither CONDSTORE nor QRESYNC RFC explicitly says what to do with it.
Hmm, I've just checked and I think you are right.
> I'd think there is no requirement to increase a message's MODSEQ when dropping its \Recent flag? But a client might still want to know when a mailbox has been SELECTed,
Do you see a use case for that?
> so even if message MODSEQs themselves don't change, the mailbox's HIGHESTMODSEQ probably should.
I suppose no harm in updating the HIGHESTMODSEQ, but I honestly wouldn't 
bother, unless you have a good use case.
> Currently Dovecot doesn't change either of them.
Isode's implementation doesn't change any of them either.

---

From: Timo Sirainen <[email-masked]>
Date: Wed, 18 Apr 2012 19:37:18 +0300

On 17.4.2012, at 14.36, Alexey Melnikov wrote:

> I suppose no harm in updating the HIGHESTMODSEQ, but I honestly wouldn't bother, unless you have a good use case.

Perhaps not.. I noticed it only because I was writing a syncing tool that used modseqs to figure out what changed. (And actually I'm not going to need it there either, I solved it another way.) A client that wants to know about it can approximate it pretty well with STATUS (RECENT), although that can't catch everything.