Subject: Re: [lemonade] BINARY & CATENATE

From: Timo Sirainen <[email-masked]>
Date: Thu, 13 Jun 2013 18:04:25 +0300

On 9.3.2006, at 4.30, Ken Murchison <[email-masked]> wrote:

> With the help of the good folks at Lucent I've been working on adding support for BINARY APPEND to Cyrus (to go along with its existing support for BINARY FETCH).
> 
> I'm now wondering if I need to support BINARY (literal8) for CATENATE (TEXT parts)?  I don't see any mention of BINARY or literal8 in the CATENATE draft.
> 
> And what about CTE=binary in messages/parts fetched via URLs?

Old message :) How was this eventually implemented to Cyrus? Or how do people think it should work? I was also wondering about this a year ago: http://mailman2.u.washington.edu/pipermail/imap-protocol/2012-June/001787.html

I'm now again wondering if I should change how it works.

---

From: Dave Cridland <[email-masked]>
Date: Fri, 14 Jun 2013 10:50:04 +0100

On Thu, Jun 13, 2013 at 4:04 PM, Timo Sirainen <[email-masked]> wrote:

> > With the help of the good folks at Lucent I've been working on adding
> support for BINARY APPEND to Cyrus (to go along with its existing support
> for BINARY FETCH).
> >
> > I'm now wondering if I need to support BINARY (literal8) for CATENATE
> (TEXT parts)?  I don't see any mention of BINARY or literal8 in the
> CATENATE draft.
> >
> Old message :) How was this eventually implemented to Cyrus? Or how do
> people think it should work? I was also wondering about this a year ago:
> http://mailman2.u.washington.edu/pipermail/imap-protocol/2012-June/001787.html
>

So looking at that, I note that literal8 is actually literalNUL - <literal>
is defined as being made up of <CHAR8>, which is any octet except NUL. So
you can have messages you need to rewrite even if they don't use literal8
syntax in the upload.

I would, in general, scan and if needs be reformat the message on any
APPEND. You're allowed to do this by RFC 3501, which specifically allows it
in the case where your underlying message store is only 7-bit capable.

Dave

---

From: Timo Sirainen <[email-masked]>
Date: Sat, 15 Jun 2013 10:43:16 +0300

On 14.6.2013, at 12.50, Dave Cridland <[email-masked]> wrote:

> So looking at that, I note that literal8 is actually literalNUL - <literal> is defined as being made up of <CHAR8>, which is any octet except NUL. So you can have messages you need to rewrite even if they don't use literal8 syntax in the upload.
> 
> I would, in general, scan and if needs be reformat the message on any APPEND. You're allowed to do this by RFC 3501, which specifically allows it in the case where your underlying message store is only 7-bit capable.

Hmh. Maybe this should be done the other way around. Save C-T-E=binary mails as is, and do the necessary translation at FETCH time instead so any digital signatures wouldn't break either. But it would be nice if clients could get C-T-E=binary BODYSTRUCTURE replies and such. Perhaps a new BINARY extension that supports "ENABLE BINARY" for clients that allows sending them literal8 for FETCH replies?

Although how common is C-T-E=binary support anyway? Is it required by something? Is it becoming more common in future? Is there any point in spending time on this?..