Subject: [lemonade] IMAP IDLE Implementation issue

From: Samsung SVL <[email-masked]>
Date: Thu, 21 Nov 2013 14:01:48 -0800 (PST)

Hi All,

Please clarify my query regarding the IMAP IDLE support. 

Assume user has configured an IMAP IDLE supported account in a mobile device. IMAP server notifies the new mail and everything works fine. 

Now, if user moves to no network connection area, IMAP idle connection is terminated with server. At this time, user received 10 emails which is not downloaded from the server. 

After sometime, user moves to network area, now a new IMAP idle connection is established with the IMAP server and waiting for the new email. Still old 10 emails are not delivered to the device.

Is there any way in IMAP protocol to get those 10 emails received during the no network from the IMAP server ? Please clarify. 

Regards,
Jay

---

From: Jan Kundrát <[email-masked]>
Date: Thu, 21 Nov 2013 23:07:46 +0100

On Thursday, 21 November 2013 23:01:48 CEST, Samsung SVL wrote:
> After sometime, user moves to network area, now a new IMAP idle 
> connection is established with the IMAP server and waiting for 
> the new email. Still old 10 emails are not delivered to the 
> device.

When the conenction gets restored, the MUA issues the SELECT command once 
again. Based on the last known state of the mailbox which the MUA has 
cached locally (which gets updated over the course of the connection 
whenever the server sends anything), and the newly reported facts (see the 
mandatory responses to SELECT), the MUA detects that 10 messages have 
arrived since its last connection. The MUA then performs whatever operation 
is usually executes upon new mail arrival.

Cheers,
Jan

-- 
Trojitá, a fast Qt IMAP e-mail client -- http://trojita.flaska.net/