Subject: [lemonade] [Lemonade] Forwarded Flag Support

From: Jayantheesh S B <[email-masked]>
Date: Wed, 21 May 2014 14:37:02 +0000

Hi All,

Kindly clarify my query regarding IMAP Forwarded flag support.

If ["\Answered", "$Forwarded", "Forwarded",] both Answered and Forwarded  is set to a message, which flag should be given preference to show to user.

Microsoft Outlook shows last performed action. For example, if a message is forwarded followed by reply, then reply icon is shown.
Their server have the intelligent of capturing last performed action and updates the client.

I guess, we do not have any such option in IMAP to inform last performed action for a message. Kindly throw some light on this.

RFC - http://tools.ietf.org/html/rfc5788

Log Snippet:
                Line 1792: 2014-05-20 20:00:42:644 2305 2324 [tMsgContr] Email| <<< #null# ["14", "FETCH", ["UID", "1370", "FLAGS", ["\Seen", "XAOL-RECEIVED", "XAOL-GOOD", "XAOL-GOODCHECK-DONE", "XAOL-READ"]]]

                Line 1793: 2014-05-20 20:00:42:648 2305 2324 [tMsgContr] Email| <<< #null# ["15", "FETCH", ["UID", "1371", "FLAGS", ["\Answered", "\Seen", "XAOL-RECEIVED", "XAOL-GOOD", "XAOL-GOODCHECK-DONE", "XAOL-READ"]]]

                Line 1794: 2014-05-20 20:00:42:652 2305 2324 [tMsgContr] Email| <<< #null# ["16", "FETCH", ["UID", "1410", "FLAGS", ["\Answered", "$Forwarded", "Forwarded", "\Seen", "XAOL-RECEIVED", "XAOL-GOOD", "XAOL-GOODCHECK-DONE", "XAOL-READ"]]]

Regards,
Jay

---

From: Dave Cridland <[email-masked]>
Date: Wed, 21 May 2014 15:38:40 +0100

Surely you'd show them both?

On 21 May 2014 15:37, Jayantheesh S B <[email-masked]> wrote:

> If ["\Answered", "$Forwarded", "Forwarded",] both Answered and Forwarded
>  is set to a message, which flag should be given preference to show to
> user.
>
>
>
> Microsoft Outlook shows last performed action. For example, if a message
> is forwarded followed by reply, then reply icon is shown.
>
> I guess, we do not have any such option in IMAP to inform last performed
> action for a message. Kindly throw some light on this.
>
>
>
> *RFC - http://tools.ietf.org/html/rfc5788
> <http://tools.ietf.org/html/rfc5788>*
>
>
>
> *Log Snippet:*
>
>                 Line 1792: 2014-05-20 20:00:42:644 2305 2324 [tMsgContr]
> Email| <<< #null# ["14", "FETCH", ["UID", "1370", "FLAGS", ["\Seen",
> "XAOL-RECEIVED", "XAOL-GOOD", "XAOL-GOODCHECK-DONE", "XAOL-READ"]]]
>
>
>
>                 Line 1793: 2014-05-20 20:00:42:648 2305 2324 [tMsgContr]
> Email| <<< #null# ["15", "FETCH", ["UID", "1371", "FLAGS", ["\Answered",
> "\Seen", "XAOL-RECEIVED", "XAOL-GOOD", "XAOL-GOODCHECK-DONE", "XAOL-READ"]]]
>
>
>
>                 Line 1794: 2014-05-20 20:00:42:652 2305 2324 [tMsgContr]
> Email| <<< #null# ["16", "FETCH", ["UID", "1410", "FLAGS", ["\Answered",
> "$Forwarded", "Forwarded", "\Seen", "XAOL-RECEIVED", "XAOL-GOOD",
> "XAOL-GOODCHECK-DONE", "XAOL-READ"]]]
>
>
>
>
>
> Regards,
>
> Jay
>
> _______________________________________________
> lemonade mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lemonade
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/lemonade
>

---

From: Jayantheesh S B <[email-masked]>
Date: Wed, 21 May 2014 14:52:10 +0000

If at all I need my client to work similar to Microsoft behavior, to make consistent user experience across protocols.

Which one can be give preference ?

From: Dave Cridland [mailto:[email-masked]]
Sent: Wednesday, May 21, 2014 10:39 AM
To: Jayantheesh S B
Cc: [email-masked]
Subject: Re: [lemonade] [Lemonade] Forwarded Flag Support

On 21 May 2014 15:37, Jayantheesh S B <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

Log Snippet:

Regards,
Jay

_______________________________________________
lemonade mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Jan Kundrát <[email-masked]>
Date: Wed, 21 May 2014 17:30:51 +0200

On Wednesday, 21 May 2014 16:52:10 CEST, Jayantheesh S B wrote:
> If at all I need my client to work similar to Microsoft 
> behavior, to make consistent user experience across protocols.

The correct behavior is showing both of these flags at once. It is also 
rather trivial to do it in the GUI -- a common idiom is to use arrows, see 
e.g. these attached images.

With kind regards,
Jan

-- 
Trojitá, a fast Qt IMAP e-mail client -- http://trojita.flaska.net/

---

From: Anil SRIVASTAVA <[email-masked]>
Date: Wed, 21 May 2014 16:44:54 +0000

You would want to show both.  That is what Thunderbird does.  It is 
rather simple to do that in GUI.

Anil

On 05/21/14 02:37 PM, Jayantheesh S B wrote:
> If ["\Answered", "$Forwarded", "Forwarded",] both Answered and 
> Forwarded  is set to a message, which flag should be given preference 
> to show to user.
>
> Microsoft Outlook shows last performed action. For example, if a 
> message is forwarded followed by reply, then reply icon is shown.
>
> I guess, we do not have any such option in IMAP to inform last 
> performed action for a message. Kindly throw some light on this.
>
> *RFC - http://tools.ietf.org/html/rfc5788*
>
> *Log Snippet:*
>
> Line 1792: 2014-05-20 20:00:42:644 2305 2324 [tMsgContr] Email| <<< 
> #null# ["14", "FETCH", ["UID", "1370", "FLAGS", ["\Seen", 
> Line 1793: 2014-05-20 20:00:42:648 2305 2324 [tMsgContr] Email| <<< 
> #null# ["15", "FETCH", ["UID", "1371", "FLAGS", ["\Answered", "\Seen", 
> Line 1794: 2014-05-20 20:00:42:652 2305 2324 [tMsgContr] Email| <<< 
> #null# ["16", "FETCH", ["UID", "1410", "FLAGS", ["\Answered",