Subject: [lemonade] [Technical Errata Reported] RFC4469 (4046)

From: RFC Errata System <[email-masked]>
Date: Thu, 10 Jul 2014 10:23:05 -0700 (PDT)

The following errata report has been submitted for RFC4469,
"Internet Message Access Protocol (IMAP) CATENATE Extension".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4469&eid=4046

--------------------------------------
Type: Technical
Reported by: Chris Newman <[email-masked]>

Section: Appendix A

Original Text
-------------
   S: A003 NO [BADURL "/INBOX;UIDVALIDITY=785799047/;UID=113330;
   section=1.5.9"] CATENATE append has failed, one message expunged

Corrected Text
--------------
   S: A003 NO [BADURL /INBOX;UIDVALIDITY=785799047/;UID=113330;
   section=1.5.9] CATENATE append has failed, one message expunged

Notes
-----
Although this example technically follows the ABNF for url-resp-text in section 5 by treating the double-quotes as part of the content of the url-resp-text rule, it is incorrect because it does not follow the additional guidance in section 5 that states:

   The astring in the definition of url and the url-resp-text in the
   definition of badurl-response-code each contain an imapurl as defined
   by [2].

Reference [2] defines IMAP URLs. In that RFC, a string surrounded by double quotes is not a valid IMAP URL. Thus the example is incorrect and the double quotes should be removed so the example aligns with the normative formal syntax.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4469 (draft-ietf-lemonade-catenate-05)
--------------------------------------
Title               : Internet Message Access Protocol (IMAP) CATENATE Extension
Publication Date    : April 2006
Author(s)           : P. Resnick
Category            : PROPOSED STANDARD
Source              : Enhancements to Internet email to support diverse service environments
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Stephan Bosch <[email-masked]>
Date: Fri, 11 Jul 2014 11:51:51 +0200

Hi,

> Original Text

This problem is also somewhat relevant here:

http://mailman13.u.washington.edu/pipermail/imap-protocol/2014-January/002146.html

Even though CATENATE doesn't deal with absolute URLs, these could 
conceivably be returned in a BADURL response when the client uses those 
anyway.

In practice, compliant clients won't send these, but still.

Regards,

Stephan.