Subject: [lemonade] [Errata Verified] RFC4469 (4046)

From: RFC Errata System <[email-masked]>
Date: Thu, 10 Jul 2014 11:01:51 -0700 (PDT)

The following errata report has been verified for RFC4469,
"Internet Message Access Protocol (IMAP) CATENATE Extension". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4469&eid=4046

--------------------------------------
Status: Verified
Type: Technical

Reported by: Chris Newman <[email-masked]>
Date Reported: 2014-07-10
Verified by: Barry Leiba (IESG)

Section: Appendix A

Original Text
-------------
   S: A003 NO [BADURL "/INBOX;UIDVALIDITY=785799047/;UID=113330;
   section=1.5.9"] CATENATE append has failed, one message expunged

Corrected Text
--------------
   S: A003 NO [BADURL /INBOX;UIDVALIDITY=785799047/;UID=113330;
   section=1.5.9] CATENATE append has failed, one message expunged

Notes
-----
This example treats the url-resp-text in the badurl-response-code as though it were an astring.  It is not: it is a bare imapurl, as stated in section 5:

   "The astring in the definition of url and the url-resp-text in the
   definition of badurl-response-code each contain an imapurl as defined
   by [2]."

The example is incorrect, in that the double quotes should be removed so the url-resp-text is a valid imapurl, and only that.

--------------------------------------
RFC4469 (draft-ietf-lemonade-catenate-05)
--------------------------------------
Title               : Internet Message Access Protocol (IMAP) CATENATE Extension
Publication Date    : April 2006
Author(s)           : P. Resnick
Category            : PROPOSED STANDARD
Source              : Enhancements to Internet email to support diverse service environments
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Dave Cridland <[email-masked]>
Date: Fri, 11 Jul 2014 19:33:41 +0100

>    definition of badurl-response-code each contain an imapurl as defined
I parsed that sentence three times to imply that url-resp-text was an
astring.

It doesn't say that, but I kept reading "The astring in the definition of
url and the url-resp-text" as a unit - I'd say that's begging for a comma.

I wonder what actual implementations do.

Dave.