Subject: [Lime] Layer-transcending OAM?

From: Erik Nordmark <[email-masked]>
Date: Wed, 04 Mar 2015 21:32:12 -0800

This draft makes 3 points:
  - we shouldn't hard-code a policy of layer isolation as we think about
OAM for NVO3 and other encapsulations
  - NVO3 encaps might consider enabling the ttl behavior which enables
this form of traceroute
  - this is easy for VXLAN encapsulation - needs a bit in the VXLAN header

The first point is relevant to the OAM architecture and model discussion in LIME.
In Honolulu there were comments at the mike about thinking about the Internet OAM model in addition to the Ethernet OAM model, and I think this property of traceroute is part of the Internet OAM model.

I hope that first point can trigger some discussion about the model in LIME.

Thanks,
  Erik

-------- Forwarded Message --------
Subject: 	New Version Notification for 
draft-nordmark-nvo3-transcending-traceroute-00.txt
Date: 	Wed, 04 Mar 2015 18:48:12 -0800
From: 	[email-masked]
To: 	Chandra Appanna <[email-masked]>, Erik Nordmark 
<[email-masked]>, Alton Lo <[email-masked]>, Alton Lo 
<[email-masked]>, Erik Nordmark <[email-masked]>, Chandra 
Appanna <[email-masked]>

A new version of I-D, draft-nordmark-nvo3-transcending-traceroute-00.txt
has been successfully submitted by Erik Nordmark and posted to the
IETF repository.

Name:		draft-nordmark-nvo3-transcending-traceroute
Revision:	00
Title:		Layer-Transcending Traceroute for Overlay Networks like VXLAN
Document date:	2015-03-02
Group:		Individual Submission
Pages:		18
URL:            http://www.ietf.org/internet-drafts/draft-nordmark-nvo3-transcending-traceroute-00.txt
Status:         https://datatracker.ietf.org/doc/draft-nordmark-nvo3-transcending-traceroute/
Htmlized:       http://tools.ietf.org/html/draft-nordmark-nvo3-transcending-traceroute-00

Abstract:
    Tools like traceroute have been very valuable for the operation of
    the Internet.  Part of that value comes from being able to display
    information about routers and paths over which the user of the tool
    has no control, but the traceroute output can be passed along to
    someone else that can further investigate or fix the problem.

    In overlay networks such as VXLAN and NVGRE the prevailing view is
    that since the overlay network has no control of the underlay there
    needs to be special tools and agreements to enable extracting traces
    from the underlay.  We argue that enabling visibility into the
    underlay and using existing tools like traceroute has been overlooked
    and would add value in many deployments of overlay networks.

    This document specifies an approach that can be used to make
    traceroute transcend layers of encapsulation including details for
    how to apply this to VXLAN.  The technique can be applied to other
    encapsulations used for overlay networks.  It can also be implemented
    using current commercial silicon.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Thu, 5 Mar 2015 15:19:46 +0000

Hi Erik,

Generic Yang draft for OAM is for Management and it's not enforcing or
proposing strict layering, filtering model. It's bringing concept of Data
Model from Ethernet OAM but adding IP specifics for Multipath support.
Also it's providing way for operator to go over OAM data hierarchy if
present.

Thanks,
Deepak

On 3/4/15 9:32 PM, "Erik Nordmark" <[email-masked]> wrote:

>In Honolulu there were comments at the mike about thinking about the
>Internet OAM model in addition to the Ethernet OAM model, and I think
>this property of traceroute is part of the Internet OAM model.
>
>URL:            
>http://www.ietf.org/internet-drafts/draft-nordmark-nvo3-transcending-trace
>route-00.txt
>Status:         
>https://datatracker.ietf.org/doc/draft-nordmark-nvo3-transcending-tracerou
>te/
>Htmlized:       
>http://tools.ietf.org/html/draft-nordmark-nvo3-transcending-traceroute-00
>
>
>Abstract:
>_______________________________________________
>Lime mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/lime

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 05 Mar 2015 15:34:58 -0800

> Also it's providing way for operator to go over OAM data hierarchy if

Deepak,

I haven't looked carefully at the Yang model draft to see whether it 
actually *prevents* layer-trancendence, but from the architecture/model 
discussion in Honolulu (that Norm presented) I got the impression that 
the layers are completely isolated.

If the Yang draft wants to *enable* layer-trancendence, then I suspect 
it needs to have a way to configure the ttl behavior at the tunnel 
endpoints to be able to select between the pipe and uniform ttl tunnel 
models.

Thus I think the LIME WG should discuss this part of the OAM model.

Regards,
    Erik

---

From: Qin Wu <[email-masked]>
Date: Fri, 6 Mar 2015 04:56:42 +0000

Hi:
Since it is relevant to the OAM architecture and model discussion in LIME, it would be nice and fair to cite
https://tools.ietf.org/html/draft-edprop-opsawg-multi-layer-oam-ps-00

LIME model is a generic model in the management plane.
LIME model should work irrespective of layer being honored or being relaxed.
LIME model should work independent of data plane OAM protocols in different portions of the network using various transport technologies.
Any data plane OAM protocol extension is not in the scope of LIME WG. I think layer-transcending traceroute is data plane OAM protocol extension.

Regards!
-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Erik Nordmark
发送时间: 2015年3月5日 13:32
收件人: [email-masked]
主题: [Lime] Layer-transcending OAM?

This draft makes 3 points:
  - we shouldn't hard-code a policy of layer isolation as we think about OAM for NVO3 and other encapsulations
  - NVO3 encaps might consider enabling the ttl behavior which enables this form of traceroute
  - this is easy for VXLAN encapsulation - needs a bit in the VXLAN header

Thanks,
  Erik

-------- Forwarded Message --------
<[email-masked]>, Alton Lo <[email-masked]>, Alton Lo <[email-masked]>, Erik Nordmark <[email-masked]>, Chandra Appanna <[email-masked]>

A new version of I-D, draft-nordmark-nvo3-transcending-traceroute-00.txt
has been successfully submitted by Erik Nordmark and posted to the IETF repository.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Loa Andersson <[email-masked]>
Date: Fri, 06 Mar 2015 13:37:11 +0800

Erik, et.al.,

While I agree that it is proper for the LIME working group to
discuss this, the decision to create Layer-transcending OAM is not
entirely up to LIME.

"Generic" has the implication - "for everyone to use". If you are doing
things for others to use you need to be sure that the intended users
actually want and need what you are proposing, and that it does not
cause problems for one data plane if another uses your generic model.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 6 Mar 2015 06:08:06 +0000

Dear All,
I think it is worth to point that after meeting in Honolulu the LIME WG formed the Design Team to investigate whether there indeed are sufficient commonality among several OAM models in IETF domain - IP, IP/MPLS, MPLS-TP, TRILL. The document you reference yet not been adopted by the LIME WG and till then is individual draft.

	Regards,
		Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Thursday, March 05, 2015 9:37 PM
To: Erik Nordmark; [email-masked]
Subject: Re: [Lime] Layer-transcending OAM?

Erik, et.al.,

While I agree that it is proper for the LIME working group to discuss this, the decision to create Layer-transcending OAM is not entirely up to LIME.

"Generic" has the implication - "for everyone to use". If you are doing things for others to use you need to be sure that the intended users actually want and need what you are proposing, and that it does not cause problems for one data plane if another uses your generic model.

/Loa

On 2015-03-06 07:34, Erik Nordmark wrote:
>> Generic Yang draft for OAM is for Management and it's not enforcing 
>> or proposing strict layering, filtering model. It's bringing concept 
>> of Data Model from Ethernet OAM but adding IP specifics for Multipath support.
> actually *prevents* layer-trancendence, but from the 
> architecture/model discussion in Honolulu (that Norm presented) I got 
> the impression that the layers are completely isolated.
>
>>>   - we shouldn't hard-code a policy of layer isolation as we think 
>>> about OAM for NVO3 and other encapsulations
>>> Internet OAM model in addition to the Ethernet OAM model, and I 
>>> think this property of traceroute is part of the Internet OAM model.
>>>
>>> A new version of I-D, 
>>> Please note that it may take a couple of minutes from the time of 
>>> submission until the htmlized version and diff are available at 
>>> tools.ietf.org.
>>>
>>> The IETF Secretariat
>>>
>>>

--

---

From: Loa Andersson <[email-masked]>
Date: Fri, 06 Mar 2015 14:14:59 +0800

Greg,

does "sufficient commonality" mean that you intend to find a common
way to do oam for different data planes, or does it mean that you
intend to interwork oam for differernt data planes?

/Loa

--

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 6 Mar 2015 06:30:30 +0000

Hi Loa,
my understanding is that it is the former - common model to express and control OAM on various data planes. Transcending, in my view, requires not just understanding of OAM model but understanding of defect data model.

	Regards,
		Greg

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Thursday, March 05, 2015 10:15 PM
To: Gregory Mirsky; Erik Nordmark; [email-masked]
Subject: Re: [Lime] Layer-transcending OAM?

Greg,

does "sufficient commonality" mean that you intend to find a common way to do oam for different data planes, or does it mean that you intend to interwork oam for differernt data planes?

/Loa

On 2015-03-06 14:08, Gregory Mirsky wrote:
>>> Also it's providing way for operator to go over OAM data hierarchy 
>>> if present.
>>
>> Deepak,
>>
>> If the Yang draft wants to *enable* layer-trancendence, then I 
>> suspect it needs to have a way to configure the ttl behavior at the 
>> tunnel endpoints to be able to select between the pipe and uniform 
>> ttl tunnel models.
>>
>>>> In Honolulu there were comments at the mike about thinking about 
>>>> the Internet OAM model in addition to the Ethernet OAM model, and I 
>>>> http://www.ietf.org/internet-drafts/draft-nordmark-nvo3-transcendin
>>>> g
>>>> -trace
>>>>
>>>> route-00.txt
>>>> Status:
>>>> https://datatracker.ietf.org/doc/draft-nordmark-nvo3-transcending-t
>>>> r
>>>> acerou
>>>>
>>>> te/
>>>> Htmlized:
>>>> http://tools.ietf.org/html/draft-nordmark-nvo3-transcending-tracero
>>>> u
>>>> te-00
>>>>
>>>>
>>>>
>>>> Abstract:

--

---

From: Loa Andersson <[email-masked]>
Date: Fri, 06 Mar 2015 14:33:40 +0800

Greg,

Thanks - as long as we are looking at common ways to do things I'm
comfortable. Interworking OAM for different data planes is a totally
kettle of fish.

/Loa

--

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 06 Mar 2015 10:14:29 +0100

Hello Loa,

> comfortable. Interworking OAM for different data planes is a totally

To catch those fish a can of worms has to be opened, which is even
worse

Regards, Huub.

>> my understanding is that it is the former - common model to express
>> and control OAM on various data planes. Transcending, in my view,
>> requires not just understanding of OAM model but understanding of
>> defect data model.
>>
>>     Regards,
>>         Greg
>>
>>> I think it is worth to point that after meeting in Honolulu the LIME
>>> WG formed the Design Team to investigate whether there indeed are
>>> sufficient commonality among several OAM models in IETF domain - IP,
>>> IP/MPLS, MPLS-TP, TRILL. The document you reference yet not been
>>> adopted by the LIME WG and till then is individual draft.
>>>
>>>     Regards,
>>>         Greg
>>>
>>> While I agree that it is proper for the LIME working group to discuss
>>> this, the decision to create Layer-transcending OAM is not entirely
>>> up to LIME.
>>>
>>> "Generic" has the implication - "for everyone to use". If you are
>>> doing things for others to use you need to be sure that the intended
>>> users actually want and need what you are proposing, and that it does
>>> not cause problems for one data plane if another uses your generic
>>> model.
>>>
>>> /Loa
>>>

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 06 Mar 2015 10:35:14 +0100

Hello Qin.

> LIME model is a generic model in the management plane.

OK.

> LIME model should work irrespective of layer being honored or being

Layer-transcending would prevent this.

> LIME model should work independent of data plane OAM protocols in
> different portions of the network using various transport
> technologies.

Layer-transcending is discouraged in the data-plane,
the LIME model should follow this/

> Any data plane OAM protocol extension is not in the scope of LIME WG.

I agree.

> I think layer-transcending traceroute is data plane OAM protocol
> extension.

And this should be discouraged.

Regards, Huub.

---

From: Qin Wu <[email-masked]>
Date: Fri, 6 Mar 2015 10:31:48 +0000

Agree,
interworking OAM for different data planes is something we early discussed in draft-edprop-opsawg-multi-layer-oam-ps.
But now I believe this piece as part of data plane OAM is not in the scope of LIME WG.

-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Huub van Helvoort
发送时间: 2015年3月6日 17:14
收件人: Loa Andersson; Gregory Mirsky; Erik Nordmark; [email-masked]
主题: Re: [Lime] Layer-transcending OAM?

Hello Loa,

> comfortable. Interworking OAM for different data planes is a totally 

To catch those fish a can of worms has to be opened, which is even worse

Regards, Huub.

>>> users actually want and need what you are proposing, and that it 
>>> does not cause problems for one data plane if another uses your 
>>> generic model.
>>>
>>> /Loa
>>>
>>>>> Generic Yang draft for OAM is for Management and it's not 
>>>>> enforcing or proposing strict layering, filtering model. It's 
>>>>> bringing concept of Data Model from Ethernet OAM but adding IP 
>>>>> specifics for Multipath support.
>>>> I haven't looked carefully at the Yang model draft to see whether 
>>>> it actually *prevents* layer-trancendence, but from the 
>>>> architecture/model discussion in Honolulu (that Norm presented) I 
>>>> got the impression that the layers are completely isolated.
>>>>
>>>>>>     - we shouldn't hard-code a policy of layer isolation as we 
>>>>>> think about OAM for NVO3 and other encapsulations
>>>>>> the Internet OAM model in addition to the Ethernet OAM model, and 
>>>>>> I think this property of traceroute is part of the Internet OAM model.
>>>>>>
>>>>>> <[email-masked]>, Erik Nordmark <[email-masked]>, 
>>>>>> Chandra Appanna <[email-masked]>
>>>>>>
>>>>>>
>>>>>>
>>>>>> A new version of I-D,

---

From: Qin Wu <[email-masked]>
Date: Fri, 6 Mar 2015 10:45:27 +0000

Huub:
I agree the LIME should respect strict OAM layering if layer transcending is discouraged in the data plane.
My point below is LIME model is orthogonal to data plane OAM model.

-Qin
-----邮件原件-----
发件人: Huub van Helvoort [mailto:[email-masked]] 
发送时间: 2015年3月6日 17:35
收件人: Qin Wu; Erik Nordmark; [email-masked]
主题: Re: [Lime] Layer-transcending OAM?

Hello Qin.

OK.

> different portions of the network using various transport 

Layer-transcending is discouraged in the data-plane, the LIME model should follow this/

I agree.

Regards, Huub.

---

From: Ronald Bonica <[email-masked]>
Date: Fri, 6 Mar 2015 14:54:02 +0000

Hi Loa,

Greg's statement, below, reflects the WG charter.

                                          Ron
                                          / chair hat on

> From: Lime [mailto:[email-masked]] On Behalf Of Gregory Mirsky
> Sent: Friday, March 06, 2015 1:31 AM
> To: Loa Andersson; Erik Nordmark; [email-masked]
> my understanding is that it is the former - common model to express and
> control OAM on various data planes. Transcending, in my view, requires not
> just understanding of OAM model but understanding of defect data model.
> 
> 	Regards,
> 		Greg
> 
> does "sufficient commonality" mean that you intend to find a common way
> to do oam for different data planes, or does it mean that you intend to
> interwork oam for differernt data planes?
> 
> /Loa
> 
> > I think it is worth to point that after meeting in Honolulu the LIME WG
> formed the Design Team to investigate whether there indeed are sufficient
> commonality among several OAM models in IETF domain - IP, IP/MPLS,
> MPLS-TP, TRILL. The document you reference yet not been adopted by the
> LIME WG and till then is individual draft.
> >
> > 	Regards,
> > 		Greg
> >
> > While I agree that it is proper for the LIME working group to discuss this,
> the decision to create Layer-transcending OAM is not entirely up to LIME.
> >
> things for others to use you need to be sure that the intended users actually
> want and need what you are proposing, and that it does not cause problems
> for one data plane if another uses your generic model.
> >
> > /Loa
> >

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 6 Mar 2015 20:02:05 -0000

All,

(responding to Qin at the top of the thread, but not specifically to his email)

I'm finding this discussion hard. The "layer independence" in LIME means "being
independent of layers".

Going back to presentations in an old BoF that wasn't even called LIME is not
helpful, and we should look at what the LIME WG is working on, not what was
floated at a BoF.

So, if the network is using a multi-layered approach with OAM in each layer,
LIME is supposed to be able to interact with the OAM in each layer
(independently) in a generic way. That means configuring the OAM, and receiving
reports from the OAM.

If the network is using "layer transcendence" (TM) and running some form of
network-wide layer-transcending OAM, then LIME is supposed to be able to
interact with the OAM in a generic way. (Ditto config, reports).

LIME makes no statement about how OAM should be operated in data planes.

LIME *does* have a secondary deliverable about specifying general guidance to
people designing new OAM or building OAM for new data planes. It looks like that
work is some way off (I don't recall seeing a draft) and *that* work might have
something to say about transcendental OAM.

Thanks,
Adrian

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 06 Mar 2015 18:24:55 -0800

> Layer-transcending is discouraged in the data-plane,

Huub,

Who is discouraging this? The IETF? The Internet architecture?

Please provide references and/or more detail.

Thanks,
     Erik

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 06 Mar 2015 18:26:28 -0800

> cause problems for one data plane if another uses your generic model.

Loa,

Hopefully "generic" doesn't mean "least common denominator".

If it did then someones favorite approach (such as the IP over avian 
carrier RFC) would then constrain too much of what you can do.

Thus I think "generic" means a base class with optional components 
and/or behaviors.

Regards,
    Erik

>>>> The first point is relevant to the OAM architecture and model 
>>>> discussion
>>>> in LIME.
>>>> submission