Subject: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 9 Aug 2016 15:53:54 +0000

LIME,

This email starts the LIME WG Call for Adoption for draft-kumar-lime-yang-connectionless-oam-05.
https://datatracker.ietf.org/doc/draft-kumar-lime-yang-connectionless-oam/

It concurrently starts an IPR check on the same draft.  There’s currently no IPR disclosed. 

Can I please ask the authors to reply-all to this email confirming whether or not they know of any IPR that needs to be disclosed? Additionally, for all WG participants, please also reply-all if you know of any IPR that needs to be disclosed.

As we discussed in Berlin, this document is in charter and targets one WG milestone. Please reply-all to this email indicating whether you support adoption of this document as basis for that deliverable, or if you have any concerns please detail those on the list.

The adoption call will close on August 23rd.

Thanks,

— Carlos & Ron.

---

From: wangzitao <[email-masked]>
Date: Wed, 10 Aug 2016 01:03:45 +0000

Support as co-author, and not aware of any IPR.

Best Regards!
-Michael

-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Carlos Pignataro (cpignata)
发送时间: 2016年8月9日 23:54
收件人: [email-masked]
抄送: [email-masked]
主题: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

LIME,

Thanks,

— Carlos & Ron.
_______________________________________________
Lime mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lime

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 12 Aug 2016 10:01:58 +0100

Hi Carlos,

Adoption is a no-brainer for me. As you say "this document is in charter and targets one WG milestone". Furthermore, there doesn't seem to be any competing draft, and this draft is already well advanced and well discussed.

So, yes, please adopt it.

Adrian

> -----Original Message-----
> From: Lime [mailto:[email-masked]] On Behalf Of Carlos Pignataro
> (cpignata)
> Sent: 09 August 2016 16:54
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-
> connectionless-oam-05
> 
> LIME,
> 
> Can I please ask the authors to reply-all to this email confirming whether or not
> they know of any IPR that needs to be disclosed? Additionally, for all WG
> participants, please also reply-all if you know of any IPR that needs to be
> disclosed.
> 
> As we discussed in Berlin, this document is in charter and targets one WG
> milestone. Please reply-all to this email indicating whether you support adoption
> of this document as basis for that deliverable, or if you have any concerns please
> detail those on the list.
>

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 16 Aug 2016 21:15:36 +0000

Dear Authors, WG chairs, et. al,

I don't support adoption of the current version of the draft by the LIME WG. Below are my comments that may explain the reason for non-support:

·         the scope of the model isn’t clearly defined. The title suggests modeling OAM protocols that provide Fault Management (FM) and Performance Measurement (PM) in connectionless networks but the latter part seems absent in the proposed model. If only FM OAM is in the scope of this document, then I’d suggest updating the name of the draft;

·         the model uses references to the number of RFCs, e.g. RFC 5881,  within grouping tp-tools. If these are indication of OAM capability at a Test Point, then why is it rw as it seems to be more logical to be part of operational information, thus be ro;

·         the model still  refers to MPLS-TP even though WG agreed that MPLS-TP OM is an example of OAM for connection-oriented networks;

·         the model extensively refers to VPN cases, e.g. L3VPN, as example of connectionless network. I think that that yet has to be discussed as at the VPN layer network demonstrates characteristics of being connection-oriented;

·         the model does not reference, nor provides examples of use case of existing YANG data models of OAM protocols that are used in IP and IP/MPLS networks:

o   BFD (draft-ietf-bfd-yang);

o   LSP Ping (draft-zheng-mpls-lsp-ping-yang-cfg).

Perhaps another virtual interim meeting like one we had on May 27, 2016 would be helpful.

                Regards,

                                Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Tuesday, August 09, 2016 8:54 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

LIME,

Thanks,

— Carlos & Ron.

Lime mailing list

[email-masked]<mailto:[email-masked]>

---

From: wangzitao <[email-masked]>
Date: Mon, 22 Aug 2016 01:54:08 +0000

Hi Greg,

Thanks for your comments.
For the first question, I think the PM function should in a stand alone document. and it can augment the base module and RPC, like CO model and CO PM model.
For the 2-4 questions, I agree with you, the “tools” need to be modified to “ro”, the “tools-mpls-tp” and “l3vpn case” need to be removed.
For the last question, we can add an applicability section like CO document.
Thanks again!

Carlos and Ron,
I will prepare these update, and could we adopt CL draft? These updates can be done in the CL WG document.

Best Regards!
-Michael

发件人: Lime [mailto:[email-masked]] 代表 Gregory Mirsky
发送时间: 2016年8月17日 5:16
收件人: Carlos Pignataro (cpignata); [email-masked]
抄送: [email-masked]
主题: Re: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

•         the scope of the model isn’t clearly defined. The title suggests modeling OAM protocols that provide Fault Management (FM) and Performance Measurement (PM) in connectionless networks but the latter part seems absent in the proposed model. If only FM OAM is in the scope of this document, then I’d suggest updating the name of the draft;

•         the model uses references to the number of RFCs, e.g. RFC 5881,  within grouping tp-tools. If these are indication of OAM capability at a Test Point, then why is it rw as it seems to be more logical to be part of operational information, thus be ro;

•         the model still  refers to MPLS-TP even though WG agreed that MPLS-TP OM is an example of OAM for connection-oriented networks;

•         the model extensively refers to VPN cases, e.g. L3VPN, as example of connectionless network. I think that that yet has to be discussed as at the VPN layer network demonstrates characteristics of being connection-oriented;

•         the model does not reference, nor provides examples of use case of existing YANG data models of OAM protocols that are used in IP and IP/MPLS networks:

                Regards,

                                Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Tuesday, August 09, 2016 8:54 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

LIME,

Thanks,

— Carlos & Ron.

Lime mailing list

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 22 Aug 2016 19:03:11 +0000

Hi Michael,
thank you the most expedient response and for your consideration of the comments.
I think that the last comment is the comment I believe require the most changes to the data model for FM OAM in CL networks (perhaps that is how we can refer to this model from now on). While discussion on the applicability document is important, the model itself must demonstrate how existing technology-specific data models, e.g. BFD, LSP Ping, augment the data model for FM OAM in CL networks.

                Regards,
                                Greg

From: wangzitao [mailto:[email-masked]]
Sent: Sunday, August 21, 2016 6:54 PM
To: Gregory Mirsky <[email-masked]>; Carlos Pignataro (cpignata) <[email-masked]>; [email-masked]; Deepak Kumar (dekumar) <[email-masked]>; Qin Wu <[email-masked]>
Cc: [email-masked]
Subject: RE: WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

Hi Greg,

Carlos and Ron,

Best Regards!
-Michael

发件人: Lime [mailto:[email-masked]] 代表 Gregory Mirsky
发送时间: 2016年8月17日 5:16
收件人: Carlos Pignataro (cpignata); [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

                Regards,

                                Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Tuesday, August 09, 2016 8:54 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Lime] WG Adoption and IPR call for draft-kumar-lime-yang-connectionless-oam-05

LIME,

Thanks,

— Carlos & Ron.

Lime mailing list