Subject: [Lime] Adam Roach's No Objection on draft-ietf-lime-yang-connection-oriented-oam-model-05: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Wed, 21 Feb 2018 18:07:51 -0800

Adam Roach has entered the following ballot position for
draft-ietf-lime-yang-connection-oriented-oam-model-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connection-oriented-oam-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I found some small editorial nits while reviewing this document.

§2.2:

>  Connectivity Verification  - Connectivity Verification are used to
>     verify that a destination is connected.  It are also referred to

"...is used to..."

§3:

>  In this document we define a generic YANG model for connection
>  oriented OAM protocols.  The YANG model defined here is generic in a

Hyphenate "connection-oriented".

>  sense that other technologies can extend it for technology specific
>  needs.

Hyphenate "technology-specific".

>  Figure 1 depicts relationship of different YANG modules.

This sentence seems redundant with the earlier "Figure 1 depicts..." statement.

>          |                    |                  |
>   +-------------------------------------------------------+
>   |                      Uniform API                      |
>   +-------------------------------------------------------+
>
>       Relationship of OAM YANG model to generic (base) YANG model

I presume this is Figure 1. It probably should say so.

In the module:

> typedef ma-name-string {
>   type string;
>   description
>     "Generic administrative name for an
>      Maintenance Association (MA).";
> }

"...for a Maintenance..."

---

From: Qin Wu <[email-masked]>
Date: Thu, 22 Feb 2018 03:30:37 +0000

Thanks Adam, all nits are fixed.

-Qin
-----邮件原件-----
发件人: Adam Roach [mailto:[email-masked]] 
发送时间: 2018年2月22日 10:08
收件人: The IESG
抄送: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: Adam Roach's No Objection on draft-ietf-lime-yang-connection-oriented-oam-model-05: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

"...is used to..."