Subject: Re: [link-relations] NEW RELATION REQUEST - pingback

From: Julian Reschke <[email-masked]>
Date: Thu, 07 Apr 2011 20:53:56 +0200

On 11.08.2010 05:35, Mark Nottingham wrote:
> ...
> If you meet the "RFC or Open Standard" test, it's possible to register it.
>
> Note that publishing on the independent submission Informational RFC track isn't really "through the IETF process" -- it's at the discretion of the RFC Editor, which is a separate entity. See:
>    http://www.rfc-editor.org/indsubs.html
>    http://tools.ietf.org/html/rfc4846
>    http://tools.ietf.org/html/rfc5742
>
> While I can't say that it's necessarily a quick process, the amount of work involved (beyond draft formatting) is relatively low, and there are a few upsides, including:
>
> 1) RFCs are institutionally guaranteed not to change over time; you say that the spec is frozen, but there aren't checks or balances, nor conventions in place, to prevent future changes.
> 2) When you die and your Web site disappears, an RFC will have a better chance of persisting in an unambiguous state.
> ...

Assuming we are ok with the content, but not with the *location* of the 
spec, there may be an easy way to fix this.

For instance,

- use 
<http://replay.waybackmachine.org/20090228033516/http://hixie.ch/specs/pingback/pingback> 
as reference, or

- have Ian send the spec as attachment to the www-archive mailing list, 
and then link to the attachment in the mail archive.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Apr 2011 16:23:19 +1000

There's some discussion currently going on about making updating the registries easier, with simplified procedures for corrections, updates, etc.

If/when that happens, I'm thinking that a reference to Ian's site (or similar) isn't problematic, as the main problem -- that it may become unavailable if something happens to Ian -- isn't such an issue. 

Make sense?

Cheers,

On 08/04/2011, at 4:53 AM, Julian Reschke wrote:

> Assuming we are ok with the content, but not with the *location* of the spec, there may be an easy way to fix this.
> 
> For instance,
> 
> - use <http://replay.waybackmachine.org/20090228033516/http://hixie.ch/specs/pingback/pingback> as reference, or
> 
> - have Ian send the spec as attachment to the www-archive mailing list, and then link to the attachment in the mail archive.
> 
> Best regards, Julian

--
Mark Nottingham   http://www.mnot.net/

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 20 Apr 2011 23:44:25 -0700

Makes sense to me.

As an aside, would an expired I-D work as an alternative copy?

EHL

> -----Original Message-----
> From: [email-masked] [mailto:link-relations-
> [email-masked]] On Behalf Of Mark Nottingham
> Sent: Wednesday, April 20, 2011 11:23 PM
> To: Julian Reschke
> Cc: Ian Hickson; [email-masked]
> Subject: Re: [link-relations] NEW RELATION REQUEST - pingback
> 
> There's some discussion currently going on about making updating the
> registries easier, with simplified procedures for corrections, updates, etc.
> 
> If/when that happens, I'm thinking that a reference to Ian's site (or similar)
> isn't problematic, as the main problem -- that it may become unavailable if
> something happens to Ian -- isn't such an issue.
> 
> Make sense?
> 
> Cheers,
> 
> 
> >> Note that publishing on the independent submission Informational RFC
> track isn't really "through the IETF process" -- it's at the discretion of the RFC
> Editor, which is a separate entity. See:
> >> While I can't say that it's necessarily a quick process, the amount of work
> involved (beyond draft formatting) is relatively low, and there are a few
> upsides, including:
> >>
> >> 1) RFCs are institutionally guaranteed not to change over time; you say
> that the spec is frozen, but there aren't checks or balances, nor conventions
> in place, to prevent future changes.
> >> 2) When you die and your Web site disappears, an RFC will have a better
> chance of persisting in an unambiguous state.
> >> ...
> >
> <http://replay.waybackmachine.org/20090228033516/http://hixie.ch/specs/
> pingback/pingback> as reference, or
> >
> > - have Ian send the spec as attachment to the www-archive mailing list, and
> then link to the attachment in the mail archive.
> >
> > Best regards, Julian
> 
> --
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Apr 2011 16:57:51 +1000

No; I-ds are very specifically temporary docs, and designed to be superceded. It might make sense to reserve an entry based upon an active I-d, of course.