Subject: [link-relations] NEW RELATION - remoteStorage

From: Michiel de Jong <[email-masked]>
Date: Fri, 16 Dec 2011 11:53:34 +0700

hi! thanks to the discussion started by elf-pavlik on the webfinger ML, I
found this registry. I would like to register:

   o  Relation Name: remoteStorage

   o  Description: Points to remote data storage, owned by the user,
and accessible from the web.

   o  Reference: http://www.w3.org/community/unhosted/wiki/RemoteStorage

   o  Notes: -

   o  Application Data: -

Let me know if you need anything else, or what the procedure is from here on.

Cheers!
Michiel
Unhosted.org

---

From: Julian Reschke <[email-masked]>
Date: Fri, 16 Dec 2011 10:31:23 +0100

On 2011-12-16 05:53, Michiel de Jong wrote:
> hi! thanks to the discussion started by elf-pavlik on the webfinger ML,
> I found this registry. I would like to register:
>
>     o  Description: Points to remote data storage, owned by the user, and accessible from the web.
>
>     o  Reference:http://www.w3.org/community/unhosted/wiki/RemoteStorage
>
>     o  Notes: -
>
>     o  Application Data: -
>
>
> ...

I haven't looked at the actual definition yet but here are two editorial 
comments:

- link relations are compared case-insensitively, so there's no point to 
camel-case here

- the registration procedure asks for a "permanent and readily 
available" specification; I'm not convinced that a Wiki page is suited, 
unless there are procedures in place that ensure that...

Best regards, Julian

---

From: Michiel de Jong <[email-masked]>
Date: Fri, 16 Dec 2011 20:48:29 +0700

On Fri, Dec 16, 2011 at 4:31 PM, Julian Reschke <[email-masked]>wrote:

>>    o  Reference:http://www.w3.org/**community/unhosted/wiki/**
>> RemoteStorage <http://www.w3.org/community/unhosted/wiki/RemoteStorage>
>>
>>    o  Notes: -
>>
>>    o  Application Data: -
>>
>>

fair enough - we use the camel-case because localStorage and sessionStorage
also use them, so remoteStorage is an extension of that. but here the
relation name can be defined as remotestorage if that's what the spec
requires - i think it will still be human-readable without problems.

> - the registration procedure asks for a "permanent and readily available"
> specification; I'm not convinced that a Wiki page is suited, unless there
> are procedures in place that ensure that...
>
>
ok, then please use
http://www.w3.org/community/unhosted/wiki/index.php?title=RemoteStorage&oldid=47which
is the currently "frozen" version. in the future (maybe next year) we
might get a nicer address from w3c, but since we're a "w3c cg" community
group only, at the moment it's the best we can do. sorry! i hope it's ok
with you this way.

> Best regards, Julian

thanks a lot!
Michiel

---

From: Julian Reschke <[email-masked]>
Date: Fri, 16 Dec 2011 20:12:44 +0100

On 2011-12-16 14:48, Michiel de Jong wrote:
> ...
> fair enough - we use the camel-case because localStorage and
> sessionStorage also use them, so remoteStorage is an extension of that.
> but here the relation name can be defined as remotestorage if that's
> what the spec requires - i think it will still be human-readable without
> problems.
> ...

Yes.

>     available" specification; I'm not convinced that a Wiki page is
>     suited, unless there are procedures in place that ensure that...
>
>
> ok, then please use
> http://www.w3.org/community/unhosted/wiki/index.php?title=RemoteStorage&oldid=47
> <http://www.w3.org/community/unhosted/wiki/index.php?title=RemoteStorage&oldid=47>
> which is the currently "frozen" version. in the future (maybe next year)
> we might get a nicer address from w3c, but since we're a "w3c cg"
> community group only, at the moment it's the best we can do. sorry! i
> hope it's ok with you this way.
> ...

Not sure I like this as a stable reference.

If the whole point of this is to reserve the name for now, don't worry, 
it is: <http://paramsr.us/tracker/issue29>.

Now to the registration itself:

"Points to remote data storage, owned by the user, and accessible from 
the web."

Who's "the user" here?

Also, on the Wiki:

> <Link rel="remoteStorage" template="$TEMPLATE" api="$API" auth="$AUTH" ></Link>

I note that this is non-conforming. It has all kinds of undefined 
attributes, and doesn't have @href.

Finally, how would the link above appear in an HTTP Link header fields?

Best regards, Julian

---

From: Michiel de Jong <[email-masked]>
Date: Mon, 19 Dec 2011 17:18:40 +0700

thanks for the pointers! we will work on fixing these issues and report
back at a later time.

and thanks also for already reserving the name by the way.

On Sat, Dec 17, 2011 at 2:12 AM, Julian Reschke <[email-masked]>wrote:

>> http://www.w3.org/community/**unhosted/wiki/index.php?title=**
>> RemoteStorage&oldid=47<http://www.w3.org/community/unhosted/wiki/index.php?title=RemoteStorage&oldid=47>
>> <http://www.w3.org/community/**unhosted/wiki/index.php?title=**
>> RemoteStorage&oldid=47<http://www.w3.org/community/unhosted/wiki/index.php?title=RemoteStorage&oldid=47>
>> >
> If the whole point of this is to reserve the name for now, don't worry, it
> is: <http://paramsr.us/tracker/**issue29<http://paramsr.us/tracker/issue29>
> >.
>
> "Points to remote data storage, owned by the user, and accessible from the
> web."
>
> Who's "the user" here?
>
> Also, on the Wiki:
>
>  <Link rel="remoteStorage" template="$TEMPLATE" api="$API" auth="$AUTH"
>> ></Link>
>>
>