Subject: NEW RELATION: action

From: Ioseb Dzmanashvili <[email-masked]>
Date: Thu, 31 Jan 2013 23:10:33 +0400

Dear All,

I've submitted new draft of the 'create' link relation type: http://tools.ietf.org/html/draft-ioseb-dzmanashvili-action-link-relation-00

Description:
- The link relation is intentionally generic, and it can be used with  multiple media types in a wide variety of use cases.
- When included in a resource which represents a collection, the 'form'  link relation identifies a target resource that represents the form for adding a new member to the context collection.
- The target IRI points to a resource that is responsible to perform an action that may affect state of the context resource or
 initiate process.

Could you please review?
Thanks in advance!

Best regards,
ioseb

-- 
Ioseb Dzmanashvili
AzRy LLC
Software Architect
#8, Chachava str.
Tbilisi, 0159, Georgia

Mobile: +(995) 99753388
github.com/ioseb (http://github.com/ioseb)
pecl.php.net/user/ioseb (http://pecl.php.net/user/ioseb)
twitter.com/iosebi (http://twitter.com/iosebi)

---

From: Ioseb Dzmanashvili <[email-masked]>
Date: Thu, 31 Jan 2013 23:20:05 +0400

Second line in the previous message: "When included in a resource which represents a collection, the 'form'  link relation identifies a target resource that represents the form for adding a new member to the context collection." is not related to this draft, i copied it accidentally from the old email. Please ignore it. 

Cheers,
ioseb

---

From: Jan Algermissen <[email-masked]>
Date: Fri, 1 Feb 2013 00:11:36 +0100

Hi Ioseb,

can you explain your use case?

To me this smells a lot like a (REST-) anti pattern.

For example, instead of invoking an action resource like

GET /content/article/22/publish

you'd rather set it's state:

PUT /content/article/22/publish

<entry>
...
<foo:status>published</foo:status>
...
</entry>

No need for link and 'action' link rel, because you know the resource to change anyhow.

Maybe I am missing your point though.

Jan

On 31.01.2013, at 20:10, Ioseb Dzmanashvili <[email-masked]> wrote:

> github.com/ioseb
> pecl.php.net/user/ioseb
> twitter.com/iosebi
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations