Subject: 'meta' link relation

From: Bjoern Hoehrmann <[email-masked]>
Date: Mon, 18 Feb 2013 17:09:03 +0100

Hi,

  I saw this on the Internet and thought I give this registration thing
a whirl...

  Relation Name:
    meta

  Description:
    Linked metadata.

  Reference:
    http://tools.ietf.org/html/draft-daviel-metadata-link-00
    http://dublincore.org/documents/dcmes-xml/#sec4
    http://www.w3.org/TR/rdf-syntax-grammar/#section-rdf-in-HTML

regards,
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Erik Wilde <[email-masked]>
Date: Mon, 18 Feb 2013 23:18:58 +0100

hello björn.

On Feb 18, 2013, at 17:09, Bjoern Hoehrmann <[email-masked]> wrote
>  I saw this on the Internet and thought I give this registration thing

what about using the already existing "describedby" link relation, which is intended for pretty much exactly this kind of scenario?

cheers,

dret.

---

From: Jan Algermissen <[email-masked]>
Date: Tue, 19 Feb 2013 09:09:25 +0100

> what about using the already existing "describedby" link relation, which is intended for pretty much exactly this kind of scenario?

+++1 :-)

Jan

> 
> cheers,
> 
> dret.
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

---

From: Mike Kelly <[email-masked]>
Date: Tue, 19 Feb 2013 08:21:13 +0000

Consider it a synonym,  then. If this is used in the wild it should be
registered.

On a slightly meta tangent.. Is there an acceptance criteria for link
relations or do you just make it up as you go along?

Cheers,
M
On 19 Feb 2013 08:09, "Jan Algermissen" <[email-masked]> wrote:

> > what about using the already existing "describedby" link relation, which
> is intended for pretty much exactly this kind of scenario?
>
> +++1 :-)
>
> Jan
>
>
> >
> > cheers,
> >
> > dret.

---

From: Jan Algermissen <[email-masked]>
Date: Tue, 19 Feb 2013 09:33:47 +0100

On 19.02.2013, at 09:21, Mike Kelly <[email-masked]> wrote:

> Consider it a synonym,  then. If this is used in the wild it should be registered.

To me it is the other way round, really. Just because you spot something, doesn't mean you need to standardize it.

> 
> On a slightly meta tangent.. Is there an acceptance criteria for link relations or do you just make it up as you go along?

To me:

- No semantic overlap
- No manifestation of Web anti patterns (e.g. the recent 'action' link rel type)
- Genericity (e.g. avoid having an OAuth1 and OAuth2 version of essentially the same semantic)

Jan

---

From: Julian Reschke <[email-masked]>
Date: Tue, 19 Feb 2013 09:36:05 +0100

> Consider it a synonym,  then. If this is used in the wild it should be

If it used a *lot*, yes. Is it?

> relations or do you just make it up as you go along?

RFC 5988.

Best regards, Julian

---

From: Mike Kelly <[email-masked]>
Date: Tue, 19 Feb 2013 08:49:15 +0000

> If it used a *lot*, yes. Is it?

How much is "a *lot*"?

I checked RFC 5988 and it doesn't say. :)

>> relations or do you just make it up as you go along?

please could you be more specific? I can't see any criteria defined,
just process

Cheers,
M

---

From: Mike Kelly <[email-masked]>
Date: Tue, 19 Feb 2013 08:54:14 +0000

>> On a slightly meta tangent.. Is there an acceptance criteria for link relations or do you just make it up as you go along?

Over time, I think you will struggle to live with this constraint.

What is the damage is the semantics do overlap? Presumably the rel
definitions can make reference to one another where this is the case?

Cheers,
M

---

From: Julian Reschke <[email-masked]>
Date: Tue, 19 Feb 2013 10:44:23 +0100

> To me it is the other way round, really. Just because you spot something, doesn't mean you need to standardize it.

Yes. Note that this case may be different; it would be interesting to 
see this used in practice.

>> On a slightly meta tangent.. Is there an acceptance criteria for link relations or do you just make it up as you go along?

I believe that's a good goal. Duplicates are bad for network effects.

> - No manifestation of Web anti patterns (e.g. the recent 'action' link rel type)

Yes.

> - Genericity (e.g. avoid having an OAuth1 and OAuth2 version of essentially the same semantic)

Yes.

Best regards, Julian

---

From: Ioseb Dzmanashvili <[email-masked]>
Date: Tue, 19 Feb 2013 15:07:33 +0400

> - No manifestation of Web anti patterns (e.g. the recent 'action' link rel type)

Looks like that "action" being considered anti pattern of web, boils down to personal prefereneces and understanding. I didn't find any 100% proof of this. Nor strong enough arguments were presented during discussion. looks like i must accept "verdict" anyway :-)

>>> what about using the already existing "describedby" link relation, which is intended for pretty much exactly this kind of scenario?

Sorry for off top.

Cheers,
ioseb

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Tue, 19 Feb 2013 12:34:12 +0100

>If it used a *lot*, yes. Is it?

It's been recommended for use in various settings as per the References
in the proposed registration, http://xmlns.com/foaf/spec/#sec-autodesc
would be another example, add http://www.w3.org/TR/cooluris/#linking and
so on. As a consequence it is used a lot, yes.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Jan Algermissen <[email-masked]>
Date: Tue, 19 Feb 2013 12:52:16 +0100

On 19.02.2013, at 12:07, Ioseb Dzmanashvili <[email-masked]> wrote:

> looks like i must accept "verdict" anyway :-)

That's not the point.

The point is that IMHO, your desire to have the rel is a symptom of 'imperfect' design. Hence, I'd rather investigate than agree with any rel that comes my way :-)

Otherwise, we'd be pretty soon in 'gimme another method for my wanna-be REST API' land overhere.

Jan

---

From: Julian Reschke <[email-masked]>
Date: Tue, 19 Feb 2013 13:25:32 +0100

>      http://tools.ietf.org/html/draft-daviel-metadata-link-00

Expired.

>      http://dublincore.org/documents/dcmes-xml/#sec4

Obsoleted by <http://dublincore.org/documents/2008/01/14/dc-rdf/> which 
doesn't mention it anymore.

>      http://www.w3.org/TR/rdf-syntax-grammar/#section-rdf-in-HTML

Just a mention.

So it seems that the definition we *could* use is 
<http://dublincore.org/documents/dcmes-xml/#sec4>, right? Should we then 
note that thos has been obsoleted, and that "describedby" is more current?

Best regards, Julian

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Tue, 19 Feb 2013 13:56:05 +0100

>note that thos has been obsoleted, and that "describedby" is more current?

Referencing that document, or any other I've mentioned, is fine by me. I
do not think it's useful to decide whether "describedby" is identical to
"meta" and whether the latter is "obsolete" now. Problems here would be-
gin with RFC 5988 saying "Refers to a resource providing information
about the link's context." while the referenced document (and the regis-
tration template the RFC uses is wrong, there is no Documentation field)
has "The relationship A 'describedby' B asserts that resource B provides
a description of resource A." and "provides information about" and "pro-
vides a description of" is not quite the same thing. And if "meta" is
obsolete, why does e.g. the FOAF specification not use "describedby" and
why does the source code of http://www.dublincore.org/ still use "meta",
and so on...
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Ioseb Dzmanashvili <[email-masked]>
Date: Wed, 20 Feb 2013 02:03:41 +0400

On Tuesday, February 19, 2013 at 3:52 PM, Jan Algermissen wrote:
> 
> On 19.02.2013, at 12:07, Ioseb Dzmanashvili <[email-masked] (mailto:[email-masked])> wrote:
> 
Perfection is relative :-)
> Otherwise, we'd be pretty soon in 'gimme another method for my wanna-be REST API' land overhere.
Fair enough.
> Jan
Sorry for off top again.
 
ioseb