Subject: NEW RELATIONS: timegate ; timemap ; memento ; original

From: Herbert van de Sompel <[email-masked]>
Date: Sun, 3 Mar 2013 17:07:01 -0700

Hi all,

I would like to request adding the following Relation Types to the Registry:
- "timegate"
- "timemap"
- "memento"
- "original"

These Relation Types are used in Memento "Time Travel for the Web" for
which a new Internet Draft was just published at
http://www.ietf.org/id/draft-vandesompel-memento-06.txt

I include the description of each Relation Type below. For
completeness, I also include the meaning of the terms TimeGate,
TimeMap, Memento, Original Resource as introduced in the Memento
specification:

   o  Original Resource: An Original Resource is a resource that
exists or used to exist, and for which access to one of its prior
states may be required.

   o  Memento: A Memento for an Original Resource is a resource that
encapsulates a prior state of the Original Resource.

   o  TimeGate: A TimeGate for an Original Resource is a resource that
is capable of datetime negotiation to support access to prior states
of the Original Resource.

   o  TimeMap: A TimeMap for an Original Resource is a resource from
which a list of URIs of Mementos of the Original Resource is
available.

Greetings

Herbert Van de Sompel

==================

Relation Type: timegate

Description: A link with a "timegate" Relation Type is used to point
from the Original Resource, as well as from a Memento associated with
the Original Resource, to a TimeGate for the Original Resource.

Reference: http://www.ietf.org/id/draft-vandesompel-memento-06.txt

Notes: Used in the Memento "Time Travel for the Web" framework.

==================

Relation Type: timemap

Description: A link with a "timemap" Relation Type is used to point
from a TimeGate or a Memento associated with an Original Resource, as
well as from the Original Resource itself, to a TimeMap for the
Original Resource.

Reference: http://www.ietf.org/id/draft-vandesompel-memento-06.txt

Notes: Used in the Memento "Time Travel for the Web" framework.

==================

Relation Type: memento

Description: A link with a "memento" Relation Type is used to point
from a TimeGate or a Memento for an Original Resource, as well as from
the Original Resource itself, to a Memento for the Original Resource.

Reference: http://www.ietf.org/id/draft-vandesompel-memento-06.txt

Notes: Used in the Memento "Time Travel for the Web" framework.

==================

Relation Type: original

Description: A link with an "original" Relation Type is used to point
from a TimeGate or a Memento to its associated Original Resource.

Reference: http://www.ietf.org/id/draft-vandesompel-memento-06.txt

Notes: Used in the Memento "Time Travel for the Web" framework.

==================

-- 
Herbert Van de Sompel
Digital Library Research & Prototyping
Los Alamos National Laboratory, Research Library
http://public.lanl.gov/herbertv/

==

---

From: Jan Algermissen <[email-masked]>
Date: Sun, 17 Mar 2013 15:14:44 +0100

Hi Herbert,

I think we need the reference to be a stable document first. Pointing to a 06-version does not seem to make much sense, IMO.

Jan

On 04.03.2013, at 01:07, Herbert van de Sompel <[email-masked]> wrote:

> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

---

From: Herbert van de Sompel <[email-masked]>
Date: Sun, 17 Mar 2013 08:49:15 -0600

Dear Jan,

In the link relation registry at
http://www.iana.org/assignments/link-relations/link-relations.xml I
see several entries that point to versions of Internet Drafts:

- http://tools.ietf.org/html/draft-snell-additional-link-relations-07
- http://tools.ietf.org/html/draft-wilde-profile-link-04

If for some reason the same approach can not be followed for the
Memento relation types, then I can see two alternatives:

(1) Use the version-independent URI of the spec as posted on the Memento site:

http://www.mementoweb.org/guide/rfc/ID/

The current version of the Internet Draft is always available from
that URI, and the RFC will eventually be available from there too.

(2) Use the version-independent URI of the spec in the IETF data tracker:

https://datatracker.ietf.org/doc/draft-vandesompel-memento/

Many greetings

Herbert

==

---

From: Jan Algermissen <[email-masked]>
Date: Mon, 18 Mar 2013 08:19:40 +0100

Herbert,

> - http://tools.ietf.org/html/draft-wilde-profile-link-04

That is strange - but I guess the idea is to update them, once the specs are done.

Agreed - there is no reason your link relation types could not be defined the same way.

Having said that, I suggest some corrections to the I-D.

- Throughout section 2.2 please s/Relation Type/Link Relation Type/

- You write that resource MUST/SHOULD include certain Link headers but it is the response entities that you mean, yes?
  Can you be more precise, what response entities and which requests you are referring too? Supposedly GET, or?

- I am not entirely sure whether such things can be constrained - I feel this is an over-specification that goes
  beyond HTTP. IOW: I think it is up to the server.

  Can you reword that in a "if you find a link with rel type XY, then ...." fashion?

  @Mark, Julian - what is your take on this?

Jan

---

From: James M Snell <[email-masked]>
Date: Mon, 18 Mar 2013 00:38:56 -0700

> That is strange - but I guess the idea is to update them, once the specs
are done.

Those specs are done really. All they are waiting for is rfc# to be issued.
The respective relations were added to the registry per the iana actions
step of final publication.

- James

> - You write that resource MUST/SHOULD include certain Link headers but it
is the response entities that you mean, yes?
> >> I think we need the reference to be a stable document first. Pointing
to a 06-version does not seem to make much sense, IMO.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 Mar 2013 12:12:00 +1100

On 18/03/2013, at 6:38 PM, James M Snell <[email-masked]> wrote:

> Those specs are done really. All they are waiting for is rfc# to be issued. The respective relations were added to the registry per the iana actions step of final publication.

Right. Memento is still in ISE review.

Cheers,

--
Mark Nottingham   http://www.mnot.net/