Subject: NEW RELATION - ispartof

From: Paul Hoffman <[email-masked]>
Date: Mon, 15 Dec 2014 16:21:55 -0800

Relation Name: ispartof

Description: Indicates that the link's content is a part of an
external series.

Reference: draft-hoffman-xml2rfc

Notes: n/a

Application Data: n/a

---

From: Herbert Van de Sompel <[email-masked]>
Date: Mon, 15 Dec 2014 22:56:01 -0700

Hi Paul,

I was trying to figure out how the ispartof rel is semantically different from the item rel, see 

http://www.iana.org/assignments/link-relations/link-relations.xhtml

http://tools.ietf.org/html/rfc6573

Cheers

Herbert

Sent from my iPad

> On Dec 15, 2014, at 17:21, Paul Hoffman <[email-masked]> wrote:
> 
> Relation Name: ispartof
> 
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

---

From: Peter Williams <[email-masked]>
Date: Tue, 16 Dec 2014 07:47:37 -0700

I was wondering a similar thing but to me it seemed more like `collection`.

Peter
Barelyenough.org

---

From: Herbert Van de Sompel <[email-masked]>
Date: Tue, 16 Dec 2014 08:14:29 -0700

> I was wondering a similar thing but to me it seemed more like `collection`.

Yes, of course. "item" points from the collection to an item in the
collection. and "collection" points the other direction. Which seems
what ispartof does too.

Herbert

-- 
Herbert Van de Sompel
Digital Library Research & Prototyping
Los Alamos National Laboratory, Research Library
http://public.lanl.gov/herbertv/

==

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 16 Dec 2014 08:29:29 -0800

Actually, "item" is probably quite close to what I wanted to use "isPartOf" for. In the use case I am working with, we are using a <link> element that can be repeated for many values. The current text is:

   o  The current ISSN for the RFC Series.  The value for the "rel"
      attribute is "isPartOf".  The link should use the form
      "urn:issn:".

The intention is to say "this link is part of that series", which "item" might already mean. Thoughts?

--Paul Hoffman

> On Dec 16, 2014, at 7:14 AM, Herbert Van de Sompel <[email-masked]> wrote:
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 17 Dec 2014 08:34:45 +0100

On 2014-12-16 17:29, Paul Hoffman wrote:
 > Actually, "item" is probably quite close to what I wanted to use 
"isPartOf" for. In the use case I am working with, we are using a <link> 
 > The intention is to say "this link is part of that series", which 
"item" might already mean. Thoughts?

"item" would link from the series resource to the RFC. I think you want 
"collection".

Best regards, Julian