Subject: NEW RELATION - derivedfrom

From: Paul Hoffman <[email-masked]>
Date: Fri, 9 Jan 2015 11:07:41 -0800

Relation Name: derivedfrom

Description: The target IRI points to a resource from which this material was derived.

Reference: draft-hoffman-xml2rfc

Notes: n/a

Application Data: n/a

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 9 Jan 2015 14:21:43 -0500

Looks good to me; anyone else have comments?

> On 9 Jan 2015, at 2:07 pm, Paul Hoffman <[email-masked]> wrote:
> 
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

--
Mark Nottingham   http://www.mnot.net/

---

From: Erik Wilde <[email-masked]>
Date: Fri, 9 Jan 2015 11:34:33 -0800

hello.

> On Jan 9, 2015, at 11:21, Mark Nottingham <[email-masked]> wrote:

one quick question, maybe just for clarification (or maybe worth a note in the registration/definition):

we are interested in using this for n:1 relations between resources, where possibly many inputs are used to generate one output (think of it as an aggregation/reporting step). thus we would have several derivedfrom links in the output resource, linking to all the inputs. that would still be an appropriate use of the proposed relation, right?

thanks and cheers,

dret.

---

From: Herbert Van de Sompel <[email-masked]>
Date: Fri, 9 Jan 2015 12:36:18 -0700

> Relation Name: derivedfrom

Thanks for that!

Herbert

-- 
Herbert Van de Sompel
Digital Library Research & Prototyping
Los Alamos National Laboratory, Research Library
http://public.lanl.gov/herbertv/

==

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 9 Jan 2015 11:40:57 -0800

> we are interested in using this for n:1 relations between resources, where possibly many inputs are used to generate one output (think of it as an aggregation/reporting step). thus we would have se…

I would certainly think so. It says "a resource", not "the resource".

--Paul Hoffman

---

From: mike amundsen <[email-masked]>
Date: Fri, 9 Jan 2015 14:46:58 -0500

seems fine.

the current I-D[1] still shows "convertedfrom" -- i assume that'll change
before IANA reg for "derivedfrom", right?

[1] https://tools.ietf.org/html/draft-hoffman-xml2rfc-14#section-6.2

mamund
+1.859.757.1449
skype: mca.amundsen
http://amundsen.com/blog/
http://twitter.com/mamund
https://github.com/mamund
http://linkedin.com/in/mamund

---

From: Julian Reschke <[email-masked]>
Date: Fri, 09 Jan 2015 20:55:03 +0100

> Looks good to me; anyone else have comments?

SGTM.

---

From: <[email-masked]>
Date: Wed, 14 Jan 2015 20:32:42 +0000

I like it.

Darrel

From: Mark Nottingham
Sent: ‎Friday‎, ‎January‎ ‎9‎, ‎2015 ‎2‎:‎21‎ ‎PM
To: Paul Hoffman
Cc: link-relations

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 19 Jan 2015 16:59:24 +1100

IANA,

in <http://www.iana.org/assignments/link-relations/link-relations.xml>,

> Reference: draft-hoffman-xml2rfc

As requested in <http://mailarchive.ietf.org/arch/msg/link-relations/joN3W2eShVffVMykOnPmqDyUjQE>

--
Mark Nottingham   https://www.mnot.net/