Subject: request to register "preload"

From: Erik Wilde <[email-masked]>
Date: Tue, 19 Jan 2016 14:14:15 -0800

hello.

https://www.w3.org/TR/2016/WD-preload-20160119/#iana-considerations is 
the registration template for the "preload" link relation type. when 
approved as a stable specification, http://www.w3.org/TR/preload/ will 
be the stable reference defining the "preload" link relation type. here 
is the description from the template:

"This link relation type establishes an external resource link for a 
required resource and its fetch properties."

this email is a request for the "preload" link relation type to be added 
to the IANA registry of link relation types.

thanks and kind regards,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 20 Jan 2016 16:24:05 +1100

Hi Erik,

The description is using terminology that might confuse people (See other registry entries for a flavour of what's typical.). I'd suggest something like:

"Refers to a resource that should be loaded early in the processing of the link's context, without blocking rendering."

...putting into the Notes:

"Target attributes establish the fetch properties of the link."

Does that make sense? 

Cheers,

> On 20 Jan 2016, at 9:14 am, Erik Wilde <[email-masked]> wrote:
> 
> hello.
> 
> https://www.w3.org/TR/2016/WD-preload-20160119/#iana-considerations is the registration template for the "preload" link relation type. when approved as a stable specification, http://www.w3.org/TR/preload/ will be the stable reference defining the "preload" link relation type. here is the description from the template:
> 
> "This link relation type establishes an external resource link for a required resource and its fetch properties."
> 
> this email is a request for the "preload" link relation type to be added to the IANA registry of link relation types.
> 
> thanks and kind regards,
> 
> dret.
> 
> -- 
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

--
Mark Nottingham   https://www.mnot.net/

---

From: Erik Wilde <[email-masked]>
Date: Wed, 20 Jan 2016 09:26:35 -0800

hello mark.

thanks for the quick feedback!

> "Target attributes establish the fetch properties of the link."

sounds good, and thanks for the suggestions. here's an updated version 
which will become part of the next published draft:

https://github.com/w3c/preload/pull/45

thanks and cheers,

dret.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Jan 2016 12:52:35 +1100

IANA,

Please add the following to the Link Relations Registry <https://www.iana.org/assignments/link-relations/link-relations.xhtml>:

* Relation Name: preload
* Description: Refers to a resource that should be loaded early in the processing of the link's context, without blocking rendering.
* Reference: http://www.w3.org/TR/preload/
* Note: Additional target attributes establish the detailed fetch properties of the link.