Subject: Re: [lisp] [lisp-interest] While we're waiting for [email-masked] to come up.....

From: David Meyer <[email-masked]>
Date: Wed, 19 Nov 2008 11:38:39 -0800

Dimitri,

> > LISP and companion documents (see below) are proposals that
> > respond to the problems discussed at the IAB's October, 2006
> 
> wouldn't it be appropriate to state the purpose is to experiment whether
> the proposals are appropriate answers to the questions of the IAB ?

	In general, the IAB workshop was a starting point and
	focused on the tier-1 ISPs. Since that time we've learned
	a lot, from both smaller SPs as well as from enterprises
	of various sizes. So my sense is that our perspective (and
	hence our questions) is somewhat broader these days.

	Dave

_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp

---

From: Joe Touch <[email-masked]>
Date: Wed, 19 Nov 2008 10:58:54 -0800

Hi, all,

I'm a bit confused. I though the consensus from the last meeting was
that LISP would be an IRTF WG, not IETF.

Joe

PAPADIMITRIOU Dimitri wrote:
> dave: 
> 
> here belwo comments on the charter: 
> 
>> -----Original Message-----
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf 
>> Of David Meyer
>> Sent: Wednesday, November 19, 2008 12:07 AM
>> To: [email-masked]
>> Subject: [lisp-interest] While we're waiting for 
>> [email-masked] to come up.....
>>
>> 	Here's the proposed LISP WG charter. Comments greatly
>> 	appreciated. 
>>
>> 	Dave
>> ---
>>
>>
>> LISP (Locator/ID Separation Protocol)
>>
>> Last Modified: 2008-11-18
>>
>> Chair(s):
>>  TBD
>>
>> Internet Area Director(s):
>>  Jari Arkko <[email-masked]>
>>  Mark Townsley <[email-masked]>
>>
>> Routing Area Advisor:
>>  TBD
>>
>> Secretary(ies):
>>  TBD
>>  
>> Mailing Lists:
>>  General Discussion: [email-masked]
>>
>> Description of Working Group:
>>
>> Routing and Addressing Workshop [0]. The purpose of the BOF is to
>> form a working group whose charter (see below) is to work on the
>> design on the LISP base protocol [1], the LISP+ALT mapping system
> 
> i would mention explicitly "protocol architecture and spec." 
> 
>> [2], LISP Interworking [4] and LISP multicast [6]. The working
> 
> text should make clear that interworking also applicable to mcast.  
> 
>> group will encourage and support interoperable LISP
>> implementations as well as defining requirements for alternate
>> mapping systems.
> 
> shouldn't it be the other way around: specify requirements and then
> implementations ?
> 
>> Goals and Milestones:
>>
>> Mar 2010  Submit base LISP specification to the IESG for
>>           Experimental.
>>
>> Mar 2010  Submit base ALT specification to the IESG for
>>           Experimental.
>>
>> Mar 2010  Submit the LISP Interworking specification to the IESG
>> 	  for Experimental.
>>
>> Mar 2010  Re-charter or close.
> 
> i would like to see a document also documenting experimental results
> from various execution of the protocol spec.
> 
> thanks,
> -d.
> 
>> Internet-Drafts:
>> 	draft-farinacci-lisp-9.txt
>> 	draft-farinacci-lisp-multicast-00.txt
>> 	draft-fuller-lisp-alt-03.txt
>> 	draft-lewis-lisp-interworking-01.txt
>>
>> Request For Comments:
>> 	  None
>>
>>
>> References
>> ----------
>> [0]     Meyer, D. et. al., "Report from the IAB Workshop on
>>         Routing and Addressing", RFC 4984.
>>
>> [1]     Farinacci, D. et. al., "Locator/ID Separation Protocol
>>         (LISP)", draft-farinacci-lisp-09.txt.
>>
>> [2]	Fuller, V., et. al., "LISP Alternative Topology
>> 	(LISP-ALT)", draft-fuller-lisp-alt-03.txt
>>
>> [3]	Iannone, L., and O. Bonaventure, "OpenLISP Implementation
>> 	Report", draft-iannone-openlisp-implementation-00.txt.
>>
>> [4]	Lewis, D., et. al., "Interworking LISP with IPv4 and
>> 	IPv6", draft-lewis-lisp-interworking-01.txt.
>>
>> [5]	Mathy, L., et. al., "LISP-DHT: Towards a DHT to map
>> 	identifiers onto locators", draft-mathy-lisp-dht-00.txt.
>>
>> [6]     Farinacci, D., Meyer, D., Zwiebel, J., and S. Venaas,
>> 	"LISP for Multicast Environments",
>> 	draft-farinacci-lisp-multicast-00.txt.  
>>

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Wed, 19 Nov 2008 11:33:53 -0800

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hi, all,
> 
> I'm a bit confused. I though the consensus from the last 
> meeting was that LISP would be an IRTF WG, not IETF.
> 
> Joe

Hi Joe,

At the Dublin EXPLISP BoF Jari asked two questions of the (approximately
80) attendees.

1) How many think this work should be done in the IRTF/RRG?
	~40 people raised their hands
2) How many think this work should be done in the IETF?
	~20 people raised their hands

So there was no clear consensus for anything at the EXPLISP BoF.

Note that the question 'Should an IETF WG be formed?' was never directly
posed.

-Darrel

---

From: Joe Touch <[email-masked]>
Date: Wed, 19 Nov 2008 11:36:25 -0800

> Note that the question 'Should an IETF WG be formed?' was never directly

Fair enough - I'll rephrase:

Given that 2/3 of the attendees thought that this would be IRTF rather
than IETF work, why is an IETF WG being formed?
_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp

---

From: Jari Arkko <[email-masked]>
Date: Mon, 24 Nov 2008 15:40:12 +0100

Joe, all,

> 2- the LISP team will keep asking the question until they
> get the answer they like
>
> I appreciate that (2) is currently in vogue in the IETF as a whole, but
> it's a suboptimal way to handle this sort of thing.
>   

Let me clarify the process here. I have no intention of changing my 
recommendation just because someone doesn't like the answer.

However, as with any other BOF, an initial reaction from the community 
may be negative. On BOFs that eventually become chartered WGs in such a 
situation, the proponents, the AD, and the community work together to 
redefine scope, goals, and technical content. Once the community is 
satisfied that the new proposal actually is a good one, we can create a WG.

Note that this can involve a significant effort and the participants 
must be willing to take feedback into account. For instance, the first 
SAVA BOF failed, but after significant scaling down of the proposals, an 
interim meeting that the ADs hosted, and a change of technical 
direction, the second BOF eventually lead to the creation of the SAVI 
WG. Similarly, the community felt in Dublin that ALTO was not ready, but 
a big effort from everyone on the mailing list allowed the redefinition 
of the charter text so that it actually got approved right before 
Minneapolis, even without a second BOF. In both cases it was important 
that the community eventually felt comfortable with the end result.

I hope that we can do something like this for EXPLISP.

I hope this clarifies,

Jari