Subject: [lisp] MTU

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 10 Nov 2010 04:41:15 -0800

Hi,

I understand there may have been some LISP operational
observations wrt MTU. Is there anything to report in
that regard?

Thanks - Fred
[email-masked]

---

From: Darrel Lewis <[email-masked]>
Date: Wed, 10 Nov 2010 19:38:54 -0800

> observations wrt MTU. Is there anything to report in

Yes, there have.  We updated the draft to reflect our observations:

   This specification recommends that implementations support for one of
   the proposed fragmentation and reassembly schemes.  These two simple
   existing schemes are detailed in Section 5.4.

> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 10 Nov 2010 23:49:51 -0800

See attached for an interesting MTU study that was recently
posted to the tsv-area list (abstract below). A PMTUD failure
rate of 5-18% seems like a significant incidence of failure.

Thanks - Fred

"Path MTU Discovery (PMTUD) is widely believed to be un- reliable because of firewalls that discard ICMP "Packet Too Big" messages. This paper measures PMTUD behaviour for 50,000 popular websites and finds the failure rate in IPv4 is much less than previous studies. We measure the overall failure rate between 5% and 18%, depending on the MTU of the constraining link. We explore methods webserver oper- ators are using to reduce their dependence on PMTUD, and find 11% limit themselves to sending packets no larger than 1380 bytes. We identify a number of common behaviours that seem to be software bugs rather than filtering by fire- walls. If these are corrected PMTUD failures could be re- duced by 63%. We further find the IPv6 failure rate is less than the IPv4 rate even with more scope for failure in IPv6."

> -----Original Message-----
> From: Darrel Lewis [mailto:[email-masked]] 
> Sent: Wednesday, November 10, 2010 7:39 PM
> To: Templin, Fred L
> Cc: Darrel Lewis; [email-masked]
> Subject: Re: [lisp] MTU
> 
> 

Subject: _Measuring Path MTU Discovery Behaviour
From: Lars Eggert <[email-masked]>
To: TSV Area <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Sun, 31 Oct 2010 22:53:22 -0700
List-Id: IETF Transport Area Mailing List <tsv-area.ietf.org>

An ACM IMC paper of potential interest to the TSV area:

Measuring Path MTU Discovery Behaviour
Matthew Luckie (University of Waikato)
Ben Stasiewicz (University of Waikato)
http://conferences.sigcomm.org/imc/2010/papers/p102.pdf

Path MTU Discovery (PMTUD) is widely believed to be un- reliable because of firewalls that discard ICMP “Packet Too Big” messages. This paper measures PMTUD behaviour for 50,000 popular websites and finds the failure rate in IPv4 is much less than previous studies. We measure the overall failure rate between 5% and 18%, depending on the MTU of the constraining link. We explore methods webserver oper- ators are using to reduce their dependence on PMTUD, and find 11% limit themselves to sending packets no larger than 1380 bytes. We identify a number of common behaviours that seem to be software bugs rather than filtering by fire- walls. If these are corrected PMTUD failures could be re- duced by 63%. We further find the IPv6 failure rate is less than the IPv4 rate even with more scope for failure in IPv6.

Lars

---

From: Jesper Skriver <[email-masked]>
Date: Thu, 11 Nov 2010 14:31:41 +0200

Fred,

Depending on pMTUd between xTRs is less likely to fail, than depending on pMTUd between end stations. For the simple reason that the likelihood of firewalls and other packet filtering devices being in the path between xTRs is much less, than such devices being in the path between end stations.

The xTR is typically deploy on the CPE edge, in front of or on the same device as the device performing firwall/packet filtering.

/Jesper

On 11 Nov 2010, at 09:49, Templin, Fred L wrote:

> Date: 1 November 2010 07:53:22 EET

/Jesper

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 11 Nov 2010 21:02:20 -0800

Jesper,

> Depending on pMTUd between xTRs is less likely to fail, than

Maybe so, but can you quantify "less likely"?

> The xTR is typically deploy on the CPE edge, in front of or 
> on the same device as the device performing firwall/packet filtering.

Is there a use case analysis for deployment of xTRs?

Thanks - Fred

> From: Jesper Skriver [mailto:[email-masked]] 
> Sent: Thursday, November 11, 2010 4:32 AM
> To: Templin, Fred L
> Depending on pMTUd between xTRs is less likely to fail, than 
> depending on pMTUd between end stations. For the simple 
> reason that the likelihood of firewalls and other packet 
> filtering devices being in the path between xTRs is much 
> less, than such devices being in the path between end stations.
> 
> The xTR is typically deploy on the CPE edge, in front of or 
> on the same device as the device performing firwall/packet filtering.
> 
> /Jesper
> 
> > "Path MTU Discovery (PMTUD) is widely believed to be un- 
> reliable because of firewalls that discard ICMP "Packet Too 
> Big" messages. This paper measures PMTUD behaviour for 50,000 
> popular websites and finds the failure rate in IPv4 is much 
> less than previous studies. We measure the overall failure 
> rate between 5% and 18%, depending on the MTU of the 
> constraining link. We explore methods webserver oper- ators 
> are using to reduce their dependence on PMTUD, and find 11% 
> limit themselves to sending packets no larger than 1380 
> bytes. We identify a number of common behaviours that seem to 
> be software bugs rather than filtering by fire- walls. If 
> these are corrected PMTUD failures could be re- duced by 63%. 
> We further find the IPv6 failure rate is less than the IPv4 
> rate even with more scope for failure in IPv6."
> > 
> > 
> > 
> > Path MTU Discovery (PMTUD) is widely believed to be un- 
> reliable because of firewalls that discard ICMP "Packet Too 
> Big" messages. This paper measures PMTUD behaviour for 50,000 
> popular websites and finds the failure rate in IPv4 is much 
> less than previous studies. We measure the overall failure 
> rate between 5% and 18%, depending on the MTU of the 
> constraining link. We explore methods webserver oper- ators 
> are using to reduce their dependence on PMTUD, and find 11% 
> limit themselves to sending packets no larger than 1380 
> bytes. We identify a number of common behaviours that seem to 
> be software bugs rather than filtering by fire- walls. If 
> these are corrected PMTUD failures could be re- duced by 63%. 
> We further find the IPv6 failure rate is less than the IPv4 
> rate even with more scope for failure in IPv6.
> > 
> > Lars
> >

---

From: Loránd Jakab <[email-masked]>
Date: Sat, 13 Nov 2010 00:58:25 +0800

Hi Fred,

> Is there a use case analysis for deployment of xTRs?

There is a draft describing deployment scenarios for xTRs (among other
things). The MTU issue is discussed as well, please take a look; we
welcome comments, and proposed text.

http://tools.ietf.org/html/draft-jakab-lisp-deployment

Thanks,
-Lori