Subject: [lisp] Fwd: I-D Action: draft-farinacci-lisp-ecdsa-auth-03.txt

From: Dino Farinacci <[email-masked]>
Date: Tue, 4 Sep 2018 12:05:21 -0700

Folks, here is an update that reflects comments we received at the Montreal presentation:

A diff file is included for your convenience. 

At this time, I would like to request this document for working group adoption.

Thanks,
Dino/Erik

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: I-D Action: draft-farinacci-lisp-ecdsa-auth-03.txt
> Date: September 4, 2018 at 12:00:14 PM PDT
> To: <[email-masked]>
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : LISP Control-Plane ECDSA Authentication and Authorization
>        Authors         : Dino Farinacci
>                          Erik Nordmark
> 	Filename        : draft-farinacci-lisp-ecdsa-auth-03.txt
> 	Pages           : 17
> 	Date            : 2018-09-04
> 
> Abstract:
>   This draft describes how LISP control-plane messages can be
>   individually authenticated and authorized without a a priori shared-
>   key configuration.  Public-key cryptography is used with no new PKI
>   infrastructure required.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-farinacci-lisp-ecdsa-auth/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-farinacci-lisp-ecdsa-auth-03
> https://datatracker.ietf.org/doc/html/draft-farinacci-lisp-ecdsa-auth-03
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-farinacci-lisp-ecdsa-auth-03
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 5 Sep 2018 09:46:27 +0200

Folks,

As you can see from Dino’s email (below) the authors are requesting that the document

https://datatracker.ietf.org/doc/draft-farinacci-lisp-ecdsa-auth/ <https://datatracker.ietf.org/doc/draft-farinacci-lisp-ecdsa-auth/>

be adopted as WG item.

This email starts the usual 14 days call for adoption, this call will end on
Thursday the 19th September, 2018.

Please email the WG list stating whether or not you support acceptance.

If you email to support the acceptance of this document as a WG item, please
also indicate if you are able and willing to either contribute to, or review, (or both) the draft.

Sitting in silence does not indicate support, please respond appropriately.

The Chairs
Joel & Luigi

> On 4 Sep 2018, at 21:05, Dino Farinacci <[email-masked]> wrote:
> 
> <rfcdiff-ecdsa.html>
>> From: [email-masked] <mailto:[email-masked]>
>> To: <[email-masked] <mailto:[email-masked]>>
>> Reply-To: [email-masked] <mailto:[email-masked]>
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-farinacci-lisp-ecdsa-auth/ <https://datatracker.ietf.org/doc/draft-farinacci-lisp-ecdsa-auth/>
>> 
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 5 Sep 2018 09:48:00 +0200

> On 5 Sep 2018, at 09:46, Luigi Iannone <[email-masked]> wrote:
> 
> Folks,
> 

Small typo in the ending date: Wednesday 19th September, 2018.

Ciao

L.

>> On 4 Sep 2018, at 21:05, Dino Farinacci <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> https://tools.ietf.org/html/draft-farinacci-lisp-ecdsa-auth-03 <https://tools.ietf.org/html/draft-farinacci-lisp-ecdsa-auth-03>
>> [email-masked] <mailto:[email-masked]>

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 11 Sep 2018 14:29:32 -0700

As an co-author, I support making this document a WG draft.

Thanks,
Dino

> On Sep 5, 2018, at 12:48 AM, Luigi Iannone <[email-masked]> wrote:
> 
> 
>

---

From: Colin Cantrell <[email-masked]>
Date: Tue, 11 Sep 2018 15:04:33 -0700

I support making this document a WG draft

Cheers,
Colin Cantrell

> On Sep 11, 2018, at 2:29 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: "Victor Moreno (vimoreno)" <[email-masked]>
Date: Thu, 13 Sep 2018 03:59:19 +0000

I support making this a WG document. We must complement the security provided for map replies in LISP-sec with mechanisms to secure map-requests and map-registers such as those proposed in ecdsa-auth.

Victor

> On Sep 11, 2018, at 6:04 PM, Colin Cantrell <[email-masked]> wrote:
>

---

From: Fabio Maino <[email-masked]>
Date: Wed, 12 Sep 2018 21:01:43 -0700

support.

Fabio

On 9/5/18 12:46 AM, Luigi Iannone wrote:
>>> *From: [email-masked] <mailto:[email-masked]>
>>> *Subject: **I-D Action: draft-farinacci-lisp-ecdsa-auth-03.txt*
>>> *Date: *September 4, 2018 at 12:00:14 PM PDT
>>> *To: *<[email-masked] <mailto:[email-masked]>>
>>> *Reply-To: [email-masked] <mailto:[email-masked]>
>>>
>>>

---

From: Jordi Paillissé Vilanova <[email-masked]>
Date: Thu, 13 Sep 2018 13:01:00 +0200

Support.

Jordi

---

From: Alberto Rodriguez-Natal <[email-masked]>
Date: Wed, 19 Sep 2018 08:52:28 -0700

Support.

Alberto

On Wed, Sep 5, 2018 at 12:46 AM Luigi Iannone <[email-masked]> wrote:

> *From: [email-masked]
> *To: *<[email-masked]>
> *Reply-To: [email-masked]
>
>

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 24 Sep 2018 11:18:16 +0200

Hi All,

the call for adoption for this document is now closed.

On the mailing list there were messages in support of the document, showing a consensus for adoption.

Authors are invited to submit a new version of the document named: draft-ietf-lisp-ecdsa-auth-00.txt

Thanks to all people that expressed their opinion.

Ciao

Luigi & Joel

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 24 Sep 2018 10:09:38 -0700

> Authors are invited to submit a new version of the document named: draft-ietf-lisp-ecdsa-auth-00.txt

Done.

Dino