Subject: [lisp] Routing directorate review of draft-ietf-lisp-rfc6833bis-13

From: Jonathan Hardwick <[email-masked]>
Date: Fri, 7 Sep 2018 18:27:04 +0000

Hi there

I have done a routing directorate review of this draft.
https://datatracker.ietf.org/doc/draft-ietf-lisp-rfc6833bis/?include_text=1

The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-lisp-rfc6833bis-13
Reviewer: Jon Hardwick
Review Date: 7 Sep 2018
IETF LC End Date: 31 Aug 2018
Intended Status: Proposed Standard

Comments
This was my first foray into LISP, so I also read draft-ietf-lisp-rfc6830bis and draft-ietf-lisp-introduction as ramp-up.  I found all three documents to be very readable and useful.

I think this document is ready to be published.  I noted a few minor comments and questions as I read through it, below.

sec3: Map-Register contains “one or more RLOCs to reach ETR(s)”.  How do you deregister all RLOCs for an EID?

sec5: (Diagrams) It seems a bit redundant to specify the IPv4/6 and UDP header formats here.  Just refer to the RFCs.

sec5: “When a UDP Map-Reply Map-Notify”  <- insert comma

sec5.1: What about code point 7?  Not assigned?  Reserved?

sec6.1: “from those sites to which” should be “to those sites to which”

sec6.1: “for the last minute” is arbitrary and should be left to the implementation / deployment to decide IMO.

sec7.1: Have you considered using multi-hop BFD instead of RLOC probing?

Best regards
Jon

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 7 Sep 2018 11:41:55 -0700

> Intended Status: Proposed Standard

Thanks for your comments Jon.

> This was my first foray into LISP, so I also read draft-ietf-lisp-rfc6830bis and draft-ietf-lisp-introduction as ramp-up.  I found all three documents to be very readable and useful.

That is good to hear. Kudos to the working group for this.

> sec5: (Diagrams) It seems a bit redundant to specify the IPv4/6 and UDP header formats here.  Just refer to the RFCs.

We want to be crystal clear and don’t want readers to have to shuffle documents. Those header formats are pretty etched in stone, so we don’t think we’ll have a document maintenance problem keeping it up to date.

> sec5: “When a UDP Map-Reply Map-Notify”  <- insert comma

Fixed.

> sec5.1: What about code point 7?  Not assigned?  Reserved?

It is assigned to a non-working group draft. NAT-traversal has not gone through working group process so far.

> sec6.1: “from those sites to which” should be “to those sites to which”

Fixed.

> sec6.1: “for the last minute” is arbitrary and should be left to the implementation / deployment to decide IMO.

Its kind of an architecture constant.

> sec7.1: Have you considered using multi-hop BFD instead of RLOC probing?

Yes. But there are too many LISP features we need that would not be appropriate in a more generalized BFD mechanism. We use RLOC-probing, not only for reachability testing, but to convey new RLOC changes, LISP-crypto keys, as well as differnet RLOC types.

> Jon

I will publish a new version of rfc6830bis and rfc6833bis on Monday with accumilated changes from various comments.

Thanks again,
Dino

---

From: Luigi Iannone <[email-masked]>
Date: Tue, 11 Sep 2018 11:23:28 +0200

Hi Dino,

a quick point on the control message type 7.

> On 7 Sep 2018, at 20:41, Dino Farinacci <[email-masked]> wrote:
> 

This point has been raised as well by Alvaro.

My take is that officially type 7 is NOT assigned and the document should state so.
Eventually, NAT-traversal will be published and type 7 will be officially assigned. 
But until then, documents should mark it as unassigned.

Ciao

L.

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 11 Sep 2018 07:39:09 -0700

I will update the spec to say type 7 is not assigned.

Dino

> On Sep 11, 2018, at 2:23 AM, Luigi Iannone <[email-masked]> wrote:
> 
> Hi Dino,
>