Subject: Re: [lisp] WG Last Call for draft-ietf-lisp-pubsub

From: "Alberto Rodriguez-Natal (natal)" <[email-masked]>
Date: Wed, 3 Feb 2021 03:18:10 +0000

New version is up now.

Alberto

From: "Alberto Rodriguez-Natal (natal)" <[email-masked]>
Date: Tuesday, January 19, 2021 at 12:51 PM
To: Eliot Lear <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked] list" <[email-masked]>
Subject: Re: [lisp] WG Last Call for draft-ietf-lisp-pubsub

Hi Eliot,

Thanks for the feedback! As Med mentioned we have made a small clarifying edit in the text. Please find the diff attached.

I’ll wait a bit before sending the new version in case there are other small changes to make during the WGLC process.

Thanks!
Alberto

From: lisp <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Monday, January 18, 2021 at 6:51 AM
To: Eliot Lear <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked] list" <[email-masked]>
Subject: Re: [lisp] WG Last Call for draft-ietf-lisp-pubsub

Re-,

Please see inline.

Cheers,
Med

De : Eliot Lear [mailto:[email-masked]]
Envoyé : lundi 18 janvier 2021 14:57
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Cc : Luigi Iannone <[email-masked]>; [email-masked]; [email-masked] list <[email-masked]>
Objet : Re: [lisp] WG Last Call for draft-ietf-lisp-pubsub

Hi Med,

Ok, I misread that text as the processing of an error condition.

[Med] We will consider tweaking that text for better clarity.

 This raises a few questions:

What happens if an xTR wants to *add* subscriptions?  Do they just do another map request with the N bit set on new EIDs?

[Med] Yes.

If that same request contains EIDs that had previously had the N bit set but no longer do? Does the ETR just process it as it would have previously and keep sending map updates for those EIDs or is that an error?

[Med] EIDs with N-bit unset will be handled as per the base LISP spec. Given that these EIDs used to have N-bit set, updates will still be notified till the TTL expires for these EIDs and then:

   When the TTL for the EID-record
   expires, the EID-prefix is removed from the Map-Server's subscription
   cache.  On EID-Record removal, the Map-Server notifies the
   subscribers via a Map-Notify with TTL equal 0.
Eliot

On 18 Jan 2021, at 14:48, [email-masked]<mailto:[email-masked]> wrote:

Hi Eliot, all,

The procedure to unsubscribe is covered by the following:

   If the Map-Request only has one ITR-RLOC with AFI = 0 (i.e., Unknown
   Address), the Map-Server MUST remove the subscription state for that
   xTR-ID.

We discussed among the authors back in 2017 whether the procedure should allow to select the EIDs for which an ITR can unsubscribe, but the agreement was to keep the spec simple. Hence the above text.

Cheers,
Med

De : lisp [mailto:[email-masked]] De la part de Eliot Lear
Envoyé : lundi 18 janvier 2021 14:12
À : Luigi Iannone <[email-masked]<mailto:[email-masked]>>
Cc : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]> list <[email-masked]<mailto:[email-masked]>>
Objet : Re: [lisp] WG Last Call for draft-ietf-lisp-pubsub

Just poking my nose in here, this is a cool draft. I say, go for it.  Depending on implementation, it may address the very problem I was attempting to solve with NERD: that first dropped packet.

I have one small suggestion and a question:

The suggestion:

It would be useful to discuss what statistics should be kept when experimenting.  Specifically: number of subscribes (prior to or after the first time one saw an EID), the number of map updates over time (I’m betting there’s a lot of stability out there, but that’s just me), number of subscribers.

The question:

How would an xTR UNsubscribe from mapping notifications?  I would imagine this would amount to a new map request that clears the N bit for appropriate EID-Records?

Eliot

On 13 Jan 2021, at 08:19, Luigi Iannone <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

The authors of  draft-ietf-lisp-pubsub submitted a new version addressing the issues raised during SECDIR review.
The document seems mature and stable and authors are asking for formal WG Last Call.

This email open the usual two weeks Working Group Last Call, to end January 28th, 2021.

Please review this WG document and let the WG know if you agree that it is ready to be handed over to the AD.
If you have objections, please state your reasons why, and explain what it would take to address your concerns.

NOTE: silence IS NOT consensus!

Thanks

Luigi & Joel
_______________________________________________
lisp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lisp

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

---

From: Luigi Iannone <[email-masked]>
Date: Wed, 3 Feb 2021 16:18:29 +0100

Thanks Alberto,

BTW the WG LC ended last week and we received several emails in support of the document, which means that there is consensus to move the document forward.

Thanks to all those that replied and discussed the document.

Ciao

L.

> On 3 Feb 2021, at 04:18, Alberto Rodriguez-Natal (natal) <[email-masked]> wrote:
> 
> New version is up now.
>  
> Alberto
>  
>> On 18 Jan 2021, at 14:48, [email-masked] <mailto:[email-masked]> wrote:
>>  
>> Hi Eliot, all,
>>  
>> De : lisp [mailto:[email-masked] <mailto:[email-masked]>] De la part de Eliot Lear
>> À : Luigi Iannone <[email-masked] <mailto:[email-masked]>>
>> Cc : [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]> list <[email-masked] <mailto:[email-masked]>>
>>> On 13 Jan 2021, at 08:19, Luigi Iannone <[email-masked] <mailto:[email-masked]>> wrote:
>>>  
>>> Hi All,
>>>  
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/lisp <https://www.ietf.org/mailman/listinfo/lisp>
>>