Subject: [lisp] Call for agenda items

From: Luigi Iannone <[email-masked]>
Date: Mon, 5 Jul 2021 08:41:43 +0200

Folks,

During the next IETF, we will have a 1 hours slot

lisp Session 1 (1:00 requested)
 Thursday, 29 July 2021, Session I 1200-1300
 Room Name: Room 5 size: 505
  ---------------------------------------------
iCalendar: https://datatracker.ietf.org/meeting/111/sessions/lisp.ics <https://datatracker.ietf.org/meeting/111/sessions/lisp.ics>

Time is indicated in the Bay Area time zone (PDT / UTC-7)

Please send your requests for agenda items (Presenter’s name, title, slot duration)  to [email-masked] <mailto:[email-masked]> by 13th July.

Ciao

L.

---

From: Sharon Barkai <[email-masked]>
Date: Mon, 5 Jul 2021 14:11:51 +0300

Hi Luigi, 

Im suggesting two agenda items:
As this is a short meeting, the WG item is higher priority.

1. Workgroup item:

The relevance of lisp-bis and lisp-nexagon to the following mobility edge (AECC) key-issues.

- Transient Data Management
- Mobility Geolocation Services
- Mobility Edge Instance Selection
- Mobility Service Continuity 

How and why these drafts are applicable,
 outlook for using extensively in specification. 

2. Non Workgroup item:

Gauging motivation for lisp-fix specification.

Lisp-fix is a contextualized flow information export, using one tangent overlay, on behalf of all the enterprise workgroups, vpns, vlans. 

It is now deployed in over a 100 locations, 
with extensive implementation experience.

The idea is that x% of ipfix sampling on any switch is steered to a specific algorithmically addressable context which performs:

1. Statistical conditional extrapolation from the x% to the 100% of conversational patterns of the workgroup
2. Matching these patterns with known normalized patterns for detecting exceptions:
- post intrusion infiltration lateral movement
-  mis-configurations and unusual behavior 

At least one verified exception is discovered each week in each site. 

The question is if there is group motivation to standardize such a lisp-fix sampling overlay interface:
-  to be supported by switches, routers, vswitches
- as well as eBPF and other OSs standard network extensions.

Thank You,
Sharon

--szb
Cell: +972.53.2470068
WhatsApp: +1.650.492.0794

> On Jul 5, 2021, at 09:42, Luigi Iannone <[email-masked]> wrote:
> 
> 
> Folks,
> 
> iCalendar: https://datatracker.ietf.org/meeting/111/sessions/lisp.ics
> 
> Please send your requests for agenda items (Presenter’s name, title, slot duration)  to [email-masked] by 13th July.
> 
> Ciao
> 
> L.
> 
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Thu, 8 Jul 2021 06:24:55 +0000

Hello Chairs,
We request a slot for the presentation on draft-vgovindan-pim-jp-extensions-lisp. Please see attached email thread for the background context.

Thanks
Prasad
On Jul 5, 2021, at 09:42, Luigi Iannone <[email-masked]<mailto:[email-masked]>> wrote:

Folks,

Please send your requests for agenda items (Presenter’s name, title, slot duration)  to [email-masked]<mailto:[email-masked]> by 13th July.

Ciao

L.

_______________________________________________
lisp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lisp

Subject: Re: draft-vgovindan-pim-jp-extensions-lisp
From: Luigi Iannone <[email-masked]>
To: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Cc: "Joel M. Halpern" <[email-masked]>, Michael McBride <[email-masked]>, Stig Venaas <[email-masked]>
Date: Thu, 1 Apr 2021 07:36:27 +0000

Hi,

> On 30 Mar 2021, at 09:42, Vengada Prasad Govindan (venggovi) <[email-masked]> wrote:
>
> Hello Joel/ Luigi,
>  Thanks for your comments, I can start a email thread outlining the background of the draft. The base idea of the draft is an extension of the RLOC receiver TLV specified in RFC8059. While RFC8059 defined the TLV for Ingress Replication (LISP Multicast over Unicast tunnels), the new draft tries to define TLVs needed for LISP multicast over Native multicast. The motivation for the TLV and the problem statement can be explained in an email to LISP WG. As suggested, this can be considered as a topic of discussion for the upcoming LISP WG interim. Can you please share the date(s) ?
Actually we have no interim meeting planned, I was referring to IETF 111 :-)

> On a separate note, it was discussed that this draft should be progressed in the PIM WG but after the LISP WG is convinced about the genuineness of the problem statement and the proposed solution. Stig pointed out during the IETF PIM WG discussion, that RFC8059 was progressed in a similar way.

Sure. The LISP WG can provide feedback on the LISP part, and it is a very good idea to have some discussion in the LISP WG.
Then, the document can progress in the PIM WG, since it does not involve any specific change in LISP.

Ciao

L.

> Thanks Mike and Stig for facilitating this discussion.
> Thanks
> Prasad
>
> -----Original Message-----
> From: Luigi Iannone <[email-masked]>
> Sent: Tuesday, March 30, 2021 12:32
> To: Joel M. Halpern <[email-masked]>
> Cc: Michael McBride <[email-masked]>; Vengada Prasad Govindan (venggovi) <[email-masked]>; Stig Venaas <[email-masked]>
> Subject: Re: draft-vgovindan-pim-jp-extensions-lisp
>
> Hi,
>
> I am also unsure were it belongs, however it is an excellent idea to make the LISP WG at least aware of this proposal
>
> May be some people get interested and will help :-)
>
> We can certainly give presentation time at next meeting, in the meantime feel free to start a discussion on the mailing list if you wish.
>
> Ciao
>
> L.
>
>
>
>> On 30 Mar 2021, at 00:16, Joel M. Halpern <[email-masked]> wrote:
>>
>> Looking at the draft, it is unclear where it belongs.
>> I may be misreading it, but it looks like it uses RFC 6831 verbatim, and asks for changes to PIM messages.
>> The LISP WG would not be the place to craft modifications to PIM.
>>
>> Prasad is certainly welcome to bring the draft up on the LISP email list, and explain what LISP issues it may have.  In particular, for the LISP WG, a better explanation than I can find about the relationship between the LISP topology and the PIM topology would be helpful.
>>
>> Yours,
>> Joel
>>
>> On 3/29/2021 5:52 PM, Michael McBride wrote:
>>> Hi lisp chairs,
>>> Prasad present this draft in our pim meeting at 110. He will request to present this in lisp at your next meeting. Here are the minutes from our meeting:
>>> draft-vgovindan-pim-jp-extensions-lisp - Prasad Govindan Stig -
>>> better to have a new attribute instead of overloading the existing one.
>>> Acee - whats the relationship with the lisp wg? Where should this be progressed? It's sort of like mvpn and bess owns that. This should be owned by lisp.
>>> Prasad - yes should be presented in lisp next wg. Should be progressed in lisp or pim? The type he is proposing is similar to the unicast type.
>>> Mike - the lisp charter calls out multicast and pim so they may want to work on this, Definitely need to coordinate with them.
>>> Alvaro - The difference between this and mvpn is the details. This is a very short draft to request the new type. Coordinate with lisp, will need to add more details. If they want it and we can give them a type then its ok to progress it in pim if that's all that the draft will say.
>>> Stig - exactly what happened last time, main work done in pim but also discussed in lisp to make sure they thought it was a good idea.
>>> Sandy - is this for *,g and/or s,g.
>>> Prasad - both.
>>> Mike - We will reach out to lisp chairs.
>>> Alvaro - lisp didn't meet this week but will have an interim so please present there.
>>> Maybe best to discuss after he introduces this in lisp. So just a heads up that this draft exists and we may need to decide in the future where the work is progressed.
>>> mike
>