Subject: [lisp] Reliable Transport issue - do you try UDP or TCP or both?

From: Dino Farinacci <[email-masked]>
Date: Fri, 12 Nov 2021 13:52:58 -0800

Regarding the Luigi comment, I didn't understand Marc's response. Simply getting a Map-Notify doesn't tell the ETR if it should try a opening a TCP connection to the Map-Server.

I would suggest this simple signalling scheme:

(1) Since we have bits in the Map-Register header that the ETR can set. It sets a new "RT" bit to indicate to the Map-Server that it wants to use TCP.

(2) If the Map-Server sends a Map-Notify (with the "RT" bit set, ie. copied from the Map-Register), then the ETR knows the Map-Server is listening on TCP port 4342 and will accept TCP connections.

(3) If the Map-Server does not support RT, it sets the "RT" bit to zero. Which is its default setting because either an new implementation doesn't want to (so it clears the bit in the Map-Notify) or an old implementation doesn't know anything about the bit so it would default to 0.

Comments?

Dino

---

From: "Marc Portoles Comeras (mportole)" <[email-masked]>
Date: Mon, 15 Nov 2021 06:01:28 +0000

I would incorporate this proposal in the draft.

For now, in the current implementation, the ETRs are just "guessing and trying". As you say there is nothing in the Map-Notify telling the ETR if the MS can support the TCP connection. 
This signaling scheme would clear this part and remove this guesswork on the ETR.

Should we allow the Map-Server to set the RT bit even if the ETR has not requested it?

Marc

On 11/12/21, 1:53 PM, "lisp on behalf of Dino Farinacci" <[email-masked] on behalf of [email-masked]> wrote:

Comments?

Dino
_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Sun, 14 Nov 2021 22:06:26 -0800

Guessing and trying can work because if you try to SYN on port 4342, you’ll get a RST or ICMP port unreachable back. That is if it gets back to you. 

Dino

> On Nov 14, 2021, at 10:01 PM, Marc Portoles Comeras (mportole) <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Sun, 14 Nov 2021 22:07:51 -0800

> Should we allow the Map-Server to set the RT bit even if the ETR has not requested it? 

I guess. That is if you want to tell the xTR that you support it even if it does t request it. 

Dino