Subject: [lisp] Suggestion to use site-id for a L2 segment-id

From: Dino Farinacci <[email-masked]>
Date: Fri, 12 Nov 2021 13:33:01 -0800

Luigi made this suggestion at the working group. 

You cannot use site-id because all the L2 sites are part of the same L2 network need the same value. And instance-ID is the only value that can be used since it is in the encapsulated header. You need to use instance-ID so multi-tenancy can be used. Because each site can be part of multiple VLANs which may partially reside in other sites (i.e. site-id A has VLANS (1,2,3), but site-id B has VLANS (1,2) and site-id C has VLANs (1,3))

Dino

---

From: "Marc Portoles Comeras (mportole)" <[email-masked]>
Date: Mon, 15 Nov 2021 06:02:13 +0000

Dino,

In this case, couldn't we use the pair <site-id, IID> to identify xTRs that form a multihoming group? Or we'd need some extra identifier? 
Do you see a case when we have xTRs using different site-ids but providing L2 multihoming to a common group of endpoints?

Thanks,
Marc

On 11/12/21, 1:33 PM, "lisp on behalf of Dino Farinacci" <[email-masked] on behalf of [email-masked]> wrote:

Dino
_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Sun, 14 Nov 2021 22:11:42 -0800

> In this case, couldn't we use the pair <site-id, IID> to identify xTRs that form a multihoming group? Or we'd need some extra identifier? 

There is no point. Then you would have to store n site-ids for no use. 

> Do you see a case when we have xTRs using different site-ids but providing L2 multihoming to a common group of endpoints?

That is a misconfiguration, if it is one host. Otherwise the MAC EID moved to a new site. 

Doesn’t matter what the site-id is in the move case, you know from a new RLOC registered. 

Dino