Subject: [lisp] LISP Nexar comment 2

From: Dino Farinacci <[email-masked]>
Date: Fri, 12 Nov 2021 14:24:48 -0800

From my understanding of the use-case, I believe there are no changes to the base protocol to support this use-case. Regarding EID assignment and allocation, that is an admin/configuration function.

H3-EIDs makes sense for assigning to nodes that provide services. But I forget if you wanted to allocate an H3-EID to a moving vehicle. Because as the EID moves, the H3 hexagon can change even the H3-ID is from resolution 16. Unless you want to scope the mobility and when the vehicle moves, you assign a new H3-EID. I hope you don't do thw latter or you lose the EID-mobility features LISP has (or maybe don't need it in this case).

Dino

---

From: Sharon Barkai <[email-masked]>
Date: Fri, 12 Nov 2021 14:49:02 -0800

1. The Edge Geolocation Services EIDs have a 64bit H3-ID part of the location of the Vehicle being served

2. This is how we eliminate the need for an actual geospatial network. These are virtualized in the form of H3EIDs

3. The prefix of the service EID is the H3 location it serves, the suffix is the specific Geolocation Service: collection, parking ..

4. The vehicle EID is not related to location (H3) because its moving. It is however ephemeral to protect drivers geoprivacy

5. The only entity which knows the vehicle carrier assigned RLOC is its RTR. We can host those at the carrier (UPF) or bring your own

6. Both lisp-nexagon and lisp-fix do not change the protocol. But you do have to understand the map assisted overlay ucast/mcast

7. Maybe after more examples we can generalize how Compute First Networks use LISP to aggregate and reduce data on a need to know basis.. 

..so that non lispers can follow a cookbook, but for now we need to do it example at a time i think. lisp-nexagon in publication lisp-fix-00 i think work group response was good, so by next ietf?? 

--szb
Cell: +972.53.2470068
WhatsApp: +1.650.492.0794

> On Nov 12, 2021, at 14:25, Dino Farinacci <[email-masked]> wrote:
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 12 Nov 2021 15:03:53 -0800

> 2. This is how we eliminate the need for an actual geospatial network. These are virtualized in the form of H3EIDs

Okay, so "Geolocation Services EID" equals an H3EID.

> 3. The prefix of the service EID is the H3 location it serves, the suffix is the specific Geolocation Service: collection, parking ..

Right, thought so.

> 4. The vehicle EID is not related to location (H3) because its moving. It is however ephemeral to protect drivers geoprivacy

Good.

> 5. The only entity which knows the vehicle carrier assigned RLOC is its RTR. We can host those at the carrier (UPF) or bring your own

Great.

> 6. Both lisp-nexagon and lisp-fix do not change the protocol. But you do have to understand the map assisted overlay ucast/mcast

I don't understand what you mean. Say more please.

> ..so that non lispers can follow a cookbook, but for now we need to do it example at a time i think. lisp-nexagon in publication lisp-fix-00 i think work group response was good, so by next ietf?? 

Yes.

Dino

---

From: Sharon Barkai <[email-masked]>
Date: Fri, 12 Nov 2021 17:02:55 -0800

> On Nov 12, 2021, at 15:04, Dino Farinacci <[email-masked]> wrote:
> 

I mean, if you didn't know LISP, you would need to  reinvent its mechanisms, the layering, the mapping, the signal-free… per app domain, the hard way, proprietary..

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 12 Nov 2021 17:11:03 -0800

Well you just need to list the features LISP-fix and LISP-nexagon need and you state what mechanisms in LISP deliver those features. I think you have done that in the drafts.

Dino

> On Nov 12, 2021, at 5:02 PM, Sharon Barkai <[email-masked]> wrote:
> 
> 
>

---

From: Sharon Barkai <[email-masked]>
Date: Sat, 13 Nov 2021 08:52:45 -0800

Yes i think you are right.
Any attempt to generalize at this point will probably fail.

--szb
Cell: +972.53.2470068

> On Nov 12, 2021, at 17:11, Dino Farinacci <[email-masked]> wrote:
>