Subject: [lisp] LISP standardization request from ICAO WG-I

From: "Gulam, Raza Ali" <[email-masked]>
Date: Thu, 7 Apr 2022 22:02:07 +0000

Dear All,

WG-I is a working group of the ICAO (International Civil Aviation Organization) Communications Panel and is concerned with the standardization of ATNIPS for safety-critical IPv6 communications in aviation.
The necessary data communication protocols and services are defined in Doc 9896 - Manual on the Aeronautical Network (ATN) using Internet Protocol Suite (IPS) Standards and Protocols.
For the realization of the mobility and multilink functionality, Doc 9896 Edition 3 proposes a solution that uses LISP as the base technology. Such base technologies must be mature and should be based on IP standards.
This results in the following standardization request:
The ICAO WG-I requests the IETF to complete the standardization for the LISP control and data plane draft protocols (draft-ietf-lisp-rfc6830bis and draft-ietf-lisp-rfc6833bis) by the third quarter of 2022
so that the corresponding RFC standards can be referenced in Edition 3 of the ICAO Doc 9896.

If you need any further information please contact the undersigned.

Thank you,

Yours sincerely,

Raza Gulam
Secretary, Data Communications Infrastructure
Specific Working Group of the Communications Panel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 8 Apr 2022 11:14:09 -0400

Thank you for your interest in the LISP work.

First, I recommend that anyone interested in IETF work read 
https://www.ietf.org/tao.html as that will give you a better 
understanding of the IETF process.

The IETF is in the process of moving the base LISP specifications from 
experimental to Proposed Standard.  While I can not promise when that 
will happen, we certainly hope it will be completed before 3Q2022.
Note that if the documents are approved, but have not yet been published 
as RFCs, there are ways we can get you the RFC numbers.
But until the approval process is complete we can not commit to anything.

Yours,
Joel

On 4/7/2022 6:02 PM, Gulam, Raza Ali wrote:
> Dear All,
> 
> WG-I is a working group of the ICAO (International Civil Aviation 
> Organization) Communications Panel and is concerned with the 
> standardization of ATNIPS for safety-critical IPv6 communications in 
> aviation.
> 
> The necessary data communication protocols and services are defined in 
> Doc 9896 - Manual on the Aeronautical Network (ATN) using Internet 
> Protocol Suite (IPS) Standards and Protocols.
> 
> For the realization of the mobility and multilink functionality, Doc 
> 9896 Edition 3 proposes a solution that uses LISP as the base 
> technology. Such base technologies must be mature and should be based on 
> IP standards.
> 
> The ICAO WG-I requests the IETF to complete the standardization for the 
> LISP control and data plane draft protocols (draft-ietf-lisp-rfc6830bis 
> and draft-ietf-lisp-rfc6833bis) by the third quarter of 2022
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 8 Apr 2022 08:23:45 -0700

[Thank you Joel!]

Dear Mr. Gulam:

As Joel explains, the IETF process is not deterministic.

To help me better understand ICAO’s requirements, I have a couple of
questions.  We may be able to have an RFC number for you sooner than a
published document — would that be enough?  The expectation would be to
have a published document soon after. Also, do you need the number by the
start of Q3 (July), or is there some flexibility.

Thank you!

Alvaro.
(Routing Area Director — responsible for the lisp WG)

On April 8, 2022 at 11:14:21 AM, Joel M. Halpern ([email-masked])
wrote:

Yours,
Joel